1. Check out our companion app, Forums for Android! Download from Google Play

Root Broke contacts app when uninstalling Yahoo

Discussion in 'Android Devices' started by Jerm13, Sep 11, 2011.

  1. Jerm13

    Jerm13 Well-Known Member
    Thread Starter
    16

    Nov 16, 2009
    71
    7
    16
    Ok, so I got a little overeager with my root powers. I uninstalled a few things, including Yahoo Contacts and Yahoo! Mail Authenticator. Of course this leads to the contacts app force closing every time. Who would have thought Yahoo was integral to the phone...

    But, I'm not completely stupid! I did back up the apps with Titanium before I uninstalled them. However, they won't reinstall. The Titanium window pops up "Restoring App" and just runs indefinitely, never completes.

    Are the backups corrupt? Is there another way to get them back?


    I've learned my lesson and am only freezing things now, but I'd love to get this issue repaired.
     

    Advertisement

  2. messenger13

    messenger13 Well-Known Member
    163

    Dec 8, 2009
    3,133
    381
    163
    Director of IT
    Cleveland, OH
    Holy crap! I just created a post about this VERY issue. I found out it was only the Yahoo! Mail Authenticator causing the issue.

    I'll dig in and see if I can't send you the files you need using Root Explorer and install them that way ... including the proper permissions. That should work.
     
  3. messenger13

    messenger13 Well-Known Member
    163

    Dec 8, 2009
    3,133
    381
    163
    Director of IT
    Cleveland, OH
    OK, for the first attempt, try installing these two files in the /system/app folder ... with permissions set to rw-r--r-- (like all the rest).

    I needed to change the file names so I could attach them to this post. Just remove the ".pdf" at the end of each filename.

    HTH
     

    Attached Files:

  4. Jerm13

    Jerm13 Well-Known Member
    Thread Starter
    16

    Nov 16, 2009
    71
    7
    16
    Thanks for the files!

    I copy and paste them into the /system/app folder and set the permissions correctly.
    Is there more to it then that? I'm not a big root explorer veteran.
    I'm hoping there's more to it because that's still not working after running fix permissions and a reboot....
     
  5. messenger13

    messenger13 Well-Known Member
    163

    Dec 8, 2009
    3,133
    381
    163
    Director of IT
    Cleveland, OH
    Unfortunately, you did exactly what I would've done. Still no good huh? Bummer. I'll let know know if I think of anything else.
     
  6. Jerm13

    Jerm13 Well-Known Member
    Thread Starter
    16

    Nov 16, 2009
    71
    7
    16
    Haha! Finally got it!

    Someone over at XDA posted a zip of allll the required files for Contacts to run properly so I DLed that and copied into system/app.

    After manually going thru the entire list and fixing permissions on everything that was off, problem was solved after a reboot.

    I guess I must have hurt something else besides the Yahoo in my initial uninstall flurry.

    But, thanks for the help!
     
  7. flyfishin69

    flyfishin69 New Member
    5

    Sep 11, 2011
    2
    0
    5
    Pa
    Would you happen to have more information on these zip files xda? Thanks
     
  8. messenger13

    messenger13 Well-Known Member
    163

    Dec 8, 2009
    3,133
    381
    163
    Director of IT
    Cleveland, OH
    Do you have a link?
     
  9. Jerm13

    Jerm13 Well-Known Member
    Thread Starter
    16

    Nov 16, 2009
    71
    7
    16
    flyfishin69 likes this.
  10. flyfishin69

    flyfishin69 New Member
    5

    Sep 11, 2011
    2
    0
    5
    Pa
    Yes I deleted files like yahoo and myspace and twitter by mistake when first rooting my BiONiC
    and promply game the force close on contacts when trying to edit.

    I copied the following from fixcontacts.zip from droidforums.net. Sorry not sure if this is politically correct to post where I got it from.
    So i copied it over and made changes with Root Explorer (Best 3.99 i've spent)


    /system/app/blur_yahoo.apk
    /sytem/app/blur_yahoo.odex
    /system/app/com.motorola.blur.provider.yahoo.apk
    /system/app/YahooContacts
    /system/app/YahooContacts.apk
    /system/app/YahooContacts.obex

    and also

    the two

    Blur_twitter.odex
    Blur_twitter.apk

    Changed permissions checkmarked (Owner) Read Write
    Changed permissions checkmarked (Group and Other) to Read only
    Changed Owner to root for both files.

    IT WORKED!!! I now can edit my contacts. and no Force Closes.
     
  11. 71ValiantSRT-4

    71ValiantSRT-4 Active Member
    15

    Mar 17, 2010
    33
    0
    15
    It keep trying to install these files and the phone keeps saying not installed?? Wtf am I doing wrong???
     
  12. ascottsman333

    ascottsman333 Member
    5

    Sep 17, 2011
    7
    0
    5
    New York
    I froze Yahoo contacts and NOT the mail auth, and no issues.
     
  13. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Re-read the quotation

    You don't install them. You have to manually move the files back into the folder, and you have to change permissions as well.

    I highly suggest that you spend a lot more time reading and a lot less time jumping up to do something without fully understanding the steps. I'm not trying to be a jerk, but I am trying to save you a lot of frustration and heartache - and this is one sure fire way to start messing your phone up, by not reading steps carefully and performing them according to what you are used to doing on another phone.
     
  14. cwaddell2

    cwaddell2 New Member
    5

    Sep 19, 2011
    1
    0
    5
    Can anyone assisnt in explaining how to move the files into these system folderS??

     
  15. bballer67

    bballer67 New Member
    5

    Nov 7, 2011
    3
    0
    5
    I copied all files the the Fix Contact.zip and set permissions to R/W for user and only read for others. I can now view contact information but I still cant add new contacts. Any ideas? Are these files for android 2.3.3?
     
  16. bballer67

    bballer67 New Member
    5

    Nov 7, 2011
    3
    0
    5
    Sorry if this sounds noobish, but how do i set owner to root for those files.
     
  17. yaknow05

    yaknow05 New Member
    5

    Nov 6, 2011
    2
    0
    5
    it says they are read only files, so i cant move/copy those files over to sys/app folder. also, how do i edit permissions? i click on properties and the only option i can click is "OK"
     
  18. OutOfPhase

    OutOfPhase Premium Member
    523

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    you need root explorer from the market Here. Along the top it says mount r/w click that. Then go to the file you want to change permissions long press it and you will see an option for permissions.
     
  19. mrdancheck

    mrdancheck Member
    5

    Feb 19, 2012
    5
    0
    5
    So I followed the instructions line by line and i STILL can't add to contacts..

    Any ideas out there.. Is there away to just rewrite the OSJ and Start over ?
     
  20. OutOfPhase

    OutOfPhase Premium Member
    523

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    You can reflash the OS and start over but it will wipe everything.
     
  21. mrdancheck

    mrdancheck Member
    5

    Feb 19, 2012
    5
    0
    5
    At this point I'm fine with that.. How do I go about doing a reflash of the OS?
     
  22. OutOfPhase

    OutOfPhase Premium Member
    523

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL

    There is a thread on how to flash 5.5.893 or 5.9.902 with rsdlite. This will give out all the files and info on how to do it.

    how to flash 5.5.893 or 5.9.902 with rsdlite
     
  23. mrdancheck

    mrdancheck Member
    5

    Feb 19, 2012
    5
    0
    5
    Thanks for the Link..
    Will this Flash Bring back the Yahoo Apps I need to make my contacts work?
    Is flash 5.5.893 or 5.9.902 an older OS ? I've got a Razr MAxx it's got 6.12.173. I took this thing out of the box 2 days ago. Everything has been great on the phone except this Contact issue..
     
  24. OutOfPhase

    OutOfPhase Premium Member
    523

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL

    Flashing the fxz will be like getting it out of the box again. 5.9.902 is the latest ota.
     
  25. SNeitzel

    SNeitzel Well-Known Member
    93

    Aug 11, 2010
    637
    102
    93
    NO!!! STOP!!! WAIT!!!
    You mention having a Razr MaXX, the .fxz files you and dfib mention are for the Bionic and ONLY the Bionic.

    You need to find .fxz files specifically for the Razr Maxx.
     
    tehsusenoh and OutOfPhase like this.

Share This Page

Loading...