1. Are you ready for the Galaxy S20? Here is everything we know so far!

Broken radio(s) after OTA on unlocked phone? Look here...

Discussion in 'Android Devices' started by Apache Thunder, Jun 12, 2012.

  1. Apache Thunder

    Apache Thunder Android Enthusiast
    Thread Starter

    If you unlocked your bootloader and rooted the phone since you got it and performed the OTA update released this month (after reinstalling stock recovery since OTA updates won't work if CWM in installed), there is a high probability that you will encounter a bug in Android resulting in 4G and/or Wifi refusing to turn on. I have found that the problem is caused by the old kernel not getting along with the updated android OS.

    It seems that even stock recovery can not flash custom radios or kernels to the phone once the phone has been unlocked. OTA updates use the stock recovery rom when performing updates and does not use hboot.

    Even relocking the phone will not work. I found that flashing the boot.img that came with the OTA update using hboot, the broken radio issue is resolved indicating a successful kernel update. Thus hboot is currently the only way to write custom radios and kernels (even official ones) to the phone. Once s-off exploit is found, you won't have to use hboot to flash kernels and radios. But until then, this will be the only way to apply an OTA update correctly.

    I have provided the modified PH44IMG that includes the new boot.img that I grabbed from the OTA update file.

    So here's the instructions on how to fix the wifi/4g problem.

    1. Reinstall stock recovery and perform the OTA update. You do NOT need to re-lock the bootloader as it won't make a difference. If you get the red triangle error when the update tries to install, ensure that you reinstalled all bloatware (so I hope you backed them up) and have fixed permissions using CWM prior to installing stock recovery since permissions may be another factor in the cause of the red triangle error.

    You do not need to unroot the phone. Though root will initially stop working after the OTA update, just reroot at the end of this guide as directed and your root access should be restored.

    2. After the OTA finishes, download the provided PH44IMG archive and place it at the root of the SD card for your phone. Rename the file so that "boot_" is not part of the filename since otherwise hboot will not recognize it.

    3. Allow hboot to flash the archive. Once it completes you can delete the ph44img zip file as it is no longer needed (and will prevent normal operation in hboot if you leave it there).

    4. Reboot phone. Be sure that the cached OTA update zip is deleted from your SD card otherwise you'll get a false positive on another update if you do a manual update check.

    5. Turn on 4G/wifi.

    6. Profit. :D


    Download link:

    Boot_PH44IMG.zip

    Feel free to report any issues or if you have any questions.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. zombu2

    zombu2 Well-Known Member


    Perfect!!!

    Thnx for finding that out . now we need custom kernels hehe
     
  3. guyphs

    guyphs Android Enthusiast

    Awesome! Worked like a charm! Thanks for figuring that out
     
  4. Apache Thunder

    Apache Thunder Android Enthusiast
    Thread Starter

    For some odd reason when I went to the system updates menu, it wanted to push the same OTA update I had already installed to it all over again. So I reinstalled bloatware and reinstalled stock recovery and let it do it a second time. (Did not run into issues with the radios since the kernel was indeed already up to date)

    After that I reinstalled cwm and root and now the phone correctly shows that it's up to date.

    Perhaps the cached update was still in my sd card's download folder and it decided to think there was an update (When it asked me again to do the OTA update, I don't recall it wanted to download it, so it already had it downloaded).

    In which case double check that the update zip it downloads to your sd card is removed after the OTA update otherwise when you go to the update screen again you'll get a false positive on another phone update. :p

    Pretty much all the version strings in the about phone information matched what was in the OTA update, so my guess was for some reason the OTA update zip was still on my SD card. :p
     
  5. joshua.worth

    joshua.worth Android Enthusiast

    It even tried to update my Hero S lol [​IMG]
    But thankfully HTC is a bit more intelligent nowadays
    [​IMG]
     
  6. zombu2

    zombu2 Well-Known Member


    so in other words

    come install our update so we can remove your root and do something else to it so you can t reroot hahahaha

    nice try HTC

    i will call em later and ask for help reverting my phone

    What you mean HTC android..... i got a nokia 5120.......
     
  7. joshua.worth

    joshua.worth Android Enthusiast

    Flashing SU in recovery is going to work for awhile.
     
  8. zombu2

    zombu2 Well-Known Member


    yeah i was just beeing sarcastic on HTC

    cmon my new notification is hillarious
     
  9. guyphs

    guyphs Android Enthusiast

    I laughed
     
  10. netmedic1

    netmedic1 Lurker

    Please help. I tried this, but at HBoot, I got "Update: Fail" due to it being an older version. Any thoughts. Phone is about a month old running ICS 4.0.3, rooted and unlocked. Any help would be appreciated.

    Thanks,

    Net
     
  11. Apache Thunder

    Apache Thunder Android Enthusiast
    Thread Starter

  12. netmedic1

    netmedic1 Lurker

    That worked. Thanks for the help. Its appreciated.

    Net
     
  13. netmedic1

    netmedic1 Lurker

    So hopefully, this will be the last question I have on this issue. The version fix worked as did fixing the wifi "error". I just realized that I have lost root access even though I still have superuser installed and my bootloader is unlocked and I still have CWM. How do I get root back?
     
  14. Apache Thunder

    Apache Thunder Android Enthusiast
    Thread Starter

  15. nitroboss

    nitroboss Lurker

    hey tanks for the great toturial :D
    but i had a problem i have my htc evo design 4g sprint with android 2.3.4 stock, no rooted, no unlocked bootloader and i have no problem with that but 2 weeks ago i recieved the ota update to 4.0.3 and at this time all was great but 4 days ago my wifi turn off by itself so i thought maybe the battery was low so i didnt gave importance. next day i check my wifi settings and it said
    Wifi off and turned on and it got stucked in turn on. sometimes says wifi error.
    evereything else works great
    please help me i try everything not nothing works i do what you say on this tutorial but when i try to flash the PH44IMG.zip says something like CID error press power to reboot
    thnx please help im rooky at this
     

HTC EVO Design Forum

The HTC EVO Design release date was October 2011. Features and Specs include a 4.0" inch screen, 5MP camera, 768GB RAM, Snapdragon S2 processor, and 1520mAh battery.

October 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...