Browser issues & user agent confusion


Android Enthusiast
Ran across issues with my web browser and certain pages and hoping someone can help me sort it out. I've been using Dolphin Browser as my default for almost two years but only started having these issues this week.

When I go to a Tumblr page there's a button at the top that says "Open in App". When I hit it, instead of launching the app I get a prompt to choose which app to use and the options are Dolphin, stock browser or Google Play Store. Which ever one I select it opens to the Play Store page to the Tumblr app, which I already have installed. It doesn't actually launch the Tumblr app. After fiddling around with it for a while, I discovered that if I change User Agent to "iPhone", the "Open in App" link automatically launches the Tumblr app. The thing is, I know that this worked under Android user agent before, as little as a week or so ago. But I don't know if something changed on my phone or on the website that prevents it from opening the Tumblr app automatically now.

Another thing I just came across this morning involves Instagram video pages. I clicked on a link to an Instagram video from within Twitter. Dolphin launched & the page loaded but I could not see the video. Just a blank space where it should be. I changed the browser User Agent to "iPhone" and reloaded the page and the video loaded and played fine. I have the latest Instagram app update and videos play fine in that as well.

I'm using an HTC Inspire so I'm still running Gingerbread. I installed Firefox, Opera & Boat browsers as well to test and they too do the same thing. So is this an issue with the coding of the webpages? If so, wouldn't all Android users run into these issues? Tried searching for info but didn't see anything. Seems more likely that I'm missing something on my phone or need to change something that would allow these pages to work properly? These aren't huge issues that I can't work around, but it's just a bit annoying when seemingly simple things don't work as they're supposed to.

Any insight and suggestions are much appreciated.