1. Download our Official Android App: Forums for Android!

Support Browser "talkback"

Discussion in 'Android Devices' started by mildot, Dec 20, 2011.

  1. mildot

    mildot Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    3
    0
    5
    Hi guys and gals!

    I got a Galaxy Nexus a few days, and I am loving this phone! I do have one annoying issue, that I'm sure is an easy fix. I just can't seem to figure it out, so I though I would ask here for help.

    When using the browser, it likes to "talk back" to me, repeating everything I type and it sometimes tries to read the page for me. This talk back only occurs when using the browser. Even when the phone is on silent mode, it still "talks back" to me. This is particularly annoying for me, and for others around me. I would love to be able to surf the internet in silence!

    I have already gone under the 'Accessibility' in Settings, and TalkBack is not turned on. I have also checked under the browser settings, but can't seem to find anything there for a TalkBack setting.

    Any help is appreciated!
     

    Advertisement

  2. RedheadRachel

    RedheadRachel Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Nov 18, 2011

    Nov 18, 2011
    4
    7
    6
    Maryland
    Did you try disabling the app?
    Go to Settings > Apps > All >TalkBack > Disable

    I haven't had this issue, so I'm not sure if that'll work, but it's worth a shot!
     
  3. mildot

    mildot Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    3
    0
    5
    Tried it, unfortunately that didn't work :(
     
  4. dyno

    dyno Member
    Rank:
    None
    Points:
    38
    Posts:
    65
    Joined:
    Jul 5, 2010

    Jul 5, 2010
    65
    12
    38
    Do you have Light Flow installed? This was happening to me with Light Flow, the only option is to uninstall it. Even with Talkback disabled from apps and accessibility, it was still active. I have contacted the dev and he is aware of the problem. It doesn't seem to effect everyone.
     
    mildot likes this.
  5. mildot

    mildot Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    3
    0
    5
    Yes I do have light flow installed. Interesting. Hopefully that gets fixed, I don't want to get rid of light flow. Thanks!
     
  6. andrewpmoore

    andrewpmoore Well-Known Member
    Rank:
    None
    Points:
    23
    Posts:
    75
    Joined:
    Apr 15, 2010

    Apr 15, 2010
    75
    30
    23
    I've had a handful of reports of this. There's nothing directly in lightflow that should be causing this (or even possible of doing this - as accessibility services need to be manually turned on for security purposes)

    I've raised a bug in android for it: Issue 23105 - android - Wrong accessibility service running in ICS when user selects another service - Android - An Open Handset Alliance Project - Google Project Hosting

    Could you "star" it and add a comment. I'm keen for a fix for this myself. There's about 10,000 people using lightflow (mostly the lite version) on the galaxy nexus (myself included) and I've had about 10 reports of this.

    I would be tempted to try install another app that uses accessibility (e.g. LED me know) and have a play around to see if you get the problem with that.

    Try toggling on and off the differences accessibility services to see if it helps.
    Cheers
    Andrew
     
  7. pool_shark

    pool_shark Android Expert
    Rank:
     #74
    Points:
    343
    Posts:
    2,520
    Joined:
    Aug 21, 2010

    Aug 21, 2010
    2,520
    578
    343
    Male
    Infrastructure Engineer
    Ohio
    It has nothing to do with light flow.
    Disable web scripts in accessibility.
     
    jimenezla and dyno like this.
  8. dyno

    dyno Member
    Rank:
    None
    Points:
    38
    Posts:
    65
    Joined:
    Jul 5, 2010

    Jul 5, 2010
    65
    12
    38
    I disabled like you said, and yes it works. What do the web scripts actually do? Will I be missing something now on the browser?
     
  9. pool_shark

    pool_shark Android Expert
    Rank:
     #74
    Points:
    343
    Posts:
    2,520
    Joined:
    Aug 21, 2010

    Aug 21, 2010
    2,520
    578
    343
    Male
    Infrastructure Engineer
    Ohio
    From what I can tell you won't miss anything. I enabled it hoping it would fix the javascript problems, that's when I learned it makes the phone speak when using the browser.
     
  10. mistermojorizi

    mistermojorizi Android Enthusiast
    Rank:
     #161
    Points:
    93
    Posts:
    500
    Joined:
    Oct 26, 2011

    Oct 26, 2011
    500
    178
    93
    one or the other for me. If both are on then it starts reading everything
     
  11. ShaiMon

    ShaiMon Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Dec 20, 2016

    Dec 20, 2016
    1
    0
    15
    Male
    What is light flow...
     
Tags:

Share This Page

Loading...