1. Are you ready for the Galaxy S20? Here is everything we know so far!

buyer beware: SanDisk class 10 32 gb does not work well with the triumph

Discussion in 'Android Devices' started by cased3448, Dec 17, 2012.

  1. cased3448

    cased3448 Newbie
    Thread Starter

    Hey guys,

    So I've done extensive testing ever since swapping in a new sandisk 32 gb sd card I bought on amazon. I cant link yet but the exact product is:
    SanDisk Ultra 32 GB MicroSDHC Class 10 UHS-1 Memory Card with Adapter (SDSDQU-032G-AFFP-A)

    I cannot flash roms using this card or restore a nandroid. It basically bricked my phone, and I ran here to get help a few days ago (got that fixed after I started using my old sdcard)I thought its because I was formatting the 32gb card on my computer so I tried to format it in my phone, it took forever and resulted in a "damaged" card (lots of folders with weird symbols show up when I reinsert the card into the computer).

    When I try to use a rom, which was stored in internal memory after it was flashed from my older sd card, many apps force close (especially google services framework, which is critical... and i need to reboot with a battery pull) and the phone itself is very sluggish and feels unstable.

    As soon as I pop in my really old 2 gb class 4 sdcard, or even my 8gb class 6 sdcard, the phone works normally.

    I am using the U9000 ROM, but the issue occurs in cm7 and sharp rom.

    Do others have issues with this card, or did I get a defective one? If so how do I return it/replace it because I threw away the packaging thinking I that a brand new SanDisk card sold via Amazon could not possibly be faulty.

    However, the card works just fine and is super fast if I use it as a normal sdcard for just the computer. I got the "frustration free" shipping option since its cheaper, not sure if the retail packaging version would be different.

    1. Download the Forums for Android™ app!


  2. MikeRL

    MikeRL Android Enthusiast

    I've had an sdcard brick my Triumph two times actually. Both times I had formatted it in Linux. Strangely, when I formatted it in Windows everything worked like a charm. Also, never format an sdcard for this phone on Linux. I do not know why doing that bricks our phone.
  3. Prepaidguy9081

    Prepaidguy9081 Android Enthusiast

    Sounds like lamesauce. That bites
  4. odojoe

    odojoe Well-Known Member

    I have had a Sandisk 32 gig since April with no issues. My version is SDSDQM-032G-B35.

    And that is with CM7, CM9, U-9000, and Sharp with CWM and TWRP.
  5. TheBritton

    TheBritton Resident Galaxy Cat

    I had a Sandisk 32gb sd card when I had this phone for months and it worked great.
    I ran into issues using it later on in my new phone (due to unpartitioning and reformatting it with windows since I didn't need Link2SD anymore) but a pc app made by Sandisk called "SD formatter" not only made the card usable again but it also showed faster reads.
  6. cased3448

    cased3448 Newbie
    Thread Starter

    Hmm that is a class 4 32gb card. Mine is a class 10. Maybe triumph just cant handle a large capacity class 10 card?

    Regarding the "SD formatter" from SanDisk, what does it do that windows formatting doesnt? I hate downloading useless applications on my pc and then uninstalling it only to find loose reg keys here and there that belonged to that old application.

    I have a 64 bit windows 7 pc, could it being 64bit have anything do with how its getting formatted. Usually when you put in a new sd card, android will write a few folders to it like 'android.secure' and 'Android' but in my sd card that does not happen and thus leads to bricking the phone. The only way to use the card is to transfer all files from an old sd card to the this new one on a pc. Then it works, very poorly at best, and force closes like I mentioned before. sighhh..
  7. GKNByNW

    GKNByNW Well-Known Member

    I picked up at Class-10 SanDisk 32GB (SDSDQUI-032G-A11) on sale for $30 at Best Buy when I bought my Triumph at the beginning of October. I have had no problems with it whatsoever. Your 64-bit OS has absolutely no bearing on how the card is getting formatted. Open up My Computer, right-click on the SD Card, and choose Format. I use the default format (I *believe* it's FAT16 but it may be FAT32; I'm on Linux right now so I can't double-check) and haven't had any problems. After formatting on your PC, use your CWM-based Recovery to partition the card if you so choose. You shouldn't have any problems, unless the card itself IS bad as you suggested it might be.
  8. Ayered

    Ayered Member

    My SanDisk Class 4 has been working for a year. Link2SD for apps works and videos and music play fine.
  9. ccody47

    ccody47 Lurker

    I picked up one of these SanDisk Ultra 32gb UHS 1 cards from Amazon little over a month ago, complete waste of money. At first, it worked great. Was extremely fast with both read/write speeds. Took all of 3-4 days before it started acting up.​

    First, when transferring over the contents of my old Trancend 8gb class 6 card (videos,pictures, etc) through USB from my PC, randomly in the middle of the transfer the card would unmount itself. Android would mount the card, and would tell me it was a blank card. I had to take the card out of the phone, and re-insert it in order to access the contents. This generally happened when moving a large amount of data at once (either through a bunch of small files, or just one large one). This frustrated the hell out of me, but I dealt with it as it only took a few seconds to fix, didn't even have to reboot the phone.​

    Then, on three separate occasions, my phone locked up. This happened random as well, could have happened when watching a movie, playing a game, or just browsing the web. Upon a battery pull/reinsert the phone would boot up like I just just done a fresh install of a rom. Would load up the Android Tutorial, but as soon as I would click the Android Guy to start the setup, the tutorial would FC and restart. That's as far as I could get, just loop through that over and over. Phone had been wiped/corrupted/I have no damn clue. Had to boot into recovery and wipe and re-install my rom from my old 8gb card, every time. Well I had enough of that crap, haha.​

    Card has been sitting on my desk for the last couple of weeks. Currently emailing back and forth with SanDisk (Amazon warranty was up) to get this swapped for another, hoping I just got a defective card.​

Motorola Triumph Forum

Features and specs are not yet known.

Release Date

Share This Page