1. Download our Official Android App: Forums for Android!

General Calender sucking all my battery when on standby

Discussion in 'Android Devices' started by lawrencep93, Nov 27, 2010.

  1. lawrencep93

    lawrencep93 Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    9
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    9
    1
    26
    Does anyone know how to stop this.

    I didn't use my phone at all today and 70% of the battery was used by the calender, I tried to uninstall it and I couldn't, I hit force stop but it started again.

    Anyone know how to fix, or disable calender?
     

    Advertisement

  2. downey667

    downey667 Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    Oct 31, 2010

    Oct 31, 2010
    30
    1
    16
    I have the exact same problem, it's frustrating!
     
  3. K24A3

    K24A3 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    18
    1
    16
    HTC calender or Android calender?
     
  4. lawrencep93

    lawrencep93 Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    9
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    9
    1
    26
    I think its the HTC one, there is a widget set one screen left by default, I removed it but no improvement.
     
  5. K24A3

    K24A3 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    18
    1
    16
    I use the HTC one and have no problems, and as you said, you removed it and saw no improvement, so maybe it's something else installed that is causing the problem. Or maybe its just a bug in android where high CPU usage is mistakenly blamed on the calender due to an id mixup.
     
  6. lawrencep93

    lawrencep93 Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    9
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    9
    1
    26
    I was unable to disable it, but I know it's not an app ID mix up, the calender is always running and updating, so it uses all my CPU.
     
  7. K24A3

    K24A3 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    18
    1
    16
    Are you using the Calender Widget? Perhaps try removing it, rebooting (full reboot), then add it again. Or remove all the calender entries.
     
  8. Brewster0101

    Brewster0101 Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    85
    Joined:
    Oct 29, 2010

    Oct 29, 2010
    85
    5
    16
    Pricing Admin
    Dorset, UK
    Is you calender constantly syncing with facebook, Gmail or something. If so then reduce the number of times it syncs in a day or get it to sync once a day.
     
  9. weaselchops

    weaselchops Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 29, 2010

    Nov 29, 2010
    2
    0
    5
    I am seeing the same problem for a few weeks now.
    I am syncing my gmail calender, some days it will be fine...others not. Never had this problem on my Milestone!
    I have set everything else (FB,news) to sync once a day. I am now using a 3rd party calender widget now, same issue with the HTC widget though.

    :(
     
  10. lawrencep93

    lawrencep93 Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    9
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    9
    1
    26
    When I look at included packages it has almost everything included with HTC like the weather facebook for HTC and stuff.

    I need to stop it some how, I barely used my phone today and it went flat after 6 hours
     
  11. WigglesGRN

    WigglesGRN Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    93
    Joined:
    Dec 4, 2010

    One thing I have found is that if you turn off the mobile data when not using it you get a hell of a lot more battery than otherwise, I turn my mobile data on to do my syncing between my jobs for the day and have it turned off when I don't need it.

    I understand that this will frustrate a lot of people who go " its a top of the range phone, should last longer" but its got very high specs and that will cost battery power, for me I get 24 hours at least from my HD by just using the phone when I need.

    So far since last night I have 14 hours 4 mins unplugged an im at 85% bat remaining. that is using some WiFi while at home too. Most of the time I just leave mobile data turned off and the phone still works as a phone so get calls and send texts.

    Another tip is that if you live in London and use the tube ( I use it daily) when on the tube set the phone to 'Air plane' mode and it wont constantly seek for a phone/36/hsdpa/Wifi connection. The other day on the tube I lost 30% of my bat while it searched.

    As I said above, it all comes down to personal usage.
     
    DanteGR likes this.
  12. Coldry

    Coldry Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 5, 2010

    Dec 5, 2010
    3
    0
    5
    All that said, can anyone tell why HTC went for the 1230 mAh battery in such a big device with a LCD screen when they put a 1400 mAh battery in the Desire which is smaller and has an AMOLED screen! If anyone on here has contacts in HTC perhaps they can find out and let us all know. Or better yet, get them to bring out a longer lasting battery for us loyal customers.
     
  13. kaine

    kaine Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    97
    Joined:
    Aug 17, 2009

    Aug 17, 2009
    97
    7
    36
    Its Facebook contacts. Turn it off.
     
  14. ruornil

    ruornil Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    6
    1
    6
    Facebook for HTC Sense / contacts

    go to settings/Accounts&sync/Facebook for HTC Sense
    and uncheck Sync contacts.

    When checked with Usage Timelines app Stocks app is eating the cpu, and according to the battery it is calendar app. :( damn those stock apps comes with the phone.
     
  15. ruornil

    ruornil Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    6
    1
    6
    I have an another issue with DHD.

    When you shut down and open the phone it starts syncing. calendar service connected to obex file transfer and stocks.app starts to use 100% cpu.

    In order to free the cpu I have to kill calendar service obex file transfer and stocks.app, but this time i can not connect DHD as a disk drive to pc or mac.

    I tried to figure out all night and finally i remove facebook for htc sense account, then add that account again. At first facebook for htc sense dropped the option for syncing contacts, so i restarted the hone to see what happens and contacts came back. I synced the contacts and for now there isn't any problems and if it come overagain I will inform you all and try to find another solution ( I can live without facebook for htc sense but having it is a charm)


    some notes about the problem:
    (i also format the microSD and restore it on my mac from a disc image file)
    (before all those problems appear I lost all my contacts and retrieve them back from google contacts, when facebook for htc sense suggest links for google contacts I mistakenly click home button and lost those links)

    maybe those can be integrated with the symptoms.
     
  16. jamie_nx01

    jamie_nx01 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    10
    0
    15
    Hi guys,

    I'm new and have a terrible battery issue.

    Firstly, let me thank the forum and the community for the "usb debugging" tip. Solved my Android OS using 60% of my battery life. But now I have a new problem.

    When auto-sync is on (and I like it on!) my Calendar uses between 60% and 95% of my battery! At first I thought this was due to it syncing my my google calendar (which subsequently syncs with my work outlook calendar) but have since deleted all entries and still the problem remains. I am aware that calendar uses a range of other items such as stocks within it, but cannot trace the issue!

    I do not have any calendar widgets being used, I have since removed my stocks widget and have got my home screen, a screen filled with 16 programs, friend stream, texts, a frequent contacts screen and a weather widget.

    Can anyone help me? Any assistance would be much appreciated.

    Thanks.
     
  17. THE ANDROID

    THE ANDROID Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    284
    Joined:
    Nov 23, 2010

    Nov 23, 2010
    284
    16
    38
    PlayStation Network
    It's HTC's fault for puting in such a small battery. I'd gladly pay pay for a battery with capacity of 1500
     
  18. jamie_nx01

    jamie_nx01 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    10
    0
    15
    If you have applications that are hogging the battery more than they should, then it doesn't matter what size battery you have, you have a problem. Even if I did have a 1500, 60% would still be taken up by the calendar. Big issue in my eyes.
     
  19. ruornil

    ruornil Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    6
    1
    6
    those are the symptoms we have here. you checked battery usage from setting/about phone/battery

    and if you checked your phone cpu usage with a program you'll see stocks.app (probably there will be two apps with same name )

    I'd like to ask a thing are you using facebook for htc sense sync? If you do so, remove your account restart your phone and add your account again to Facebook for HTC sense. This solved my problem. No problems for 2 days.
     
    jamie_nx01 likes this.
  20. jamie_nx01

    jamie_nx01 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    10
    0
    15
    Yes thats how I checked my battery usage. If I charged my phone before going to bed, I would wake up and the calendar would be at 95%. CRAZY!

    Right ok. I will take your word on the stocks.app thing as I dont have a cpu usage program installed. Makes sense though as the Stocks is part of the calendar....still searching for the logic behind that one!

    I am using facebook for HTC sense, but have just unticked the box for syncing the contacts automatically. I will give your suggestion above a go, many thanks. Although I hope that is a permanent fix...Dont want to be having to do that every couple of weeks :mad:
     
  21. ruornil

    ruornil Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    6
    1
    6
    unchecking doesn't do the trick for me because when I restart my phone I found that contacts are checked again.

    In my opinion it is a problem with having loads of facebook contacts and server problems and authentication errors of Facebook for HTC Sense client accessing facebook servers and an infinite loop :) also the stocks app I metioned is not the stocks app you can use (or anyother DHD users). It is just mentioned to be stocks app, when DHD is syncing, stocks app always hit above 50% CPU usage and goes back to 0 to 1% when syncing complete according to the Usage Timelines app (may be that app is misnamed the process as stocks app).
     
  22. downey667

    downey667 Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    Oct 31, 2010

    Oct 31, 2010
    30
    1
    16
    Omg m8, i have been looking for an answer to that since i got my phone and you just hit the nail on the head! my phones battery is consideribly better after turning that off. Cheers pal
     
  23. jamie_nx01

    jamie_nx01 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Dec 6, 2010

    Dec 6, 2010
    10
    0
    15
    Same here mate. Un-checked it this afternoon, and calendar is nowhere to be seen. And I have re-started the phone.

    What an odd little system Google have developed here. Even with the initial teething problems, im still glad I dont have an iPhone.

    Thanks for the help mate. Like I said above, i've un-checked it and all seems well so far. Will post if this changes.
     
  24. lawrencep93

    lawrencep93 Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    9
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    9
    1
    26
    com.HTC.BGP is always using my CPU.
     

Share This Page

Loading...