1. Download our Official Android App: Forums for Android!

Support Call problem - Echo on the other end

Discussion in 'Android Devices' started by uncle_moe, Jul 13, 2011.

  1. uncle_moe

    uncle_moe Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 13, 2011

    Jul 13, 2011
    2
    0
    5
    when i make or receive calls i hear a clicking in the headset and the caller on the other end can hear an echo of their voice played back and only partially hear me. phone has been "repaired" twice but neither time was the problem resolved. updated to gingerbread but problem persists
    anyone got ideas? oh and im losing signal frequently
     

    Advertisement

  2. formmailer

    formmailer Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 22, 2011

    Jul 22, 2011
    1
    0
    5
    Hi!

    I have the same problem with the Incredible S.
    Did you happen to find a solution for the problem?
    Where do you live. Can the place be an issue? I am living in Sweden.
     
  3. PeteFinn

    PeteFinn Newbie
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Jul 16, 2011

    Jul 16, 2011
    14
    0
    15
    Helsinki, Finland
    Same problem here in Finland. This seems to be a very common problem and I don't think there's an official fix. I know people who've had their phones serviced more than once because of this but it didn't help.

    Great phone but totally crappy 2G/3G radio module. By far the worst I've ever used. Lots of echoing (on both ends depending on the situation) and terrible call quality with break-ups in places where other phones have zero problems.

    I really hope HTC comes up with a firmware update that fixes this major problem.
     
  4. Superand

    Superand Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 25, 2011

    Apr 25, 2011
    10
    0
    15
    Denmark
    I have the same problem. And also a very metallic sound from the speaker during calls. Very poor calling experience - a really anoying upset in an otherwise very good phone! Cannot believe that the phone-part should be the difficult thing to make in a smartphone!:-s
     
  5. DavidKundalini

    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 30, 2011

    Jul 30, 2011
    2
    0
    5
    Same to me...
    I'm from Italy, but the phone was bought on Amazon.co.uk.
    My phone model number is S710e, android 2.3.3., firmware is
    2.30.405.1, radio module is 20.2808.30.085AU_3805.06.03.03_M

    I have these problems for the radio module:
    • My voice is kind of intermittent from the other side of the phone (who listens me)
    • I can hear echo of my voice
    • The other side of the phone can hear its own echo
    • Sometimes connection is lost
    • Long time for the call to start

    I have tried soft reset, updated firmware, set GSM auto (PRL) as network preference, etc.

    No solution? I'm thinking of flashing ROM, radio module and whatever... but if the phone is broken, what about warranty loss?
    :mad::thinking:
     
  6. haria.mehul

    haria.mehul Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Aug 1, 2011

    Aug 1, 2011
    5
    0
    5
    Same problem to me.

    I am from India. But the problem seems to be onlyon specific numbers and networks especially for Vodafone!!.

    Please let me know if anyone finds a solution for this!!
     
  7. DavidKundalini

    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 30, 2011

    Jul 30, 2011
    2
    0
    5
    Yes, that's true. I have Vodafone too and they (HTC) told me to try with another SIM from a different mobile phone operator.
    So, I'm trying with Wind (an Italian operator) and the situation seems to be better, even if I'm still in the testing phase...

    Tell me if there are news and improvements!
     
  8. haria.mehul

    haria.mehul Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Aug 1, 2011

    Aug 1, 2011
    5
    0
    5
    Hi,

    I have changed my handset and sim card once but t he same problem persists.

    But, hey guys i found a solution which was pretty weird.

    I tried calling after removing my back cover and it works perfectly fine which is surprising to say the least!!:thinking:

    You can try if it works for you and let me know the same.
     
  9. canadiac

    canadiac Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jul 9, 2011

    Jul 9, 2011
    8
    0
    5
    That's a bit surprising. Isn't the antenna inside the back cover?
     

Share This Page

Loading...