1. Download our Official Android App: Forums for Android!

Support Camera/Gallery not responding

Discussion in 'Android Devices' started by h_mansa, Aug 2, 2013.

  1. h_mansa

    h_mansa Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 2, 2013

    Aug 2, 2013
    1
    0
    5
    Alright, so I've been working on finding a solution for this issue for a loooong time now, encountered this fora today, hoping you are able to help me out! :)

    Issue:
    When I open my camera app the screen stays "black"/receives no image from the camera and the app freezes, stays like that for a couple of minutes until it responds that "the camera is not responding" and after that "the gallery is not responding".

    - This issue is existing no matter what camera app I use
    * I tried stock, Camera ICS and CameraMX
    - It also affects flash, I'm not able to use any flashlight app
    - It doesn't help to boot in safemode, still same issue.
    - If I lock the screen while in camera (both from lock screen or app directly) phone freezes and I have to hard reboot by pulling battery.
    - Phone sometime freezes on random during day or night without any given user activity.
    - Upgraded to 4.3 over air last week, problem persists.
    Edit: Screenshot is possible!

    Can anyone recognize these problems and have any kind of solution for them? I admit! My phone has been near coffee once or twice, but I have tried disasembling it to look for rust, spills, areas to clean and all connections seems dead clean (they are also quite well hidden in a couple of layers)....

    Anyone? =/ I would soo love for my phone to work fully again and not have to buy a new one to get this to work...

    - Hjalte
     

    Advertisement

  2. rvonder

    rvonder Member
    Rank:
    None
    Points:
    38
    Posts:
    54
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    54
    12
    38
    D.C Metro
    I've had similar problems with my camera for several months now. In my case, I can't even get the camera to start at all - Gallery crashes immediately after boot, and any attempt to manually start it (e.g. by clicking the Camera icon) results in the same crash. It appears that Android keeps trying to restart the Gallery app, because these "Unfortunately, Gallery has crashed" messages keep popping up every few minutes - really irritating! I tried to switch to the front camera, but get the same results.

    Like you, I've tried everything I can think of in terms of software... new kernels, new ROMs, different camera apps, etc. Nothing helps. So I'm concluding that the problem must be hardware-related, not software?

    I found only one way to get the camera to run again, which is to pull the battery and leave it out of the phone for an extended period (at least 20-30 minutes). When I then reinstall the battery and boot the phone, the camera works perfectly for a few minutes before it starts crashing again. Maybe having the phone completely shut down lets the hardware cool off to the point the camera works again? I might try putting the powered-up phone in the refrigerator to see if that has the same effect.

    Anyway, you might want to try the extended-term battery pull to see if it helps you. And if anyone has any ideas why these camera failures occur and how to fix them, I'd sure love to hear it!
     
Tags:

Share This Page

Loading...