1. Download our Official Android App: Forums for Android!

Support Camera on 2.2 colour balance too red

Discussion in 'Android Devices' started by jreid9001, Nov 22, 2010.

  1. jreid9001

    jreid9001 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    14
    Joined:
    Sep 16, 2010

    Sep 16, 2010
    14
    0
    15
    Well, I finally managed to get my phone rooted and onto 2.2 a while ago, but today I went to use the camera (don't use it that often)and noticed the colour balance was really messed up, it made everything really red. I assume this is a 2.2 issue, does anyone have any idea for a solution?
     

    Advertisement

  2. Phenomenological

    Phenomenological Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    782
    Joined:
    Jul 7, 2010

    Jul 7, 2010
    782
    186
    93
    Have you checked you haven't accidentally tweaked the white balance setting in the options pane?
     
  3. garryknight

    garryknight Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    164
    Joined:
    Oct 12, 2010

    Oct 12, 2010
    164
    22
    38
    London, England
    Mine tends to be a bit bluer than it should be. The auto-white balance isn't very good on this phone. Far better to set it manually.

    Just on the offchance that you haven't a clue what I'm talking about (not everyone is a keen photographer), I'll explain. Cameras aren't like eyes and can't easily tell how to adjust the colour balance in a picture so that the whites are truly white. So they have a set of default white balance settings. If you start the camera then pull the slider over and press the gearwheels icon, you'll find White Balance at the top of the list. Just change that to match the type of light you're in. Daylight and cloudy should be obvious, but you use Incandescent with indoor light bulbs and Fluorescent with indoor tube lighting.

    Hope that helps. And if you knew all this already, just ignore me. It's advice for anyone who searches the forums. :)
     
  4. ben.fred

    ben.fred Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    144
    Joined:
    Aug 10, 2010

    Aug 10, 2010
    144
    1
    56
    mine was the same,

    turned out i had hit a wrong setting......
     
Tags:

Share This Page

Loading...