1. Are you ready for the Galaxy S20? Here is everything we know so far!

Camera on Samsung SGS7 stops recording audio after about a minute

Discussion in 'Android Help' started by PacificaBren, Aug 21, 2020.

  1. PacificaBren

    PacificaBren Member
    Thread Starter

    Can anybody suggest how I might fix this problem? It just began happening quite recently. The camera doesn't seem to start recording video until a few seconds after I thought it had started recording, and then, after about a minute, the audio stops being recorded.

    Troubleshooting steps I've tried so far:

    1. Changed whether camera was saving files to internal memory vs. saving to SD card

    2. Reset camera settings

    3. Deleted camera cache

    4. Deleted camera data

    I can't think of anything else to do, since this is the built-in camera app, and it therefore can not be uninstalled and then re-installed.

    About my phone:

    Model number: SM-G935T

    Android version: 8.0.0

    Samsung Experience version: 9.0

    Thank you for whatever help you can offer!
     


  2. Dannydet

    Dannydet Extreme Android User

    Have you tried installing a different camera app from the play store?
    Test one and post your results
     
    olbriar, MrJavi and MoodyBlues like this.
  3. PacificaBren

    PacificaBren Member
    Thread Starter

    I was thinking that might be the next step. Is there one you recommend?
     
  4. svim

    svim Extreme Android User

    How much free storage space do you have in your internal storage and microSD card? Video files generally are quite sizable so if there's not enough storage that 'might' be why it's doing that odd audio cut-off thing. Have you tried setting the Camera app to use a lower resolution?

    Otherwise, I'll recommend the Open Camera app. It's an Open Source project so there are no corporate ties, and it's free with no ads. It also has a very extensive feature set so be sure to go into the app's Settings menu to set it up to your liking.
    https://play.google.com/store/apps/details?id=net.sourceforge.opencamera&hl=en_US
     
    olbriar, ocnbrze and Dannydet like this.
  5. steiny180

    steiny180 Android Enthusiast

    Try disabling battery optimization for the camera app...
     
    olbriar and ocnbrze like this.
  6. PacificaBren

    PacificaBren Member
    Thread Starter

    Sorry for the late reply, and thank you all for your suggestions!

    I installed Open Camera, but the problem is persisting. Tonight I shot a two-minute video with Open Camera, and I'd say the last 30 to 20 seconds had no audio.

    Steiny, how do I disable battery optimization for the camera app? Or are you saying just disable battery optimization in general?

    Regarding free storage, it looks like my internal storage has used up 26.35 GB out of 32 GB, while on my Micro SD card, 11.23 GB out of 29.71 GB have been used.
     
  7. steiny180

    steiny180 Android Enthusiast

    (From my Moto G6)

    1. Go to Settings
    2. Enter "battery optimization" in the search text box and tap search
    3. From the seach results, tap "battery optimization"
    4. Select the camera app from the list
    5. Tap "don't optimize"
    7. Tap "Done"
    8. Thank me very much...
     
    Dannydet likes this.
  8. PacificaBren

    PacificaBren Member
    Thread Starter


    I do thank you! But the search results said, "No results found."

    Is there some other term I should search for, or some other way of getting into those settings?
     
  9. PacificaBren

    PacificaBren Member
    Thread Starter

    OK, I had to go into settings/apps/camera/battery/battery optimization.

    I'll let you know if this fixes my problem later.
     
  10. svim

    svim Extreme Android User

    Since you encountered the same problem using two different camera apps, it's unlikely to be directly related to the camera app itself but more about something with your phone (i.e. Storage).
    Try going into the Settings menu of the Camera app or the Open Camera app, and change the default Save location from your internal storage to your microSD card storage. Or set the resolution for default Video files down to a smaller setting (higher resolution videos result in larger file sizes, lower res will be smaller) and see if that makes any difference.
     
    Dannydet likes this.
Loading...

Share This Page

Loading...