1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can anyone recommend their viewof safest + best browser showing file extensions on its DownloadPage?

Discussion in 'Android Lounge' started by Oncebittentwicebitten, Mar 4, 2021.

  1. Oncebittentwicebitten

    Thread Starter

    Hello,
    I have started downloading my entire collection from gog games for my pc and unfortunately right from 1st download I have encountered a problem.
    The 2 dlcs for game Northgard correctly (i believe or I am supposing it appears correctly) downloaded as exe files but the game itself downloaded as an SH file. There's a bit more to this and that I could have sworn it started as an Exe file on commencing download. On looking at their offline (for) downloader as they call it, it shows on my pc now in their site as an SH download. I sent in an email and they replied with just one of their paste the faq answers (does this answer it type things or get further in touch) which is just a pure paste from them and mentions that files are exe files and should they be large files sometimes they make them bin files. I have replied that it doesn't actually explain why my system shows I downloaded an SH file from their site. And please, yes I know what an SH file is, that doesn't need saying(I looked it up). Their faq paste which they sent doesn't make mention of SH files. I have replied with please can you answer why my system shows the download as an SH file as I had mentioned and should it?
    Well here's why I contacted you. (Oh I started the download same day of buying Northgard, almost immediately after, give or take an hour or so at max.) Anyway I sent them 2 attachments in that reply to their reply. One shows the area of the download page from chrome browser(and it doesn't show file extensions) thus I was forced to also include a file manager screenshot as a 2nd attachment which shows the download as an SH file for the game itself and the two dlcs showing as exe files. My version of chrome is 88.0.4324.181, copyrighted 2021 Google Inc. My question is can anyone recommend a safe or trusted browser that shows file extensions in the browser's downloads page? (That's so I can in future provide proof in a more failsafe, unholed manner.)
    Edit Addition: Note please I tried fingerpressing to try and get the full file name with extension to come up(for a screenshot but that didn't show it) and also looked in settings so am wondering if there's a recommended and safe browser which has considered this and shows file extensions, 1st preference would be straight on page itself without any need for opening outs or if not then shown after opening out as 2nd preference.
    Screenshot_20210305_010022_com.android.chrome.jpg
     

    Attached Files:



    #1 Oncebittentwicebitten, Mar 4, 2021
    Last edited: Mar 4, 2021

    1. Download the Forums for Android™ app!


      Download

       
  2. Oncebittentwicebitten

    Thread Starter

    Thanks its appreciated.
    Oh there is something else. Its a bug or how it works anyway. It makes mention of sd card. Yet my phone is on internal memory as I forgot to change it on simcard reinsert. And actual internal memory is a few gb below capacity. However I put download directory setting(chrome) to my actual sd external card before starting what is now yesterday's downloads. It seems to have covered it by using that internal capacity but my external card is actually 256.7gb. This method is preferable to kicking up errors but for safety of having and keeping what I have, it's actually on a 256.7gb memory card. Again thanks for recommendation anyway.
     
    #3 Oncebittentwicebitten, Mar 4, 2021
    Last edited: Mar 4, 2021
    ocnbrze likes this.
  3. Oncebittentwicebitten

    Thread Starter

    Screenshot_20210305_025307_com.android.vending.jpg Screenshot_20210305_030745_com.android.chrome.jpg
    I am sorry I don't mean to be rude but is that, LighningBrowser by Anthony Restaino that is shown in play store, if not can you recommend one in play store that should if you guys think so be safe that shows extensions.

    Edit Addition. I apologise, think I no longer need it answered, see other attachment. Thanks for advice recommendation Sir.
     
    #4 Oncebittentwicebitten, Mar 4, 2021
    Last edited: Mar 4, 2021
    MrJavi likes this.
  4. Oncebittentwicebitten

    Thread Starter

    Hey I thought I would just let you know what's just happened. I logged in with a new password I created last night, a very complicated one but entered perfectly. It stated it looked as if I was logging on from a new device(I wasn't) and it said it sent a verification code to my email address. I minimised browser(chrome still) and I got the code, went back and it had closed the page where you enter the code. This I swear on my life. I regularly minimise browser and come back to by the way, this time it had closed the page.

    Addition, oh and going into the site the login button has vanished. I have checked cookie settings in chrome and my cookies are set to on. (that applies both desktop mode and mobile)
     
    #5 Oncebittentwicebitten, Mar 4, 2021
    Last edited: Mar 4, 2021
  5. Oncebittentwicebitten

    Thread Starter

    Guys it's got worse.
    1. The login button vanished.
    2. Cookies were enabled.
    3.Went to bed
    4. This morning I looked. With chrome, same thing.
    5. I decided to look with lightning. There was a sign in. I was using lightning Instead of chrome.
    I logged in. It sent the password enter 4code as it did with chrome but shouldn't have with chrome.
    6.i minimised screen, got the verif, came back and this time I could maximise again and entered, entered it. And that I thought was that but it shows no sign of my being logged in - account name after I came out of log in. I have just checked that email and it says browser used chrome.. I was definitely in lightning this morning. Any ideas please, I would like to get all my games off of gog, I have plenty of hard drive space and there's another reason and it looks like I am being messed with. I cannot send a password reset without being able to login.
    I have browser looked and found, see attachment.. Is that a correct gog login, its found from browser search so am a little concerned.
    I want to send iin a password reset again but if I don't get the login page I can't. I've sent password reset on that(attachment) but not entered anything yet. (Will have to redo it I think but it's better than somebody logging in as me elsewhere.
    PLEASE ASSIST, this isn't a windup.
    That site, https://login.gog.com. It's an https, does that mean it's guaranteed to be correct as gog's or do fakesters have them too??
    [The order is correct above, it sent the code thing after it showed the login on their webpage, this morning, I entered the code after it said I needed to then it accepted it but gives no indication I am logged in showing no account details so browser searched as again there's no login and found what you see in attachment. Sent a password reset but not touched the email yet. That's how it stands. Does that login link sound correct and yes I know it's the most stupid /simplistic thing to get her up over considering the rest..]
     

    Attached Files:

    #6 Oncebittentwicebitten, Mar 5, 2021
    Last edited: Mar 5, 2021
  6. Oncebittentwicebitten

    Thread Starter

    OK I have checked the email they send.
    It's from no-reply@email.gog.com. Unless they've changed it overnight in my inbox that's the same as the website did.
    And for info looking at that and previous one this morning, it says the browser used on their website or link which it goes off to as browser used isn't showing in what's sat in my emails visible but it told me chrome so obviously sent me to what said it.
    Is it likely at all that browser lightning may show up as chrome incorrectly??
     
  7. Oncebittentwicebitten

    Thread Starter

    Ok to finish this iogged in immediately after that code send, it was literally right in your face, only thing on the screen, in similar font to attachment, and again there is no indication on main screen I am logged in, no username, no these are your games where I can select the Download using what they call offline browser.
    NOTE Gog Galaxy for me is amazingly slow. Note I want to put my pc offline permanantly. I've tried their offline browser using straight to download, that too is amazingly slow and has also had fails. I used a download manager on pc and for a few attempts it worked fine then it started losing the download and to me it seemed like the download was being reset, sometimes it couldn't find a number 4 when I decided OK I wil be exceedingly, above extreme patient. I downloaded one yesterday on my phone instead which went from being an exe when I started to an sh when I went back and found it completed in the folder on my phone. I then kept an eye on the next one and gog has it as a bin file and that seemed to download correctly and FAST but when I went to verify its size against what it had finished at before install, this started happening...I want to get them all onto my pc and quickly, there's a fair few. A gog reference because I think I need to post this #88E78AF9E30E.oh and 13.
    I've only currently got less than half my games downloaded, that's without trying to download all. In trying, I only have got to adding two. Is it necessary? Yep. I tried running ALL that I've downloaded OFFLINE, so far only four(yesterday) didn't work. I tested that yesterday morning NOT HOOKED UP AT ALL TO THE INTERNET. About 20 minutes ago(today) one that worked yesterday errored on run not even getting into game load up but claiming its an error with the game yet it worked yesterday. (note I've tested yesterday (Thursday 4th)actually into running game past menu for each.) I haven't connected to the Internet between and can go as far to say for the past three to four days there's been no router attached. I checked network adaptor today after this game wouldn't run 20 minutes ago and it looked very offline. Disconnected here, disconnected there but NO CROSS on the graphical display, that dented my belief in it and I thought probably lying bstuds, I wanted to see the X between pc symbol on that line between it and the other thing. I from reading the text thought it sounded offline enough and it just surprised me to find on network adaptors, same area I was that I could right click and select disable, I've just done that for ethernet and vpn right beside it, and ive rebooted and tried running the game and surprise, surprise, it loads up and runs(No Man's Sky) so back to just the one game that won't run offline or online, and I have four which won't run offline but will online connected to gog galaxy(I guess, still) aswell as all the others that run correctly offline that I've downloaded. Gog hasn't been that helpful in previous needing answers support tickets more to do with (connected with) err inventory, longstooding(Delib) inventory where I asked some general questions about gog policy on inventory games and them retaining on them.
     
    #8 Oncebittentwicebitten, Mar 5, 2021
    Last edited: Mar 5, 2021
  8. puppykickr

    puppykickr Android Expert

    Ok, to be honest, I did not read all of that.

    No offense, but one thing at a time.
    (Some of us are getting old!)

    Anyway, the reason that Lightning may sometimes appear as Chrome to some sites (I have had that, as well as Mozilla, and even Safari!) is because Lightning is a wrapper app for the Android System Webview app that is installed in every Android device.

    Chrome and other apps all use this same webview, and depending upon the site, some can only see what webview you are using- and not the interface app that you are using to access the webview.

    A webview is simply an app that allows other apps to display web content.

    Lightning gives access in a secure, speedy way, without all the complexities and extra junk of other browsers.
    For instance, Brave has its own webview. Why, when there is already a webview installed in the device?

    Alright, now that is out of the way, as far as logging in- if you have too many security features turned on, sometimes you have to exit the app and then come back in.
    If cookies are allowed, then you should still be logged in.

    Are you using incognito mode, by any chance?
    This can cause such an issue, because in that mode each tab is sandboxed- that means each one is completely separate from the others- and for some reason (in my experience) this has happened when certain sites are used with sandboxed browsers.

    If this is the case, then stop using incognito mode. There are other security features that work fine, and I never use incognito mode.
     
  9. puppykickr

    puppykickr Android Expert

    Also, get Lightning from F-Droid.
    That way you will not have Google junk attached to a browser that is made to circumvent such things in the first place.

    There is no point in a secure browser, if Google is tracking everything that you do with it.
     
Loading...

Share This Page

Loading...