1. Are you ready for the Galaxy S20? Here is everything we know so far!

can i flash a rom through fastboot? HTC Evo

Discussion in 'Android Devices' started by crhopkins, Feb 9, 2011.

  1. crhopkins

    crhopkins Newbie
    Thread Starter

    hey guys ive been on this thing for a few weeks now, and ive deducted it all down to three simple questions

    One: is it possible to flash a rom from my pc to the evo through fastboot?:thinking:

    I found this: fastboot flash partition filename, i tried: fastboot flash par01 mik.zip (where par01 is just something i made up, and mik.zip was located in sdk-windows\tools\. (i renamed it... maybe thats why it didnt work? - its mikfroyo 4.4 - signed btw) Reason is because i cannot get recovery-windows.bat to find my evo. but fastboot through sdk tools does. ive read that updating the radio fixes this, but i dont know how, since it would have to be manually (as opposed to using the sprint way, through settings blah blah)

    Secondly: How do i use the terminal emulator through sdk if i dont have root. :thinking:
    (S-ON PC36IMG) I downloaded flash_image and mtd-eng.img but when i go to terminal emulator and type in SU it says permission denied

    Thirdly: Why is it that only through windows xp, fastboot recognizes the phone? :thinking:
    I downloaded the x64 windows 7 drivers and manually updated it through device manager, yet it continues to try to install qualcomm, and none of the windows 7 drivers work.

    I was dead in the water, but since the new co-operation with fastboot there is light at the end of this very very dark and depressing tunnel.

    before it wouldnt charge unless the phone was off, and would give me a sd card removed error everytime. I managed to get the sd card recognized by the phone, and now the phone will charge will its on. But i cant get the sd card mounted onto windows, 7 or xp. Evo doesnt show a display menu when its connected through usb, it simply charges. i tried removing the sd card, booting up, the restart with the sd card, i tried toggling the (usb debugging) and the (ask me what to do) boxes several times. I downloaded htc sync on both windows xp and 7, then manually changed in "connect to computer - htc sync" on the phone, and still nothing.

    What i think i maybe able to accomplish is to flash from fastboot mikfroyo 4.4 and all my troubles will go away.
    Or i can fix the usb through the terminal emulator, but first i have to get root. and since im running pc36img i dont really know how to flash to another rom without using recovery. :eek:
    unrEVOked did not work, since it didnt recognize the phone. Yet everytime i plug it in, it asks to install two things. One: android 1.0 and Second: Qualcomm. i manually downloaded android 1.0 and thats how i got fastboot to recognize the phone.

    i did, fastboot oem enableqxdm 0, it worked.

    If i could do
    cat/sdcard/flash_image > /data/flash_image
    and so on it would be fixed, but i cant get passed SU :mad:

    Here's what i see in hboot:
    SuperSonic EVT2-3 SHIP S-ON
    MICROP- 041f
    apr 14 2010, 15:41:34

    Clear storage
    hboot usb

    any help appreciated thanks

    1. Download the Forums for Android™ app!


  2. crhopkins

    crhopkins Newbie
    Thread Starter

    OK so im moving forward, on my own... yes this is scary, dont try this at home kids!

    Alrighty then, what i want to do is fastboot erase recovery but i get this error:

    erasing recovery... FAILED <remote: not allowed>

    i guess because i have s-on? and also when trying to flash from fastboot i get this:

    INFOsignature checking... FAILED (remote: signature verify fail) finished. total time: 3.076s

    but ive tried flashing mikfroyo's SIGNED rom...
    also is there any signed recovery?
    when i fastboot flash <what goes here for flashing a rom? - is it boot.img?> <and then the .zip file located on my computer that i want to flash>

    When i say: fastboot devices
    i get
    HT06YHL15243 fastboot

    so, there must be a way to flash recovery from fastboot, which will then lead to using recovery to solve ll of this mess. omg im so lost - even if i get recovery i still wont have the USB thing fixed until after i flash the new ROM. im losing my mind guys, im going to stop here before i really relly break something.
  3. akazabam

    akazabam Android Expert

    Ok, I think you might be looking a little to far into this. Let me start with a few things:

    1) You can't flash a ROM until you have root and a custom recovery. Not only that, but flashing things through fast boot is very different than flashing things through recovery. Mikfroyo, for example, is a specifically formatted update zip file. It has the files for the ROM, plus an update script/update binary. Recovery knows what to do with this because it was designed to use these. Fastboot, is far more generic, and will only flash files packages in the .img format. These files are meant to replace entire partitions. For example, open up a PC36IMG.zip, and you'll see a text file called android-info along with a bunch of img files. The text file is just to verify it's the right phone, etc., and whatever img files are included will write to the partition they are designed to overwrite. So, it's these second type of files that fastboot can flash. You'll never be able to flash a zip designed to be flashed in recovery through fastboot, or any other method in hboot.

    2) How do you expect to get root from the terminal if your phone isn't rooted? I'm not sure I understand what you're trying to do. Are you following a particular guide, such as this:

    [ROOT][GUIDE] HBoot 2.02/2.10 SOFF - There Will Be Root - Upd. 01.26.11 - xda-developers

    If so, that involves getting temp root with z4root, which will allow you to at least get root at the terminal. Did you do that? If you did, you might need to verify the phone isn't prompting you to allow root access via Superuser when you try to get root remotely.

    Before we get any farther, I see you're quite out of data when it comes to OTAs. Based on your hboot version, I would guess you're not even on android 2.2. A lot of your issues might be resolved if you just accept the OTA updates up to, say 3.29 (hboot 0.97). You can still still flash the eng boot loader with that if you ever want to. Keep in mind, these newer rooting methods were written with newer update in mind. Not that it *shouldn't* work with older ones, it's just that you're having issues that could easily be resolved by just updating a bit (radio updates, for example, as you mentioned.

    All that being said, I have an idea. Download this file:


    Rename it to PC36IMG.zip. Just follow the instructions given here:


    This file is a bit different from the ones provided in the above link, in that I signed it. Not sure if you need that with S-ON or not, but just covering all the bases. I'm not sure if you'll be able to flash this at this point or not. Try it, and let's see if you can get a custom recovery with it.
  4. crhopkins

    crhopkins Newbie
    Thread Starter

    awesome thanks a ton, im at work right now but around 1500 ill be testing this. ill post my results for those who have issues similar to mine.

    I bought the phone in july (the day the white version came out) and i immediately went out to sea for 7 months, so yes, my evo is never been updated, yet through sprint's update menu on the phone, it says im up-to-date... my guess its just timing out due to mismatched versions and so forth.

    With the terminal i was using this thread:
    to fix the usb
  5. akazabam

    akazabam Android Expert

    Ok, let me know how it goes when you try. As for it saying you're all up to date, are you checking via HTC update? That's the one you want to check. In any case, hold off on that. If you really can't get that to update, there's ways of making it work, anyway.
  6. crhopkins

    crhopkins Newbie
    Thread Starter

    I did this: renamed to PC36IMG.zip, loaded into sd card, via card reader, went into hboot, it loaded checked - successful, but then went back to the hboot menu, without giving me an option to flash.

    any suggestions?


    Went here http://files.androidspin.com/downloads.php?dir=amon_ra/RECOVERY/

    tried to flash recovery-RA-supersonic-v2.3.img
    fastboot flash recovery recovery-RA-supersonic-v2.3.img
    and got the same <remote: signature verify fail> error

    maybe im doing something wrong, so is there a way i can flash the recovery.img from the pc36img_clockwork_2.6.0.1 signed through fastboot. i know im alittle fastboot enthusiastic but its the only communication through pc and evo i have. thanks
  7. akazabam

    akazabam Android Expert

    How long did it take? Did it say anything about finding the files, or did it just go to the menu within a few seconds?

    1) Are you sure you didn't accidentally rename it to PC36IMG.zip.zip? Windows automatically hides file extensions. If it was hidden, and you added another .zip to the end, the file would have the wrong name.
    2) Are you sure you didn't accidentally unzip the file? That's been known to happen too.
    3) Are you using the stock sdcard, or a different one?
  8. crhopkins

    crhopkins Newbie
    Thread Starter

    no im sure i didnt name it zip zip, i have hide file extensions turned off in windows.
    i am using a 32 gb 2 class but i can try it on a 2 gb, those are the only two i currently have. and im positive that my sd card is good.


    currently reading
    [ROOT][GUIDE] HBoot 2.02/2.10 SOFF - There Will Be Root - Upd. 01.26.11 - xda-developers
    in accordance with:
    ok so for this, i need usb connection to use:

    adb -d install -r root/z4root.apk
    adb shell am start -a android.intent.action.MAIN -n com.z4mod.z4root/com.z4mod.z4root.z4root
  9. akazabam

    akazabam Android Expert

    Nah, a 2 GB card will be even worse :). The reason I asked is because if the card is too small, it won't work. I don't see why you'd have problems with a 32 GB one. Have you ever flashed a PC36IMG.zip file before, or at least tried to, and had it recognized?

    Yeah, go ahead and read that link; there's useful information in there. I'm sure we can get it working, but you'll need to read through this information, first :).
  10. crhopkins

    crhopkins Newbie
    Thread Starter

    Yep ive done pc36img from hboot several times, it works (flashes, and loads rom) but never fixes my usb connection. Also on recovery menu on my evo i see:

    Android system recovery <2e>
    reboot system now
    apply sdcard:update.zip
    wipe data/factory reset
    wipe cache partition

    and then at the bottom it says:
    E:Can't open /cache/recovery/command

    update -

    ok so after reading this http://forum.xda-developers.com/showthread.php?t=829045
    and downloading hboot_2.xx_soff-V9.zip

    i get stuck at adb -d install -r root/z4root.apk, - adb says: error: device not found -(not surprising)
    im going manually put it on the sd card, and try to install it via evo

    well i know this is seriously a complicated way of doing this (ill explain why), but it may be possible to unzip pc36img, add z4root.apk, and then zip again and flash from hboot?

    nevermind thats just a box of worms, id have to go into the image file.
  11. crhopkins

    crhopkins Newbie
    Thread Starter

    ok i havent gotten any closer than i was 3 hours ago. i dont know what to do. heres what i think

    One. If i can install z4root.apk then i can use terminal emulator and "su" my way fixing the usb (flash_img and mtd-eng.img)

    Two. make a gold card

    Three. reflash pc36img (again) and hope it fixed the usb itself.

    Four. Is this all due to drivers? if so, ill be damned if i can figure out why. cause if its drivers im completely and totally lost. here's what device manager says:

    Under 'Android Phone'
    Android ADB Interface
    Android Bootloader Interface
    Android Composite ADB Interface

    (from Google Inc. not digitally signed)

    And then later on into USB Controllers:
    USB Composite Device
  12. akazabam

    akazabam Android Expert

    1) Do you have an example of a PC36IMG.zip file you've flashed? I have a few ideas, but I want to know what you've gotten to work. I think I know why it won't flash.

    2) You can get just z4root here. You don't need adb to just install it.

    3) It does kind of sound like a driver issues you're having. You mentioned windows xp earlier. Do you have another computer you can try on?
  13. crhopkins

    crhopkins Newbie
    Thread Starter

  14. akazabam

    akazabam Android Expert

    And you can't get any of them to connect to the phone via adb or unrevoked?
  15. crhopkins

    crhopkins Newbie
    Thread Starter

    how would i go about doing it?
  16. akazabam

    akazabam Android Expert

    Follow the instructions here with windows xp. Let's start with that before doing anything more complicated.
  17. crhopkins

    crhopkins Newbie
    Thread Starter

    not o be an annoying pest but my HBOOT is 0.79.0000
    and here it says
    HBoot Compatible Versions:

    but i will move forward ;) ( since when has something like that kept anyone from trying it anyway? LOL)
  18. akazabam

    akazabam Android Expert

    Eh, if it doesn't work, it doesn't work. I think that's in the guide only because most people aren't as far back on OTAs. I think it will still work. And if it doesn't there's other things we can do. You're far enough back to where we could try a few other things.
    crhopkins likes this.
  19. crhopkins

    crhopkins Newbie
    Thread Starter

    i go to hboot usb, successfully install Android Bootloader Interface (under Android Phone) then following directions i go to fastboot - reboot - then normal ON - double click reflash package, wait to intialize, and then plug in my phone via usb.
    so heres what happens,
    windows asks to install Qualcomm CDMA Technologies MSM drivers... three of them
    Android Bootloader Interface is no longer found on device manager, and i have the yellow question marks on the qualcomm drivers found under Other Devices.
    Using windows to search automatically for drivers turns up no results.
    using google, i found nothing. (of use)
  20. akazabam

    akazabam Android Expert

    Hmm, I'll have to look into this one more in the morning. Is it asking you to install those when you plug the phone in no matter what or only after you started unrevoked? that doesn't make much sense.
  21. crhopkins

    crhopkins Newbie
    Thread Starter

    No. Its not related to unrevoked. it happens everytime i plug it into the computer. but never when i plug it into my laptop (windows 7) - it simply just ignores it.
  22. akazabam

    akazabam Android Expert

    Are you able to connect the phone as a disk drive and browse the sdcard, at least? You aid above that you tried htc sync. You couldn't get it to connect? What happens if you just cancel when it asks you for those specific drivers, then run unrevoked?
  23. crhopkins

    crhopkins Newbie
    Thread Starter

    Yes, it searched pc36img found and loaded within a few seconds then brought me back to the hboot menu. :(

    No, i cannot connect as disk drive, htc sync will not connect but it was useful in that it came with x64 windows 7 drivers, which worked, atleast they were accepted by windows, yet seem to do nothing in aiding the situation. :thinking:

    when i cancel the balloon that asks for the drivers, (three times) it shows another balloon saying that hardware might not have installed correctly yada yada, and then when running unrEVOked 3.3 it just says, connect your phone now, waiting for device :mad:

    Maybe it has something to do with my phone, because if the computer is now recognizing that the phone is plugged in, the only way (i know) to use the sd card as a disk drive, is through the evo, and thats not working. It doesnt pop up with a menu, even with, 'Ask me every time selected' i can manually change the default option 'When I connect' to disk drive, htc sync or whatever and it still ONLY charges. :thinking:
  24. akazabam

    akazabam Android Expert

    Did you ever install htc sync on the xp computer to get the drivers? As for connecting as a disk drive, when you set it, if you drop down the notification window, does it say charge only or disk drive?
  25. crhopkins

    crhopkins Newbie
    Thread Starter

    yes installed htc sync directly from htc.com on a windows xp sp3, didn't work.

    On the evo's notification bar (the one with the clock in the top right hand corner) There says neither, charging, or disk drive. it doesnt say anything except "change current time and date"

    Also an interesting fact:

    When i disconnect the evo from the computer and reconnect it, it doesn't charge. Only when i reboot the evo with the usb connected do i receive the qualcomm driver notification balloon. Any other time it fails to charge or recognize.

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
Similar Threads - flash rom through
  1. kylabeardad
  2. andriodadmirer
  3. imnothere
  4. Yesi Trotamundos
  5. kumaranil13k
  6. 67defalt
  7. Hoegali
  8. quickfeet7
  9. emiller413
  10. joshkrupinsky

Share This Page