1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can I root OTA FRG01B using a Mac running OS X?

Discussion in 'Android Devices' started by Liebensaft, Aug 8, 2010.

  1. Liebensaft

    Liebensaft Member
    Thread Starter

    Alright, I've browsed the site a bit and have been lurking for a couple weeks now. I also did some google searching that wasn't entirely helpful. I'm looking to root my Droid currently running the OTA Froyo update, but I'm unable to find instructions for doing this with a Mac. Buying the Easy Root key is kind of out of the question ($0.78 in the checking account - college is great), so I'm turning to your infinite wisdom for help. I'm basically looking for a sequence of steps/the links and downloads I will need. Has anyone else already done this? I'm new to the rooting concept, but it sounds like it's worth it.

  2. OMJ

    OMJ Bazinga

    I would suggest finding someone with a pc you can use. I have heard of some using a windows emulator but I wouldnt suggest that.
  3. Liebensaft

    Liebensaft Member
    Thread Starter

    Well I'm using a friend's PC now and all seems to be going well until I open RSD Lite. I got the phone into the bootloader screen, clicked start in RSD Lite, but then nothing happened. No change on either the computer or phone's screen, and I've waited a few minutes now, but the phone hasn't rebooted either. Is this normal? Does it take awhile? I just like the idea of knowing that something is happening...as lame as that is.
  4. johnlgalt

    johnlgalt Antidisestablishmentarian

    When you're running RSDLite it shows a percentage in the next to the last column of it doing the stuff that it does.

    If it is not doing anything at all, and the wording on the bootloader screen has not changed from the beginning, I'd probably tr re-running it as administrator on the PC.

    If it is running XP, make sure the user logged in has administrative rights - corporate PCs can force even XP users to not have administrative privileges, and that can cause the same / other similar issues as those on Vista and 7 trying to run the app without full administrative privileges.
  5. Liebensaft

    Liebensaft Member
    Thread Starter

    Running it as an admin worked, and I kept going through the steps as listed in the guide. The phone rebooted and said the battery was dead, I pulled it out and put it back in, going into SPRecovery. After getting update.zip onto the sd card, I tried to install it from the menu, but keep getting the message

    "E: Can't mount /dev/block/mmcblk0p1 (or /dev/block/mmcblk0)
    (No such file or directory)
    E:Can't mount SDCARD:update.zip
    Installation aborted."

    Someone else suggested rebooting and trying again, but I've done that to no avail. I'm getting a little worried now. Hopefully I'm not screwed. Ideas?
  6. OMJ

    OMJ Bazinga

    your update.zip is probably actually named update.zip.zip or its in a folder on your sdcard instead of in the root. Try renaming your update.zip to update and make sure its on the sdcard but not in a folder
  7. I'm running Win7 through Boot Camp and the SPF Recovery worked fine for me. And by "fine" I mean I hit the "Code corrupt" snafu when I unplugged the phone from the USB drive because it just sat there doing nothing for thirty minutes. I ended up fixing it, so it definitely can be done. I think you get the error message a few times, yet you still force it to flash by continuing to click it and it will eventually go through.

    One thing I'm wondering about is whether I should upgrade to 2.2 officially and then take a chance with rooting or just stick with 2.0.1 rooted to run 2.2. I think that's what I'm doing now. I don't think I'm on 2.1 originally. Either way, it doesn't matter, I can't see 2.2 OTA being worth upgrading to just to root again.
  8. Liebensaft

    Liebensaft Member
    Thread Starter

    Well, it was neither of those issues, unfortunately. I tried downloading a couple other ROMs as well (FRG22, FRG01B, and Sapphire 1.0). None have been successful. The phone keeps telling me it's unable to mount the SD card, but the card works in computers. The phone turns on, but doesn't seem to have any network connections. The low battery indicator thing doesn't go away. I've tried reusing RSDLite to no avail. Is there an easy way to get it back to factory settings and try this all over? I just don't want a brick. The thing's only a month or two old.
  9. OMJ

    OMJ Bazinga

    flash one of the stock sbf files is the best way back to stock. Or get an update.zip to work.
  10. Liebensaft

    Liebensaft Member
    Thread Starter

    Well, I got one of the updates to work, so hallelujah. It just took longer than expected. Thanks for the help. I guess I just needed to be persistent. I don't know why I kept getting so many failed installations before one finally worked though. That seems really strange.

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page