1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can I root?

Discussion in 'Android Devices' started by MattGarner, Apr 21, 2010.

  1. MattGarner

    MattGarner Newbie
    Thread Starter

    I'm just wondering if I can root and which ways would be best for me If I can.

    I have an unlocked HTC Hero with an O2 Sim in.

    Firmware Version: 1.5
    Build Number: 2.73.405.66

    I don't know what other information is needed as I'm new to this sort of stuff.

    Thanks,
     



    1. Download the Forums for Android™ app!


      Download

       
  2. jUsT2eXy

    jUsT2eXy Android Enthusiast

    Hi there. As you have a generic HTC ROM you will be able to root your phone wihout any problems in a few, easy to follow steps.

    First of all read this

    Click on How To Root. Follow the instructions.

    After that (if you don't have any problems) you can try installing a custom rom for example.

    If you need anymore help post back here.
     
  3. MattGarner

    MattGarner Newbie
    Thread Starter

    Thanks for the reply. I have tried the instantroot method and after installing it, I get the following message: "Instant Root Failed, Root access was not acquired".
     
  4. jUsT2eXy

    jUsT2eXy Android Enthusiast

    What you need to do then is to downgrade your ROM. In order to do this do the following:-

    1) Download the ROM from the this link from HTC.
    2) Run the download. Follow the instructions.
    3) Read this thread and follow the instructions depending on what you want to do. e.g. Root or install a Custom ROM.

    To sum up what you are going to do / have done.

    You have downgraded your ROM from 2.73.405.66 (latest) to 2.73.405.5 (old) in order to Root / install a custom ROM onto your phone.

    Then you can flash a custom ROM because you don't want an outdated 1.5 ROM. We are only downgrading so you can get root access.
     
    MattGarner likes this.
  5. MattGarner

    MattGarner Newbie
    Thread Starter

    Thanks a lot! I went for the VillainRom 5.2. My only question is that they have a few fixes at the bottom of the thread like removing the dashes from numbers when you dial them. How do I apply such fixes?
     
  6. jUsT2eXy

    jUsT2eXy Android Enthusiast

    Hey glad it works.

    It is the same concept as the main rom.

    Download the 'fixes' however many you want etc

    Put them on the ROOT of your SD card (not in any folders)

    Power down your phone

    Hold down HOME + POWER button down for a few seconds

    In the recovery menu select flash from zip

    Apply all the fixes one by one

    Click restart and Voila

    (It is a good idea to perform a nandroid backup before you apply the fixes, in case something goes wrong)

    :D
     
  7. premiump

    premiump Well-Known Member

    Hmmm, struggling here (sorry).

    My build is 2.73.405 146733 CL#61267 release-keys (that's the full line)

    Instant root did not work (though it said it did) as Titanium then said it didn't have "root access".

    I decided to follow the instructions above (to see if I could get rid of the extra stuff (146733 CL etc) and flashed the phone no problem.

    Unfortunately, I still have the extra stuff and Titanium still does not workj after running instant root.

    I'm stuck. Any advice on how to proceed from here?

    thx
     
  8. Jaffa

    Jaffa Android Expert


    Hit the problem button and let titanium download busy box, see if that helps, it fixed it for me
     
    premiump likes this.
  9. vjprakashbe

    vjprakashbe Well-Known Member

    It is better to test root with any simple (like AdFree) app from the market. Titanium backup needs BusyBox to work.
     
  10. premiump

    premiump Well-Known Member

    That worked a treat mate, cheers.

    Attempting a full install of Modaco ROM 3.2 ...

    Here goes nothing ...
     
  11. premiump

    premiump Well-Known Member

    Massive relief, my phone still works, even managed to update the Radio to the latest version :D

    One thing though, my Firmware version still says it is 1.5 :(

    What have I done wrong?
     
  12. Jaffa

    Jaffa Android Expert

    Modaco 3.2 is not a 2.1 rom, its based on 1.5

    Try vilain 5.2
     
    premiump likes this.
  13. kingvortex

    kingvortex Well-Known Member

    You've done nothing wrong. Modaco 3.2 is based on Android 1.5 ;)
    If you want Android 2.1, there are several roms out there, the most popular being probably Villain 5.2 and SenseHero 2.1.
    Have a look around XDA Developer's Hero development section-
    Hero, G2 Touch Android Development - xda-developers
     
  14. aidan257

    aidan257 Well-Known Member

    I think i'm getting somewhere guys. I can flash the roms, but they never boot up. :S It either sticks @ the HTC screen or gives me a blank screen. Luckily i've done a Nandroid backup which works. I just can't seem to get a custom rom to work.
     
  15. jUsT2eXy

    jUsT2eXy Android Enthusiast

    wait 5-10 mins. if it is still stuck pull out the battery and restart and wait

    the rom is transfering your app to the sd card.. it takes time..
     
  16. Jaffa

    Jaffa Android Expert

    Yeah, mine took a while the first time..
     
  17. premiump

    premiump Well-Known Member

    2.1 goodness with Villain 5.2 :D

    So, before I start re-installing all of my apps (noted before the wipe), I need to figure out the apps2sd stuff.

    Great forum, many thanks :D:D
     
  18. MattGarner

    MattGarner Newbie
    Thread Starter

    Thanks for everything! :D


    -----------------------------------

    Yeah on first boot it does seem to take a while.
     

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date
0
Reviews
Loading...
Similar Threads - root
  1. regressist
    Replies:
    0
    Views:
    277
  2. Truck Davis
    Replies:
    16
    Views:
    1,490
  3. Marvin P Droid
    Replies:
    19
    Views:
    927
  4. Yesi Trotamundos
    Replies:
    4
    Views:
    514
  5. enby_dashie
    Replies:
    3
    Views:
    737
  6. Yesi Trotamundos
    Replies:
    5
    Views:
    404
  7. Yesi Trotamundos
    Replies:
    9
    Views:
    813
  8. Yesi Trotamundos
    Replies:
    6
    Views:
    875
  9. asiopat9
    Replies:
    2
    Views:
    771
  10. kumaranil13k
    Replies:
    4
    Views:
    741

Share This Page

Loading...