1. Download our Official Android App: Forums for Android!

Support Can not register to network

Discussion in 'Android Devices' started by kofuukali, Dec 17, 2009.

  1. kofuukali

    kofuukali Member
    Thread Starter
    16

    Oct 7, 2009
    49
    3
    16
    Hey guys,
    Serious issue here with my galaxy.
    I was coming back to Denmark from Sweden yesterday, and my phone was working fine on roaming all this time.
    As my train crosses to Denmark, I lose the network, and very much since then have not been able to get it back.

    If I manually go into search for networks, it will take a minute or so, and sometimes finally find some networks.
    If I choose my home network, it will try for 2-3 minutes, and fail 90% of the time, and sometimes succeed. (that is act as if I was connected with 4 bars, but still, when I send myself an SMS from another phone, or try to call, nothing comes up).

    The more I try, the less it seems to work. I fear my internal antenna might be f***ed or something... could that be?

    I know it is not the sim, or the provider, as I have switched sims with another phone, and the sim works on the other phone, just like the other phone's sim doesn't work on my galaxy.

    I am running Galaxo1.1, but as I said....this problem started occuring without my even handling the phone at that time.
    Please help...
     

    Advertisement

  2. kofuukali

    kofuukali Member
    Thread Starter
    16

    Oct 7, 2009
    49
    3
    16
    Two things I forgot to mention.
    Sometimes when I get out of lock, a message comes up saying "Network with Limited Service found. So you want to initiate a Network search", appears.
    And the last time I did one of these repetitive network searches to try to connect, I got a application crash from "android.phone"!!
     
  3. kam187

    kam187 Android Expert
    118

    Aug 3, 2009
    1,320
    46
    118
    UK
    Hmm strange, doesnt sound like the antenna. Sounds more like an authentication problem. Are you back to where you knew it was working? i.e. back to a home town where it worked before.

    Is the second sim on the same network?
     
  4. just in case: you have tried rebooting, right?
     
  5. spottyelephant

    spottyelephant Android Enthusiast
    63

    Jul 31, 2009
    550
    17
    63
    That happened to me while i was in the states. I'm also running galaxhero. I can't remember exactly what i did, but when i came home I turned off data roaming, made sure that "use wireless networks" to determine my location was on, and then used my 3g connection it seemed to sort itself out. Havent had a problem since.
     
  6. kofuukali

    kofuukali Member
    Thread Starter
    16

    Oct 7, 2009
    49
    3
    16
    That's very interesting. And it got my hopes up really high there for a second, as when I switched off "allow data roaming", suddenly my connection came back up. 3G and all!!
    Unfortunately, my joy was short lived, for as soon as I tried actually suing the network, it dropped straight back down. And that is also the case if I use APNDroid to disable data. I get a network that drops as soon as I place a call...
    Anybody got some insights on what could be the problem here?
    It has got something to do with the "enable data roaming", that is for sure, as that is the only setting that gets anything out of it (albeit for a very short time).
    It was also the first time I actually used data roaming before.

    Has anybody else activated data roaming before and used it in another country (which is of course, a very bad idea, as I realised that my 1 minute 30mb quicktime download, cost me 100
     
  7. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    what is this apn droid?

    ive seen it a few times and never looked into it but most people that mention they have it also mention they are having wierd phone and internet related problems
     
  8. kofuukali

    kofuukali Member
    Thread Starter
    16

    Oct 7, 2009
    49
    3
    16
    APNdroit is program that disable all data related activities and transforms your phone into a basic old fashioned phone (+mp3 player).

    Very useful when you are low on battery for instance and want to stay reachable.
     
  9. informale

    informale Android Enthusiast
    68

    Oct 25, 2009
    704
    33
    68
    Scotland
    APNDroid is the same as Toggle Data app. It basically renames the APN address in your apn settings, so that the phone cannot use data transfer. APNDroid disables all APNs, whereas Toggle Data can ignore your MMS APNs.
     
  10. spottyelephant

    spottyelephant Android Enthusiast
    63

    Jul 31, 2009
    550
    17
    63
     
  11. kofuukali

    kofuukali Member
    Thread Starter
    16

    Oct 7, 2009
    49
    3
    16
    Well that was very precise information. And you need not have a bad conscience anymore. It works :D
    I can't say that I followed your instructions, as I didn't see it in time, but Rastaman's queries about APNdroid lead me to try uninstalling it anyway (along with another set of random manipulations), and it ended up working, somehow....
    So to anybody suffering from the same problems, follow spotty's indications, uninstall apndroid...and pray to the god's of android (that would be google I guess...)
    I have since reinstalled and reused APNdroid, so it really just might have took an uninstall, re-install.
    Oh and I also had manually deleted my APN, and rewrote it...
    Try it all and hope it helps. And thank you spotty.
     
  12. KlaymenDK

    KlaymenDK Android Expert
    143

    May 29, 2009
    1,217
    130
    143
    Denmark
    kofuutali,
    is your provider "3"? If so, there are a couple of notes:

    3 only provides 3G coverage, and had partnered with TDC for 2G coverage. Recently this partnership was cancelled -- without any warning or even info to the customers :eek: -- so if you can't get a 3G connection somewhere, your phone may be able to see other networks but will refuse to connect to them.

    I found out about this last month, while my phone was in for repair and I (tried to!) rely on my Treo. I could see all sorts of networks, but could get no connection; it took a number of support calls to get the above info out of them.
     
  13. kofuukali

    kofuukali Member
    Thread Starter
    16

    Oct 7, 2009
    49
    3
    16
    Nope, I am on telenor. But what you say is interesting.
    Thanks for the input
     
  14. kofuukali

    kofuukali Member
    Thread Starter
    16

    Oct 7, 2009
    49
    3
    16
    Well... this is a last call out for help, as I have in fact practically given up on the concept of 3G on my super advanced high technology samsung galaxy phone...
    the rare times I get it, i feel like I just got upgraded to a brand new phone...
    So before I completely give up until HTC desire comes out, and keep paying bills for 3G connection that I don't use, I was wondering if anybody had extra input on this issue.

    It seems to me, although this was originally linked to some roaming activity, that the problem has been getting worse and worse, I have now been weeks away from my last roaming, and have battled everyday to try to get 3g back to work, but helplessly.
    At first I thought it was maybe firmware, nope, tried them all, even galaxo or 1.6 changes nothing.
    I know nobody that has the same issue, be it in denmark or in france.
    Have tried different sim cards, no change there, it is definitely in the phone.
    And therefore... i can only imagine it to be some kind of hardware deficiency in my galaxy. Obviously a rare occurrence too as so few people are complaining about it.

    So... does anybody know if I can get samsung to change my phone (I can not ask my provider, as my phone was originally bought of a french provider, and is now on a danish one, that had nothing to do with selling me the phone).
    Any advice as to how I should approach samsung on this one?
    thanks a bunch
     

Share This Page

Loading...