1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can not use odin on Prevail, but not a total brick

Discussion in 'Android Devices' started by xuare, Jan 4, 2012.

  1. xuare

    xuare Newbie
    Thread Starter

    I'm at a loss. My phone won't flash with Odin. I get three possible outcomes:

    First, when I use only PDA and Phone images:

    Second, when I use the boot image as well:

    I also tried CyanogenMod beta's one-package, which fails as well. The closest I ever got to having an upload work was the first one that bombed out on step 1 when downloading the boot image when one wasn't specified. I killed it after over 10 minuets of waiting. It was running from a network drive.

    The current ODIN results are run locally from the C drive. The phone boots afterward far enough to enter adb shell commands in recovery mode, however it cannot boot all the way due to my attempts to symlink system/apps (see http://androidforums.com/samsung-ga...op-after-deleting-system-app.html#post3756020)

    Any ideas? I have a useless phone if I can't either reflash it or find a way to regain root via adb shell in recovery mode (i.e. w/o the SuperUser app able to run, or any java/gui based program).

    The Prevail in question came stock from Boost with 2.3.1 IIRC

  2. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓

    Try to use the ee14 Odin image. See if same result, re download ejo6 image try again, download stock ejo6 try... Well you get the idea...
  3. xuare

    xuare Newbie
    Thread Starter

    I've rotated between the rom images and retried so much I worry I am going to break the usb port from fatigue. I was hoping for some...lower level help. For instance, is it possible to upload the raw images via TFTP?
  4. hroark13

    hroark13 Android Expert
    Recognized Developer

    There is no CyanogenMod beta's one-package

    Did you try flashing all three tars?
    Does the phone reboot after Odin load the image and says reset?
    Can you get into recovery (vol up and power)?
  5. xuare

    xuare Newbie
    Thread Starter

    -I have tried flashing all three images. Anytime the Boot image is in the set I get instant FAIL (I have tried different combinations of the three images)

    -Anytime it is the Phone, PDA, or both Phone and PDA images, the upload remains in START and produces no output after the last "big partition size!" warning. I let in run last night and it dies at 533 minutes when the battery gave out.

    The instructions for the one package came from HROAK_CWMv5_SPH-M820 readme.txt [may not be CM as indicated previously, sorry). I tried both the mod and the recovery file. Other ROM's I have tried are SPHM820_EJ06-CWM5-Rooted and (per Lordvincent's idea) SPHM820_EE14_FACTORY.
  6. hroark13

    hroark13 Android Expert
    Recognized Developer

    reboot computer
    try again
    unplug sdcard from phone
    try again
    unplug battery for 30 seconds and put back in
    try again
    try different USB port
    try again
    try different USB cable
    try again
    try different computer
    try again

    It should not take longer than 5 minutes for Odin to finish loading all three tar files

    You have to select the OPS and and all three tars at the same time, One package should NOT be unchecked for this (installing ROM)

    If after all this, if it does not work, your phone may have some type of hardware failure.
  7. xuare

    xuare Newbie
    Thread Starter

    I am about to try with my Touchpad's USB cable (thicker, higher gauge wires may provide better signals). After that, I can try the new computer, but it would be a slower Pentium II. The current computer was completely reformatted and only used for this recovery process (can't connect to anything outside our LAN).
  8. new optimus

    new optimus Android Expert

    not all cables are able to transmit data to samsung phones, I have an older samsung eternity 2 and a couple of lg phones that all have the same connecter yet only the samsung cable and the prevail stock cable can transmit data.
  9. xuare

    xuare Newbie
    Thread Starter

    Neither the USB cable nor the PII w/ Win2K seem to have worked. I'm at a loss.
  10. Alsaces Daddy

    Alsaces Daddy Android Expert

    I've been having the same trouble getting my usb to connect to my computer. Thing is my wife's phone connects with both usbs that I have and same computer. Oh, and we both have prevails.
  11. Bandaid

    Bandaid Android Enthusiast

    Xuare, when using odin and selecting
  12. xuare

    xuare Newbie
    Thread Starter

    Bandaid: All the files I have been attempting to upload into the phone via Odin are TAR (tape archive) files. This is how they came out of the image archive, which was a ZIP. i.e., "SPHM820_EJ06-CWM5-Rooted-rfsCache.zip" contained Odin 4.4.2 and a Phone, PDA, and Boot TAR file. Odin gave no warnings upon using these files.
  13. Kcsuper

    Kcsuper Well-Known Member

    I'm wondering if you manipulated/broke a vital piece of hardware in your phone.
    Can you use odin to flash back to Froyo (I think you can do that right?).
    What about using only the .ops and just one .tar like only PDA or only Phone...it obviously won't complete but see if it deivers any additional progress.
  14. hroark13

    hroark13 Android Expert
    Recognized Developer

    Which CyanogenMod beta's one-package ?

    What is 2.3.1 IIRC ?
  15. Koumajutsu

    Koumajutsu Android Expert

    If I Recall Correctly :)
  16. Kcsuper

    Kcsuper Well-Known Member

    LOL @ Kouma, I actually googled that acronym.
  17. new optimus

    new optimus Android Expert

    if it came with gingerbread it is fairly new it could be possible they made a hardware change.
  18. Koumajutsu

    Koumajutsu Android Expert

    Stupid question, but you are putting the phone in download mode first, right?
  19. Bandaid

    Bandaid Android Enthusiast

    I just wanted to make sure you unzipped the main zip file and not the other zip files that were included.
  20. xuare

    xuare Newbie
    Thread Starter

    Thanks for all the interest!

    -The phone is in download mode (down vol, camera, power)
    -I have tried using just one type of image in a flash (usually PDA, but also phone and boot)
    -The name of the "one package file was "HROARK_CWMv5_SPH-M820_Odin_1P.tar", from HROARK_CWMv5_SPH-M820
    -I don't think Odin cares about the file, as I have tried a few different images. I don't have high hopes about Froyo or other images, as the phone doesn't ever change as a result of flashing.

    I think my problem is over for now, as I have managed to exchange the hardware. Troubleshooting is great for building experience and knowledge, however my time has become limited recently and I needed to have a working phone.

    EDIT: Final thoughts

    To those who deal with this kind of issue, here are some lessons learned:

    -Don't try to flash a phone through Parallels or VMWare. The Samsung USB drivers are special, low level drivers that cannot operate properly when translated through the standard USB systems of MacOS / Linux / etc.

    -Don't blindly mess with your sdcard. The Android JVM is critical to the GUI and system, and doesn't mount at boot. Android doesn't use standard fstab and mounting procedures for the sdcard.

    -Don't turn your USB debugging off. This has security issues for the phone, so if this is a concern you will need to find other mitigations for losing a phone with personal information on it.

    -Test your phone's flash-ability early, and use WinXP SP2 or newer w/ ODIN. It is possible for ODIN to not work, which will limit the amount of tinkering you will want to do with the phone.

    If you are really paranoid, you will want to create a personally secured version of su or rootsu with the suid flag set. Basically, some way of getting root without using the GUI / JVM / Superuser.apk so recovery mode & adb can be used to make changes. You very likely will NOT want to store this binary on the phone (security)
  21. xuare

    xuare Newbie
    Thread Starter

    On an interesting note, my new phone has "all the old flash symptoms" of the old one. At this point I'm left with two conclusions. More likely, I'm doing something wrong (for the life of me I can't figure out what), or there's an Odin block in the newer phones. The new phone came with 2.3.5 installed.

    Given my past pain, I'm not going to worry about flashing it, though I do have the su process stored to allow root access when I do Su from the adb shell... just in case :)
  22. wetbiker7

    wetbiker7 Extreme Android User

    Thanks for taking the time to share your info with the Forum . :)
  23. inigomontoyasr

    inigomontoyasr Android Enthusiast

    just catching up.

    what OS and Odin version are you using to try this?
  24. hroark13

    hroark13 Android Expert
    Recognized Developer

    The problem the other person was having, was he was not using the Odin that came with the zip file

    he was downloading another version of Odin from the internet

    I dont think Odin is being blocked on new phones

Samsung Galaxy Prevail Forum

The Samsung Galaxy Prevail release date was April 2011. Features and Specs include a 3.2" inch screen, 2MP camera, GB RAM, MSM7627-3 processor, and 1500mAh battery.

April 2011
Release Date

Share This Page