1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can someone recommend a good file manager?

Discussion in 'Android Apps & Games' started by Djard, Dec 15, 2013.

  1. Djard

    Djard Newbie
    Thread Starter

    I'm looking for a file manager that is capable of creating shortcuts as well as accessing a microSD card added to an Android tablet. That rules out 'ES File Explorer' and others like it that can't access an added SD card. I contacted the developer of ES File Explorer who kindly responded with, "We are working on it."

    I accessed the added SD card using Windows Explorer from my PC and created folders, named video, music, and photos. But I can't create shortcuts to the home screen for those folders. I'm hoping a fully functional file manager exists for Android (v4).

    'ES File Explorer' was uselessly recommended to me by well-meaning folks. Hopefully an experienced person who has actually used such an app for managing files on a microSD card will help me with a better recommendation. I don't mind paying for the app.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. funkylogik

    funkylogik share the love peeps ;)

    Im not sure what im missing here but i use ES and im able to access any file on my phone including the micro SD :thinking::thinking:
     
    gtbarry likes this.
  3. saptech

    saptech Android Expert

    I just verified, I can access my external SD card using ES File Explorer.
     
  4. Petrah

    Petrah Psychotic Female

    Yes, we've experienced this as well. Like you we're waiting for the ES devs to fix it.

    There was one on the Play store that I found that had been updated to work with Android 4.4, but it was extremely buggy when trying to maneuver things around in the MicroSD.
     
  5. saptech

    saptech Android Expert

    I'm not sure what I'm missing. I don't know about creating shortcuts but I can access my SD Card.

    What issue are they working on?

    **Edit**
    Ok I get it, you can't create shortcuts to the home screen using ES.
     
    funkylogik likes this.
  6. funkylogik

    funkylogik share the love peeps ;)

    Ahh. I thought he just couldnt access it. dont think ive ever made a shortcut to a folder.
    it can certainly access and manipulate the external SD (extSdCard) though on my phone anyway running 4.4.2.
    Are you looking in /MNT op?
     
  7. funkylogik

    funkylogik share the love peeps ;)

  8. funkylogik

    funkylogik share the love peeps ;)

    And i just added a shortcut uploadfromtaptalk1387176183533.jpg
    Just long-press the folder, hit "more" at the the bottom right then select "add to desktop" :thumbup:
    Im actually glad i read this thread lol. Its gona be handy having a shortcut to my /downloads folder. And with a custom launcher you can make the shortcut look less ugly than in my screenshot :)
     
  9. saptech

    saptech Android Expert

    funkylogik, did you do that using ES? Well, I just figured out how to do it using menus within ES. I'm doing this on my tablet, haven't tried it with phone yet.

    Open ES, Select the folder, at the bottom menu where it show the Delete option, select More, and choose Add to Desktop.

    I have never really tried to create shortcuts either but it is good to know.
     
  10. funkylogik

    funkylogik share the love peeps ;)

    Exact same as u bro :D we're always learning eh :beer:
     
  11. saptech

    saptech Android Expert

    Wow, it's time for me to goto bed. I thought you had something different. :)
     
  12. funkylogik

    funkylogik share the love peeps ;)

    Lol its 7am here, im just gona stay awake until tonight :):beer:
     
  13. Petrah

    Petrah Psychotic Female

    We cannot access the MicroSD card from within ES File Explorer. It says "Invalid Path". The ES developers are working on a fix for it (ie; they are aware of the problem).

    My boyfriend began having the issue on his unrooted stock Google Edition Galaxy S4 when he updated using the OTA install for Android 4.4.

    I began having the issue tonight when I flashed CyanogenMod 11 (Android 4.4.2) on my Google Edition Galaxy S4.

    I haven't tested it yet on my Google Edition Galaxy Nexus.
     
    funkylogik and saptech like this.
  14. saptech

    saptech Android Expert

    It is 1am here in the States, Central time.

    So it's version 4.4 issue I assume. Whewww, glad we got that sorted.
     
  15. funkylogik

    funkylogik share the love peeps ;)

    But ive used CM11 since the first experimental build and im up to 4.4.2 now and its always worked for me. I save all my nandroid backups to external SD and i always edit the file name so i know its always worked. Must be a device specific issue? Im on the international s3
     
  16. Djard

    Djard Newbie
    Thread Starter

    I believe the version of Android on my tablet is 4.0.1, so maybe that's why 'ES File Explorer' won't permit me to access my files on the ext. SD card. I see a tiny icon up top "sdcard"; tapping does nothing. But tapping "Window" in the right pane brings up "sdcard," "LAN" and "Cloud." All three of these icons have a red "x" in the top right corner. Interstingly, ES File Explorer shows in its history: "sdcard 26.66/1.71 GB" and "extsd" (2.43 GB/29.71 GB)."

    The resident file manager lets me access the SD card but not create a shortcut on the home screen. But it does show a path to the ext. SD card /mnt/sdcard.

    Man, after becoming familiar apps like Windows Explorer and managing them with wonderful 'Registrar Registry Manager', Androids apps seem like barebone stuff. Yeah, I know... I'll have to acclimate.

    It appears that I need to upgrade to the latest version of Android or find a a good file manager compatible with version 4. Is it even possible to upgrdae to a later version?
     
  17. dvhttn

    dvhttn Android Expert

  18. funkylogik

    funkylogik share the love peeps ;)

    In ES settings, Directory Settings> Home Directory> try setting the home directory as deep as you can go. I have it as "/" but im rooted. Maybe you can set it to "/mnt/" then you should be able to see "extSdCard" (your micro Sd)
     
  19. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

  20. macavsk

    macavsk Lurker

    I am using Total Commander and works really good :) I also tend to open movies from network shares with it..
     
  21. franticbleep

    franticbleep Lurker

    I installed. Es and i noticed. My (com.lge filebrowser. APK) was gone! !!no problem. Cause. I could. Just reinstall.... nope the. File doesn't. Exist. Anymore #%@!
     
  22. Petrah

    Petrah Psychotic Female

    Blah, I had this long thing written out and Chrome just decided it wanted to close. :mad: At any rate, something wonky is going on. I use to be able to store all of my Alarms, Notifications, and Ringtones on the MicroSD, which worked just fine pre 4.4. Now the phone will not see them when I try to set them with the phones Media Storage. Even more odd, JetAudio can pick up and play all of my songs stored on the MicroSD. Even QuickPic picks up images stored there.

    None of the file managers I've tried work. Even the ones that do see the path for the MicroSD, they're buggy as all get out (ie; copy/cut from/to MicroSD works when it feels like it, or leaves a ghost file that doesn't really exist).

    Check out the paths. The last image there, notice how it doesn't even see that the MicroSD is there, and you get an "invalid path" error if you try to tap on it. But if you look at the center image where ES shows two ways you can get to the MicroSD... both of those work if you tap on them.

    So.... what's QuickPic and JetAudio doing that these file managers cannot? :thinking:

    [​IMG]

    [​IMG]

    [​IMG]
     
Loading...

Share This Page

Loading...