1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can this Tablet Be Rooted

Discussion in 'Android Help' started by ADR2, Mar 6, 2016.

  1. ADR2

    ADR2 Newbie
    Thread Starter

    I now own a three day old tablet with a trojan in an area that requires a rooting, according to to Stubborn Trojan app.

    Unfortunately, I am a novice android user and have never rooted a device so, I'd love to find some help, here.
    The following is as much info as I could obtain about my device:
    Processor…….AllWINNER A83T Octa-Core Cortex-A7 2.0 GHz
    PowerVR SGX544
    RAM 1 GB
    Storage 16 GB flash built-in
    Networking Wi-Fi IEEE 802.11 b/g/n
    USB Interface USB 2.0 hhi-speed
    Operating System Android 5.1.1

    About Tablet screen info:
    Adroid Current version: A83T_N106_N1061L7BC_1512248.201601330
    Model number A10
    Processor type UltraOcta-A83
    Android version 5.1.1
    Firmware version v2.1rc3_20151211
    Kernel version 3.4.39
    Inet_fyf@suppperFAE #30
    Sat Jan 30 14:06:09 CST 2016
    Build number A83T_N106_N1061L7BC_1512248.201601330

    May be the same as Infocus C2107, according to one internet review.

    This is a link to the seller and a description of the tablet: http://www.amazon.com/gp/product/B01B50DXEI?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00

    I ran another app and the root is not accessible so rooting has to be performed.
    I don't mind reading so, any links that are suggested reading are appreciated and any step-by-step advice is also, greatly appreciated. I downloaded several free apps and infect is confirmed.

    1. Download the Forums for Android™ app!


  2. ADR2

    ADR2 Newbie
    Thread Starter

    This is the virus that infected it:
  3. ADR2

    ADR2 Newbie
    Thread Starter

    Further testing with diagnostic apps exposed Android.Troj.at_xbkp.a has infected the app updater in my system. Can this be somehow replaced wtihout rooting or do I have to root the
    Astro Tab A10 - 10 inch Octa Core Android 5.1 Lollipop Tablet PC, 16GB Nand Flash, 1GB RAM, IPS Display 1280x800, HDMI, Bluetooth 4.0, Google Play?
  4. Wanitto

    Wanitto Newbie

    Not an expert, just a bored man waiting for my question to be answered. But since the machine is 3 days old, why not just wipe and reset it (this can be found in Settings, usually under ¨Backup and reset¨)? This might fix the issue. It's probably safer than attempting to root, and running a bunch of stuff which might damage it further. As far as I know, every android device can be 'rooted', but I'll leave that to the experts.

    If you don't want to do that, try installing Avast AntiVirus, or MalwareBytes Anti-malware... maybe - this worked for me once upon a time. Do update the page if the problem is fixed.
  5. ADR2

    ADR2 Newbie
    Thread Starter

    Thanks for your input, Wanitto. I already did a reset. I had only added a few apps. But, foolishly didn't do a backup for future restore as soon as I turned it on, the first time. Instead, I (foolishly, again) went to a free movie site that doesn't have the best reputation (I knew that). After the infection, I down loaded and ran StubbornTrojan and it identified the virus as AppDropper.Android.SilentSecret.a.
    Another Trojan finder id'd it as Android.Troj.at_sbkp.a . It has set up residence in the App Updater within the System and all that I can do is ForceStop App Updates which isn't going to work too well in the long run. At least the tablet works but, the Tojans both have a reputation for stealing info and, although I've changed my Google Password, twice within the last three days, I'm still concerned that my privacy has or will be violated. I wish I knew how to root. The tablet was $99 so, it's not a big loss. My only reason for buying it was to use it to mirror movies to the Smart TV but, I never got to realize the goal.
    Thanks, again, for your input.
  6. mikedt

    mikedt 你好

    Cheapo Chinese tablet, anonymous manufacturer. Almost certainly it came with the root trojan malware from the factory. As for doing anything about it yourself, good luck I think. It would be best to RMA it to the Amazon vendor for a refund, and if they're uncooperative, take it up with Amazon. And then get something decent like a Nexus or something.
    psionandy likes this.
  7. Wanitto

    Wanitto Newbie

    Buying a new one isn't ever a solution. Rooting isn't that difficult. Read up on how to (1) unlock bootloader, (2) flash recovery image (such as TWRP), (3) flash SuperSU from TWRP. Device should then be 'rooted'. I believe these are all generic softwares, but the process may differ depending on the device. If you are able to find it for your device, try flashing another ROM (operating system) while you're at it, after wiping the system.
  8. psionandy

    psionandy Extreme Android User

    Good luck with finding a rom for a third party generic Chinese tablet device...
  9. Travis Fryman

    Travis Fryman Lurker

  10. Travis Fryman

    Travis Fryman Lurker

    Not sure if this is too late for you, but I was able to easily root this tablet with Wondershare Mobilego one touch root on PC. From there I just updated binaries, etc. with supersu pro. Hope you were/are able to resolve the issue!
  11. ADR2

    ADR2 Newbie
    Thread Starter

  12. l3lank

    l3lank Lurker

    Use kingo root apk if it fails try again

Share This Page