1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cannot Connect my Nexus 5 to my laptop via USB

Discussion in 'Android Devices' started by shravan1985, Oct 5, 2014.

  1. shravan1985

    shravan1985 Lurker
    Thread Starter

    I am trying to connect my Nexus 5 to my Laptop via USB.
    Each time it detects the phone but the driver installation says Failed.

    I have tried every possible thing.

    Please help.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. xdrc45

    xdrc45 Android Enthusiast

    Hello shravan1985 and Welcome to AF.
    Depending on your windows version and what driver package you use, you may run into issues trying to install the drivers properly.... Since there are a couple different driver package's, like the Universal Naked Drivers, LG Drivers and the Google drivers.
    The easiest solution would be to try using WugFresh's Nexus tool kit. The program has a driver installation and un-installation wizard that will help you to configure and install the proper drivers for tour N5 to your PC.
    Take a look here - Nexus Root Toolkit v1.8.8 | WugFresh

    Hope this helps and good luck! :thumbup:
     
  3. shravan1985

    shravan1985 Lurker
    Thread Starter

    Thanks my friend. I tried, but in vain.
    The installation to MTP USB to Device still fails n I do not see any additional drive on my explorer.

    Please check the image below

    [​IMG]
     
  4. xdrc45

    xdrc45 Android Enthusiast

    What version of Windows are using?
    Have you tried switching back and forth between MTP and PTP mode?
    Also have you tried enabling and/or disabling USB debugging mode in developer options?
     
  5. shravan1985

    shravan1985 Lurker
    Thread Starter

    Im using windows7 64 bit.
    Yes, I tried both, but it shows the same error.
     
  6. xdrc45

    xdrc45 Android Enthusiast

    OK. I know that Windows media player has a role in installing MTP drivers... So make sure that Windows media player is updated to at least 10.1 or higher.

    Also you may need to install the MTP Porting Kit from Microsoft. (I had MTP issues and installed the Porting Kit and updated the media player and it resolved my issues)
    Take a look here - Download Media Transfer Protocol Porting Kit from Official Microsoft Download Center
     
  7. shravan1985

    shravan1985 Lurker
    Thread Starter

    No Luck :(
    Still the same error
     
  8. vandyman

    vandyman Android Expert

    Go to the settings on your N5;
    storage ;usb computer connection. And toggle the MTP device box.
     
  9. shravan1985

    shravan1985 Lurker
    Thread Starter

    That was the first thing i did.
     
  10. xdrc45

    xdrc45 Android Enthusiast

    You may want to try and use the WugFresh tool kit and follow the directions and use the driver program to uninstall all the drivers installed for your N5 and then use Wugs driver program again to reinstall the drivers.
     
  11. shravan1985

    shravan1985 Lurker
    Thread Starter

    I have tried that too..The wugfresh drivers showz as a Success..but it fails to show any additional drive on my explorer.
    Also, on connecting the device, it showz Installation Failed.
     
  12. jj14x

    jj14x Android Expert

    In device manager, do you see an ACER ADB Interface device listed? If so, right click to go to properties
    On the the Driver tab, click update driver. Click browse my computer and "let me pick"
    Select MTP USB Device and click next
     

Nexus 5 Forum

The Nexus 5 release date was November 2013. Features and Specs include a 4.95" screen, 8MP camera, Snapdragon 800 processor, 2300mAh battery, and 2GB storage.

November 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...