1. Check out our companion app, Forums for Android! Download from Google Play

Root Cannot Connect To Camera

Discussion in 'Android Devices' started by lightningdude, Feb 15, 2011.

  1. lightningdude

    lightningdude Well-Known Member
    Thread Starter
    23

    Oct 9, 2010
    86
    28
    23
    Just recently, I have been trying to use my camera in vain. Every time I try to access it, either by the camera itself or through an app such as Layar or Barcode Scanner, I'm met with an error, basically saying that I'm unable to connect to the camera. If anyone has any suggestions other than resetting to stock v6, let me know. If I don't get any good ones in about 8 hours, I will be resetting. I'm on velocity 1.0, by the way.
     

    Advertisement

  2. Afteraffekt

    Afteraffekt Well-Known Member
    53

    Nov 1, 2010
    354
    76
    53
    Computer Electronics Engineer
    South Carolina
    We need an actual error code, not a "basically". Not being rude, just being honest! Get us that and we'll do what we can!
     
  3. lightningdude

    lightningdude Well-Known Member
    Thread Starter
    23

    Oct 9, 2010
    86
    28
    23
    Like a logcat? Otherwise, I don't know what kind of error code. I'm at work right now, otherwise I'd hook up to a computer to do a logcat.

    Edit: After running a logcat, the only thing that jumped out at me is:

    E/QualcommCameraHardware( 1282): startCamera X: /dev/msm_camera/control0 open failed: Unknown error: 0!
    E/QualcommCameraHardware( 1282): createInstance: startCamera failed!
    D/AMCE ( 4261): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    D/AMCE ( 4261): Fail to connect to camera service
    D/AMCE ( 4261): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    I'm not sure if this tells you anything or not, but I'm pretty sure I'm gonna do a full restore.

    Edit 2: I just did a full restore to zv6 and then went through upgrades, camera still doesn't work. I guess it's time for a new phone.
     
  4. lightningdude

    lightningdude Well-Known Member
    Thread Starter
    23

    Oct 9, 2010
    86
    28
    23
    Well, just got off the phone with Verizon and they are sending me a replacement phone. Sorry to clutter the forum with this thread, but I didn't see this problem addressed anywhere else.

    The steps I took include going back completely stock, doing a factory data reset, reflashing Velocity 1.0, reinstalling the ArcCamera app, and restoring a nandroid from when my camera still worked. Not in that order. All that, but to no avail.
     
  5. Afteraffekt

    Afteraffekt Well-Known Member
    53

    Nov 1, 2010
    354
    76
    53
    Computer Electronics Engineer
    South Carolina
    Wow, All I can fathom is that the camera hardware got damaged in a drop or something, well atleast your getting a new phone!
     
  6. death2all110

    death2all110 Well-Known Member
    313

    Jun 25, 2010
    1,996
    1,210
    313
    Male
    Systems Administrator Windows/Unix
    Illinois, US
    I could tell by the logcat that it was hardware. Sorry i didnt see this sooner man, but afteraffekt beat me to it =P
     
  7. lightningdude

    lightningdude Well-Known Member
    Thread Starter
    23

    Oct 9, 2010
    86
    28
    23
    That's okay, I was thinking hardware from the beginning, but since I didn't know for sure, I figured I'd ask. New phone tomorrow, though.
     
Tags:

Share This Page

Loading...