Android Enthusiast
Mar 30, 2010
Slough, England
I am unable to factory reset my phone. Has anybody come across this before?

When I tried a factory reset by going into settings, the phone rebooted, but the screen stayed simply saying "Google". I had to pull out the battery. It started up OK, but hadn't been reset.

I tried by turning the phone off and using the volume and power buttons. I was able to select "Recovery Mode" using the volume buttons, but when I clicked on the power button to select "Recovery Mode", the phone just displayed "Google" and I had to pull out the battery again.

It's still starting up OK, but I still want to factory reset it.

I suppose I could try uninstalling all of my apps and then trying again. I would probably start with WidgetLocker. I'm not saying it's a bad app, but if it's starting before the lock screen, it could be causing problems.

I haven't rooted the phone. It's running 4.0.2. It tells me that the phone is up-to-date, so I can't upgrade to 4.0.4.