1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cannot get Android_x86 to boot from HDD

Discussion in 'Android Lounge' started by Mike Norkus, Jul 2, 2017.

  1. Mike Norkus

    Mike Norkus Lurker
    Thread Starter

    Hello all,

    I relatively new to android and have been searching high and low on web to resolve my issue. I got an Acer Aspire One for free and it had Windows Starter 7 on it, so I decided to install Android x86 on it. The specs for the processor is Intel (R) Atom N450 1.666GHz, I know that it is not very speedy but I figure Android should run on it fine. Anyway, I downloaded an Android 6.0 R3 32 bit ISO and installed on a USB, I can boot and run from the USB fine. I can also install it from the USB and it asks to install GRUB and appears to install fine. I can even run the OS from the HDD after the install but if I reboot, it comes back with non-system disk error. I do get an error when I try to Enter the Partition Software, "Warning!! Unsupported GPT detected. Use GNU parted." press enter and then "Fatal Error: Bad Primary Partition 0: Partition ends in the final partial cylinder, press any key to exit cfdisk". If I use cgdisk 1.0.0 I cannot partition the drive so that I have a bootable partition. Most of the instructions that I have reviewed use cfdisk but mine appears to be incompatible with my hardware. I am just not sure where to start, I under stand PCs pretty well and if I can get the syntax right :), I can navigate thru a terminal, if needed.

    I also tried running Android 5.1 32 Bit as well with the same results.

    Any advise would be greatly appreciated.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mikedt

    mikedt 你好

    Something to do with the BIOS settings possibly? What exactly are you trying to run it on, what's the PC? What build of Android-x86 is it, because some are built for specific hardware, like Asus netbooks.
     
    Bg260 likes this.
  3. Your hdd has a GPT. Try the 64 bit version. Or you'll have to wipe the entire disk and reformat it to MBR/MSDOS
     
    mikedt likes this.
  4. Paulyd0051

    Paulyd0051 Newbie

    I am in the same boat as you right now, I have a feeling I know what to do, and you risk bricking your tablet, but it could be worth it.

    You can keep the windows BIOS as far as I am aware (but I am still checking that). You will need to remove the boot sectors on your tablet that refer to the Windows boot.

    Go to the "Install" again the way you did it (ie F12, boot from USB, enter installation process) then go down to Create / Modify partitions and get rid of the ones you don't want.

    WARNING! I have not tried this yet. So I do not know if you can recover from this. When I read about the Windows RE it seems you could re-establish a new bootable USB. But.... I warn you, it does sound like this might not work.

    It also might work. I am going to post a thread soon with some screenshots (hopefully) to get more advice.
     
  5. Paulyd0051

    Paulyd0051 Newbie

Loading...

Share This Page

Loading...