1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cannot RElock phone so that unlock properly

Discussion in 'Android Devices' started by sps177, Sep 20, 2011.

  1. sps177

    sps177 Lurker
    Thread Starter

    I use a samsung captivate that was locked to Rogers. And now I am running it on Fido

    I have been having issues connecting to 3G for over 6 months now. I completely gave up on the idea and lived off 2G, until someone suggested that I had unlocked my improperly. I believe this to be the root of my problems. I need to figure out how to lock my phone, and then if I can unlock it it properly, all my problems will be solved. PLEASE HELP. I will now try and explain all the different methods that I have used

    The method I used initially was by extracting nv_data.bin file and using a hex editor to edit it to unlock. This did work, and my phone was working perfectly. But on a ROM update my 3G connectivity issues started.

    I have to explicitly state 'only 2G' on my network connections, otherwise I lose my voice connection as well (because somehow the voice connections runs over the data connection - and one wont work with the other)

    I decided to unlock properly - by buying a code off ebay. The code is based on the IMEI number of the phone.

    I tried locking the phone by entering *7465625*638*# and entered
    302720 (mnc/mcc for rogers)
    and my purchased nck code
    the phone even states that the lock code was successful. But on inserting my fido SIM, my phone acts like it did before - i.e. voice connection does work unless I explicitly select '2G only'

    Initially I also tried locking by reediting nv_data.bin file using a hex editor. The instructions state editing the address '0x181468' on the file. There are 5 different bytes representing different locks (network lock, subset lock, sp lock, cp lock, data lock) and they are represented in binary. On just changing 'network lock' to 01 to phone acts the same. But on changing all the values on all the bytes the phone locks and asks for an unlock code on restart - but the purchased nck code does not work

    This is over 6 months of trial and errror, so I apologize if I am all over the place. Please provide any suggestions and I will clarify as soon as I can
     

    Advertisement

Loading...

Share This Page

Loading...