1. Download our Official Android App: Forums for Android!

Support Cannot reply to SMS - area code issue

Discussion in 'Android Devices' started by seylerg, Sep 22, 2009.

  1. seylerg

    seylerg Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 22, 2009

    Sep 22, 2009
    2
    0
    5
    I am using the main android messaging app that came with the phone.
    I have set my contatcts to include the area code.
    I can send a new message to a contact and it includes the area code.
    But when someone sends me a text message, I open it from the notification bar, and it opens in the messaging app, but does not include their area code on the top so it will not let me reply to that thread.
    I have to exit messaging and send them a new sms.
    I would really like to just type my reply text and hit send.
    any thoughts would be great - thanks
     

    Advertisement

  2. justjimjpc

    justjimjpc Premium Member
    Rank:
    None
    Points:
    663
    Posts:
    10,543
    Joined:
    Nov 3, 2008

    Nov 3, 2008
    10,543
    210
    663
    Washington DC, USA
    Sounds like you may have downloaded another sms program ... if yes delete it ... restart phone ...


    Backup your Messages : "MyBackups PRO"

    Same Problem ...?? then go into settings | Applications | manage apps |

    Find "Messaging" and click on clear data..
    Restart Phone ...

    Your problem should be cleared ... if Not then you have something set strangely in your contacts ...
     
  3. seylerg

    seylerg Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 22, 2009

    Sep 22, 2009
    2
    0
    5
    Thanks Justjimjpc,
    Tried all on your list, but when I get a text the number still does not include area code. it is very odd.
    I can send a text to anyone in my contacts - it shows area code when I do this, if they reply to me - then it comes in without area code and I cannot continue to text them again until I go to the home screen and launch a text to a contact. The thread remains and all the info is there but if I reply from there most recent message it will not send as it is texting a 7 digit number not 10.
     
  4. wooden droid

    wooden droid Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 1, 2009

    Dec 1, 2009
    2
    0
    5
    I am whishing to let you know that this, is my exect problem. It causes much irritation. I have scoured the settings to find out what's up....no luck!

    I am running the Cyanogen mod for Android 1.6 on an unlocked G1.

    Any help would much be apreciated.
     
  5. Sweed

    Sweed Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    208
    Joined:
    Sep 27, 2009

    Sep 27, 2009
    208
    1
    56
    you don't need to put the area code if your in the same area as the other person.
    If you're both in the same area code, then don't put in their area code on the contact info
     
  6. wooden droid

    wooden droid Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 1, 2009

    Dec 1, 2009
    2
    0
    5
    Apparently (somewhat surprisingly, and defiantly) if one subscribes to the Fido network in Canada, the case might be different. It is in exactly that scenario (replying to a sms that comes from a 7 digit number) that it fails and requires that one put in the area code, to get the message through.​
     
  7. trunkwontopen

    trunkwontopen Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Dec 13, 2009

    Dec 13, 2009
    5
    0
    5
    I'm having the same issue, and I have not downloaded any other programs to manage the SMS / MMS threads. Some areas of the country (USA) will need to put the area code in there (NY for example)

    Anyone have any luck trying some things that are not mentioned in this thread? I'm only having this issue after I close out of the MMS thread (go back to the home screen, etc.) And..this is coming from the Nextel network.

    Edit: I spel guud.
     
  8. sedea

    sedea Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    1
    0
    5
    I am currently having this same problem

    I have a samsung captivate on the rogers network in canada, running 2.1

    I need to include the area code in all text messages (Even if within the same area code) for them to send successfully. However, with select contacts, if you send an SMS to them (including the area code), they reply back, and you try and respond to then, the area code has been dropped and you need to start a new message as opposed to replying directly.

    Deleting the contact info and all existing conversations, followed by re-entering the contact info does not solve this problem

    Using alternate SMS programs also does not solve this problem.

    I suspect the problem is a function of the fact that these contacts appear to be on Fido (MTS and rogers work fine), and something to do with how either the rogers network interacts with contacts on fido, or how android deals with info that originated from fido.

    I have been unable to find any solutions to this problem; though it does appear to be quite widespread.
     
  9. postalj

    postalj Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 12, 2010

    Dec 12, 2010
    1
    0
    5
    Funny, same problem, same phone. My problem arises when replying to Rogers texts.
    I get over it by just replying (which fails). Then I long press the failed message, click forward, and then enter the 10 digit number.
    If I want the treaded conversation to remain intact, I then long press the failed message and delete it. The 'forwarded' message remains in the conversation.
     
  10. tungxpii

    tungxpii Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 7, 2011

    Feb 7, 2011
    1
    0
    5
    It means we only can send NEW sms but cannot reply a exist sms
     
Tags:

Share This Page

Loading...