1. Download our Official Android App: Forums for Android!

Support Cannot restore Music.apk with Titanium Backup Pro

Discussion in 'Android Devices' started by mycroftholmes, Jul 30, 2011.

  1. mycroftholmes

    mycroftholmes Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 30, 2011

    Jul 30, 2011
    3
    0
    5
    Mods: Move this if I posted in wrong section. I apologize if I did.

    Searched and tried everything on forums and the web for a few weeks. Don't need it per se but this is just driving me crazy as this *should* be possible.

    Situation: Used Titanium Back Pro to test freeze several Sprint bloatware apps for several months. Had no system problems. Needed a bit more internal memory free and decided to uninstall the stock Froyo music app (which was frozen at the time I uninstalled it) because I use other music players and it has been listed as being safe to remove w/o system probs. I do encrypt my backups.

    LG Optimus S (LS670)
    Stock 2.2.2 Froyo ROM
    SW Version: LS670ZVD


    Before doing anymore uninstalls I wanted to see if i could restore this. Titanium Backup Pro just hangs indefinitely when trying to restore the stock music.apk app. Have to force stop it. Using Root Explorer and ES File Manager, I am able to see the app in the system/app folder after doing this but it does not show in the app drawer.

    What I've Tried:

    1. Contacted Titanium Support. Great guys and very helpful. Cannot stress this enough and the app is awesome. They suggested taking the apk from the backup files and moving it using adb.

    Result: Moved the file but would not show up in app drawer.

    2. Found the stock music.apk and .odex files in a LG Optimus S system dump. Moved them to the system/app folder using Root Explorer and changed permissions and ownership of files to match that of the other files in the folder, i.e. r-w-r-r and owner=root/group=root.

    Result: Tried rebooting. Did not work. Tried factory reset from Privacy Menu. Still not in app drawer.

    3. Tried Step #2 with ES Explorer.

    Result: Still no dice.

    4. Tried Step #2 but set permissions to all possible options.

    Result: Same.

    Is it possible that the Gingerbreak root software does not give "full" root for this phone? Every root checker shows full root and apps that require root work fine.

    I am able to use Titanium Backup Pro to convert files from system to user apps and vice versa with NO problems. Could it be because I un-installed the stock music app while it was frozen?

    I have the "Google Music" app installed but this shouldn't be a prob. It is installed as a user app.

    I know there are ways that I can restore the phone to its original state but it isn't necessary as I'm upgrading in a few months to the Nexus S. This is just more of a WTH question.
     

    Advertisement

Share This Page

Loading...