1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cannot set notification sound in Textra

Discussion in 'Android Apps & Games' started by ETtrailrunner, Jul 19, 2020.

  1. ETtrailrunner

    ETtrailrunner Newbie
    Thread Starter

    Hey;
    I just bought a new phone - Moto G7 Optimo Maxx (Tracfone) with Android 9 Pie.
    Before this phone I was using an LG Fiesta 2 with Android 7.

    I have been using Textra ver 4.27 as my SMS app, and on Android 7 it worked perfectly.
    But now on Android 9 I am unable to set the Notification Sound to anything but the default set for the phone.
    For example, I have the Default Notification Sound (in Apps & Notifications > Notifications > Default Notification Sound) set to Captain's Log.

    In Textra, I set the Notification Sound to Tinkerbell.
    But whenever a text comes in, I get the Captain's Log sound.
    If I set Default Notification to None, then I get no sound when a text arrives.

    I uninstalled and re-installed Textra, but this had no effect.

    Can anyone tell me what the problem is?

    Thanks
    ET
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Dannydet

    Dannydet Extreme Android User

    Go to settings, sounds, notifications, set it to a default sound....
     
    MrJavi likes this.
  3. ETtrailrunner

    ETtrailrunner Newbie
    Thread Starter

    Um, well, that's the problem. I can set the default notification sound in Android settings, but in Textra itself, no matter what sound I set for notification, I always get the default (Android) notification sound. I should be able to set a specific sound for Textra, no? That is how it worked in Android 7 on my old phone.
     
  4. Dannydet

    Dannydet Extreme Android User

    I believe with the newer version of Android this is not possible. Try installing Zedge from the play store as a work around.
     
    MrJavi likes this.
  5. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    No, I have custom notifications sounds for many apps, and have never installed any app for it. This is all with Android 10, July patch level.

    I've not used Textra for a few months, but it still uses the same custom notification I always use for SMS. And when I fire it up, change the sound and then test it the sound behaves as I'd expect.
     
    PitCarver and Dannydet like this.
  6. Dannydet

    Dannydet Extreme Android User

    Thanks Hadron, for clarifying that.
    I wasn't sure so I threw it out there.
     
    MrJavi likes this.
  7. ETtrailrunner

    ETtrailrunner Newbie
    Thread Starter

    Perhaps this is a limitation in the Moto G7 Optimo Maxx Tracfone? The phone is running Android 9 Pie. I may try Zedge, but I hesitate to install any app that is going to bug me with ads. I checked out their website, but it appears the 'premium' membership is for those who want to sell their art, not those of us who want to enjoy it without ads.
    Can someone clarify this for me?
    Thanks
     
  8. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I've heard people have such problems with the stock Samsung app, but that's rather specific (and I don't know how widespread).
     
    Dannydet likes this.
  9. knight1fox3

    knight1fox3 Newbie

    Hello. Sorry to revive an older thread, but I too am encountering an issue on my new Pixel 5 with Android 11 using Textra and not being able to customize the default notification sound for new messages. Tried installing Zedge but I don't see that having any impact on the options in Textra within the "Customize Notifications" menu. Any additional feedback/suggestions would be appreciated. Thank you in advance!
     
  10. ETtrailrunner

    ETtrailrunner Newbie
    Thread Starter

    I solved the problem.
    From what I recall, this is what I did:
    Open Textra, and go to settings > Customize Notifications > Notification Sound
    Select the sound you want, and hit OK at the bottom of the screen.
    Now, at the top of the screen, hit the right arrow > to have Textra bot send you a test text message.
    You should hear the new notification sound.

    If you simply hit the back arrow instead, the new notification will not 'stick'.

    I hope this helps you.
     
  11. Oshi

    Oshi Lurker

    I just got the new Sony Xperia 1 iii and had this issue but I found the solution.

    Android 11 - Textra Version 4.43

    - Hit the 3 dots at the top right
    - Select "settings"
    - Select "customize notifications"
    - Make sure "play notification sound" is on
    - Hit the "android settings" button under the notification style group
    - In the notification menu that pops up, hit the "advanced" drop down
    - select "sound" and choose your tone from the list
    - back out using the top left back arrow
    - hit the play button in the top right of the texts app to very the change.

    Hope this helps.
     
Loading...
Similar Threads - Cannot set notification
  1. Krawk
    Replies:
    14
    Views:
    543
  2. Jimbo Woods
    Replies:
    3
    Views:
    220
  3. TheOneGuy
    Replies:
    0
    Views:
    266
  4. sancho_s
    Replies:
    3
    Views:
    401
  5. Alan Silberman
    Replies:
    4
    Views:
    307
  6. Pedro Vera
    Replies:
    4
    Views:
    546
  7. metalman228
    Replies:
    3
    Views:
    787
  8. rwbil
    Replies:
    4
    Views:
    677
  9. brentc
    Replies:
    3
    Views:
    1,360
  10. WimYogya
    Replies:
    5
    Views:
    988

Share This Page

Loading...