1. Download our Official Android App: Forums for Android!

Support Cannot sync calendar

Discussion in 'Android Devices' started by lordofthemoon, Jun 15, 2011.

  1. lordofthemoon

    lordofthemoon Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    22
    Joined:
    Jun 15, 2011

    Jun 15, 2011
    22
    4
    16
    Software developer
    Glasgow, UK
    Hi,
    I just got my new Samsung Galaxy SII (running Android 2.3.3) yesterday and I've been playing with it and setting it up. I have configured it with my Google account (it's an @googlemail.com one if that makes a difference) but I don't seem to be able to sync my Google Calendar with the calendar app on the phone.

    When I go into the Calendar app settings -> Calendars, I don't actually see my GCal calendar there, just the default "My calendar". When I had first set up the account, I had seen my calendar there, but it vanished in a few seconds and I've never figured out how to get it back since.

    I've googled the question and have tried clearing the data for the calendar and even restored it to factory settings, but the same thing happened - it appeared in the calendars list for a few seconds as it was trying to sync and then vanished. Any ideas?

    TIA,
    Raj.
     

    Advertisement

  2. heshanj

    heshanj Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,251
    Joined:
    Jun 7, 2011

    im not sure if this could be the problem, but when u go to Accounts & Sync, and open ur google account, is ur Calendar set to sync? maybe this could be the problem, thats all i can think of. my google calendar shows as an option inside the calendar app like it should
     
  3. lordofthemoon

    lordofthemoon Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    22
    Joined:
    Jun 15, 2011

    Jun 15, 2011
    22
    4
    16
    Software developer
    Glasgow, UK
    Yes, I've checked and the Calendar option in that menu is ticked. Thanks for the suggestion though.
     
  4. lordofthemoon

    lordofthemoon Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    22
    Joined:
    Jun 15, 2011

    Jun 15, 2011
    22
    4
    16
    Software developer
    Glasgow, UK
    Ah, I'm not sure what's happened, but it's working now. I deleted the calendar data again in "Settings > Applications > Manage applications > Hit the Menu Button > Filter > All > Calendar Storage > Clear data" (despite having tried this before and it not working). Perhaps the difference was that I rebooted the phone after clearing the data this time.

    Thanks for all your help.

    Raj.
     
    Randy and Allee like this.
  5. ajh94

    ajh94 Android Expert
    Rank:
    None
    Points:
    148
    Posts:
    1,072
    Joined:
    Dec 15, 2010

    Dec 15, 2010
    1,072
    73
    148
    Orange Telecomunications, Product marketing!
    Essex, UK
    Glad u got it sorted :)
     
  6. colirv

    colirv Lurker
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    May 30, 2011

    May 30, 2011
    9
    0
    5
    Raj - I've just started a new thread called "Calendar reminders". I'd be grateful for your input.
     
  7. Allee

    Allee Lurker
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Jul 14, 2011

    Jul 14, 2011
    4
    0
    25
    Thanks so much for this - Orange sent us a new phone because we couldn't get the calendar to work and after going through all the levels of their technical support they suggested we look at these forums! Your method has worked, now I just have to figure out how to get picture messaging to work.....
     
  8. GeneralSunTzu

    GeneralSunTzu Lurker
    Rank:
    None
    Points:
    25
    Posts:
    5
    Joined:
    Jul 15, 2011

    Jul 15, 2011
    5
    0
    25
    Having the same problem, I tried the same solution, but my menu, in the same position does not display calendar storage>Clear Data.
    Please state your build number (under "About phone"). Mine is GINGERBREAD.XWKE7.

    Thank you.
     
  9. Randy

    Randy Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    129
    Joined:
    Jan 3, 2010

    Jan 3, 2010
    129
    6
    36
    Hey, that worked for me.. great, Thanks :)
     

Share This Page

Loading...