1. Are you ready for the Galaxy S20? Here is everything we know so far!

Cannot text to non-phone numbers?

Discussion in 'Android Help' started by RASelkirk, Dec 7, 2019.

  1. RASelkirk

    RASelkirk Well-Known Member
    Thread Starter

    Hi all,

    I have several apps that either send me info via text and expect replies, or expect me to originate a text to these oddball numbers. . These "problems" are from "non-phone" type numbers, usually 5 or 6 digit number sequences. When I attempt to reply to them the message always fails to send. Phone is an LG-6 on T-Mobile, not rooted, with latest updates. Is this a setting I'm overlooking? A function of the LG messaging app? Or just another impossibility?

    Thanks!

    Russ
     


    racibennett likes this.
  2. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    Definitely not an impossibility! The local station I watch the most is always running free tickets for Disneyland or something, and they say 'text such-and-such to 515151'--and I've done it, and it worked. So it can be done.

    You're putting the non-phone number, like 515151 above, in the phone number field, right? And then what happens when you send it? Is there an error message?
     
    ocnbrze likes this.
  3. mikedt

    mikedt 你好

    They're SMS short-codes, and depending on the service and country you're in, can be billed at premium rates. Check with your carrier, maybe they're blocking them?
     
    ocnbrze likes this.
  4. RASelkirk

    RASelkirk Well-Known Member
    Thread Starter

    Doesn't matter if I "reply to" or type the number on a new message, It's always:

    Screenshot_2019-12-07-17-12-56_resized.png

    This is just an example of what happens when I "reply to"...

    Russ
     
  5. mikedt

    mikedt 你好

    I know what's supposed to happen. Something like this. I text "101" to the SMS short-code 10010, and I get my carrier account balance
    Screenshot_20191208_090218_com.android.mms.jpg

    Why it's not working for you, no idea. Suggest you do check with your carrier customer service about it.
     
    dontpanicbobby and ocnbrze like this.
  6. RASelkirk

    RASelkirk Well-Known Member
    Thread Starter

    Ok, got this one solved. T-Mobile, in their infinite wisdom, has disabled the ability to text to "short code" numbers by default and there's not a readily obvious method to toggle it. There are a few vids on how to, but my LG does not have the "message service" under system apps. One must click on the gear on the top menu bar, locate "Apps & Notifications", then "Special Access", then "Premium SMS Access". Now you can set your Message App to "Ask | Never Allow | Always Allow".

    HTH,

    Russ
     
  7. MoodyBlues

    MoodyBlues Compassion is cool!
    VIP Member

    I'm glad you got it figured out, @RASelkirk, and posting its solution was very thoughtful. It will likely help someone else who comes along later with a similar problem. :)
     
    dontpanicbobby likes this.
Loading...
Similar Threads - Cannot text non
  1. Mubeen Ahmed
    Replies:
    3
    Views:
    239
  2. Victor Connor
    Replies:
    8
    Views:
    531
  3. ETtrailrunner
    Replies:
    7
    Views:
    467
  4. izabelle221
    Replies:
    2
    Views:
    417
  5. Doulos Adonai
    Replies:
    4
    Views:
    444
  6. droidros
    Replies:
    6
    Views:
    538
  7. Samir Essa
    Replies:
    0
    Views:
    405
  8. Froglet89
    Replies:
    2
    Views:
    342
  9. dianyah613
    Replies:
    2
    Views:
    562
  10. Hatim456
    Replies:
    6
    Views:
    1,059

Share This Page

Loading...