1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't access mobile broadband except with Opera

Discussion in 'Android Devices' started by Chriswaterguy, Aug 6, 2010.

  1. Chriswaterguy

    Chriswaterguy Newbie
    Thread Starter

    I can't get a fully functioning data connection on my Galaxy S through my current SIM card. I can browse with Opera (which doesn't seem to care what the APN settings are) but nothing else works, (unless I get a wifi connection, which works fine). The problem may or may not disappear when I move countries soon (to Indonesia) but I'd like to understand what's going on.

    I bought it in Singapore - it's got a SingTel setup (sticker on the back, boot screen, links on home) but it's supposed to be unlocked (and SingTel say they sell them unlocked too). A guy at the Samsung service center in Singapore said it was "locked" for other countries though because they don't yet have the Galaxy S - but once phone companies have the right settings for the phone it should be fine.

    I used it with a different Singapore phone company (StarHub) with a data plan for a couple of days that worked fine. I browsed and used the Google Maps app, no problem.

    Then the problem. I came to Malaysia a week ago and bought a Maxis SIM card. At their service center they entered the APN settings (they already sell the Galaxy S), and the internet worked when I tested it on a few pages. 30 min later I tried again and got nothing, and it didn't come back. I returned to the service center, they made small changes to the settings, and it worked again... for a few minutes only. Then I discovered that I can browse in Opera - even if I use dummy APN settings (random numbers in one field and everything else blank or default).

    One more time I went to the Maxis service center. The person at the counter noted the severe lag and suggested there was something wrong with the software.* (Actually I had about 4 different browsers running, to see which ones worked.) He restarted the phone, asked me to force close some apps (e.g. NimBuzz and maps, which had started automatically). And... suddenly I had data access! This lasted a couple of hours, while my battery lasted.

    However after I restarted the phone again, I couldn't repeat the success. I stopped unneeded apps, I uninstalled NimBuzz, I tried restarting over and over... but I get no connection other than with Opera. I've tried other internet apps (Maps, sync in GTasks, OkCupid, NimBuzz) and none work.

    Any clues as to what's going on? Thanks.

    * I now only get small lagging, since I followed the advice on another thread - I removed the Daily Briefing and Google search apps from the home screen, and regularly check running apps. (I exit apps properly when possible.) But this hasn't helped the data connection.

    1. Download the Forums for Android™ app!


  2. Chriswaterguy

    Chriswaterguy Newbie
    Thread Starter

    Perhaps an admin could move this from "Galaxy S" to a more general category? Any kind of lead as to what's going on would be appreciated.

Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date

Share This Page