1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't access to mobile data

Discussion in 'Android Carriers' started by MrFiddle, Jul 2, 2017.

  1. MrFiddle

    MrFiddle Lurker
    Thread Starter

    Hi guys.
    4 days ago Telcel gave me a new cellphone, it's a ZTE Blade A520, well, it's a good medium-low gamma smartphone, it work's good.
    Well, 3 days ago I was using my phone watching some memes on my school, then the teacher started the class so I locked it. Few hours later I saw that mobile data apparently was off, my signal bar didn't have that "H" or 4G, I tried to turn it on but, it was on.
    Then a message has appeared on a pop-up saying "Sin suscripción al servicio -33-" (Without suscription at service -33-), I readed on Internet that it is about mobile data and APNs, I tried check them but nothing is wrong with them... Actually I tried to do a factory reset but still without mobile data. HAAAALP PLZ :(

    Note: My cellphone doesn't have a custom ROM, it has the original.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Phalon4

    Phalon4 Android Enthusiast

    Hi, Try this turn your phone on then go to Settings { Then look for (more ) then tick that. Look until you see (mobile network) tick that, then look at the top right corner where 3 vertical dots is. Then tick that where it says Reset Network. After Network has been reset, then power cycle the phone= turn it off and turn it on. See if that helps your issue.
     
  3. Is it possible to install custom rom? I have this phone too. But I don't know how to install custom rom or root. Can you help?
     

TELCEL

Loading...

Share This Page

Loading...