1. Download our Official Android App: Forums for Android!

Root Can't boot into recovery

Discussion in 'Android Devices' started by seaniscool1, Dec 22, 2009.

  1. seaniscool1

    seaniscool1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 20, 2009

    Nov 20, 2009
    4
    0
    5
    I have tried everything, Last time I did was when I manually updated...This time I am going hard reset because my phone is acting a little weird. It just won't boot into recovery, I can sit there holding x and power at the "M" for 15 min, it wont do anything? I battery pull and boot regular and it boots fine
     

    Advertisement

  2. polakatl

    polakatl Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Nov 8, 2009

    Nov 8, 2009
    8
    0
    5
    I just got the same problem. I'm on 2.0.1 with the Droid. I wanted to flash a new recovery from sholes.info. ADB responded with

    error writing recovery: No space left on device

    after I rebooted I can no longer get into recovery. Phone hangs on the moto logo. Boots into OS fine.
     
  3. Berry2Droid

    Berry2Droid Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    402
    Joined:
    Nov 17, 2009

    Nov 17, 2009
    402
    45
    43
    Assistant Manager for Verizon Wireless
    NJ
    try reboot recovery from adb shell?
     
  4. refriend

    refriend Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 12, 2009

    Nov 12, 2009
    2
    0
    5
    Same situation... same problem.

    reboot hangs on "adb reboot recovery" but normal boot works fine.
     
  5. CRPercodani

    CRPercodani OFWGKTA
    Rank:
    None
    Points:
    213
    Posts:
    2,940
    Joined:
    Oct 24, 2009

    Oct 24, 2009
    2,940
    564
    213
    Real Estate Agent
    M A dub'l dolla sign
    Sounds like you recovery partition got overwritten somehow. You will need to install the flash_image binary then flash SPRecovery from a terminal app.

    Command would be as so...

    su
    flash_image recovery /sdcard/recovery-0.99.2b.img
    reboot recovery


    If that works then your all set, no idea on how to get the original recovery back though except by finding a original droid dump and seeing if it is in there. I wonder if the 2.0.1 update you used had those 2 files missing from system, boot-old or something like that. That could have caused your recovery to be deleted when you rebooted at any time.
     
    darkjinni2 likes this.
  6. messenger13

    messenger13 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    3,133
    Joined:
    Dec 8, 2009

    Dec 8, 2009
    3,133
    381
    163
    Director of IT
    Cleveland, OH
    Just so we're clear...
    - Shut phone OFF
    - Press & Hold 'X' on hardware keybd
    - Press power button
    - As soon as you see the Motorola logo, let go.
    - Recovery console appears

    If that doesn't work, you'll have to reflash the recovery image.
     
  7. refriend

    refriend Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Nov 12, 2009

    Nov 12, 2009
    2
    0
    5
    Aahh. You're right (with a small mod)...

    su
    /data/local/flash_image recovery /sdcard/recovery-0.99.2b.img
    reboot recovery

    Thanks!
     
  8. CRPercodani

    CRPercodani OFWGKTA
    Rank:
    None
    Points:
    213
    Posts:
    2,940
    Joined:
    Oct 24, 2009

    Oct 24, 2009
    2,940
    564
    213
    Real Estate Agent
    M A dub'l dolla sign
    I'm glad that worked, I had guessed you had the file in your sd. Either way glad it is fixed, how about the other guys?
     
  9. zososon76

    zososon76 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 23, 2010

    Jan 23, 2010
    1
    0
    5
    when i boot into recovery why are their any options (like to install update.zip) ?!~
     
  10. clinefsu

    clinefsu Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jan 9, 2010

    Jan 9, 2010
    8
    0
    5
    I too am having an issue when trying to reboot into recovery. After entering the recovery menu I am getting the error

    "E: Can't open /cache/recovery/command"

    This is a stock Droid with no mods. rooting, or flashing to date. Can anyone help with this??
     
  11. Dr Saltfish

    Dr Saltfish Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 23, 2010

    Aug 23, 2010
    1
    0
    5
    Where can I download a flash_image binary to install? And as for flashing the SPRecovery, what terminal app do you recommend? I am running 2.2 and rooted, but and getting the same triangle! hang-up when booting into recovery to do a nandroid backup.

    Thanks
     
  12. tatert0t

    tatert0t Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 10, 2010

    Sep 10, 2010
    2
    0
    5
    I am having the same problem. I ran Easy Root on the Droid 2.2 but I cannot get into the reboot into recovery menu. I just get a triangle error message. How do i fix this? Ive tried even doing the factory reset on the phone and nothing works :mad:
     
  13. ambient711

    ambient711 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Sep 11, 2010

    Sep 11, 2010
    7
    0
    5
    Portland, OR
    I am having that problem too. will not boot recovery but loads os fine. I just tried to install SPRecovery. I tried what CRPercodani said, No luck though.

    Is there anyway to remove SPRecovery without being in Recovery mode?

    Thanks
     
  14. gwlaw99

    gwlaw99 Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,030
    Joined:
    Nov 1, 2009

    Nov 1, 2009
    1,030
    53
    128
    If you get the yellow triangle message then press volume down and camera at the same exact time (this can take a few minutes as it has to be at the exact same time). If you are rooted I would install ROM Manager and flash clockwork recovery. Then you can select boot into recovery from the menu inside ROM Manager.
     
    ambient711 likes this.
  15. ambient711

    ambient711 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Sep 11, 2010

    Sep 11, 2010
    7
    0
    5
    Portland, OR
    Thanks, Although I cant even get to the triangle. I used to be able to before I installed SPRecovery. I tried a rom manager and it will not put it into recovery it just reboots the phone. I tried holding the buttons down for 5 minutes, do you think it would be much longer than that?
     
  16. bluemsw

    bluemsw Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    90
    Joined:
    Dec 2, 2009

    Dec 2, 2009
    90
    6
    16
    Tech
    so. cal
    I had similar problem with my phone using the ROM Manager. (if anyone is using ROM Manager) All I did to fix it was re-flash the clockworkmod recovery. Now I can manually get in to recovery on power up.
     
    Durania likes this.
  17. bluemsw

    bluemsw Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    90
    Joined:
    Dec 2, 2009

    Dec 2, 2009
    90
    6
    16
    Tech
    so. cal

    A long period of time will not help, or it didn't help me, try the reflash i suggested. then try it again. Also you can select the "reboot into recovery" in ROM manager and see if it will take you there. Hope this helps.
     
    ambient711 likes this.
  18. gwlaw99

    gwlaw99 Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,030
    Joined:
    Nov 1, 2009

    Nov 1, 2009
    1,030
    53
    128
    Did you install clockwork recovery in rom manager?
     
    ambient711 likes this.
  19. ambient711

    ambient711 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Sep 11, 2010

    Sep 11, 2010
    7
    0
    5
    Portland, OR
    I tried reboot recovery from terminal, from Clockwork but it didnt seem to work. Im going to try uninstalling the rom manager just to see if it makes a difference. yes I installed the clockwork mod from the rom manager. Ill try reflashing too.
     
  20. dfine06

    dfine06 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    179
    Joined:
    Dec 21, 2009

    Dec 21, 2009
    179
    2
    36
    if you just cant boot into but you have a recovery flashed use quickboot from the market. its great.
     
    ambient711 likes this.
  21. ambient711

    ambient711 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Sep 11, 2010

    Sep 11, 2010
    7
    0
    5
    Portland, OR
    I tried that, it didnt work it just rebooted normally. I think I may have found the problem.
    I found one of the files that its supposed to use for boot with SPRecovery. And I think the other one is missing. Under "/system/" there is a "recovery-from-boot.old" but isnt there also supposed to be a "recovery-from-boot.p"

    Thanks again for the help
     
  22. rgomez287

    rgomez287 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 25, 2011

    Mar 25, 2011
    1
    0
    5
    I am also having trouble getting into recovery menu. I hold x and power and it just hangs at the M logo. It will boot into OS just fine. I backed up with rommanager and downloaded the clockwork through it as well. I clicked on rester as well as wipe and clean. It does nothing. Just hangs on the logo as well, then reboots into the OS. Is there anyway to fix this? I would appreciate any help.
     
  23. teddyearp

    teddyearp Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    2,409
    Joined:
    May 19, 2010

    May 19, 2010
    2,409
    832
    233
    Store Manager
    Pinetop, AZ
    Sorry for a delay, but since your phone will boot up normally, open rom manager and then go here:
    Code (Text):
    1. menu -> Clear Download Cache
    then:
    Code (Text):
    1. menu -> settings -> Advanced Mode [check]
    then go towards the bottom of the main screen in Rom Manager and under "more Recoveries" select "Flash Alternate Recovery". After it completes then go back to the top and flash CWRecovery again and see if it will take.

    good luck
     
    nbajam, bluevine and Myco like this.
  24. Myco

    Myco Newbie
    Rank:
    None
    Points:
    36
    Posts:
    26
    Joined:
    Mar 23, 2011

    Mar 23, 2011
    26
    1
    36

    I've never been able to flash alternate recovery in ROM Manager. Tried these and "An error occurred while flashing your recovery" comes up. ROM mgr also reboots into stock recovery. Hope this helps, looks like a lot of us have the same prob.
     
  25. teddyearp

    teddyearp Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    2,409
    Joined:
    May 19, 2010

    May 19, 2010
    2,409
    832
    233
    Store Manager
    Pinetop, AZ
    With the increase of these types of problems, I can only wonder if the 'alternate' recovery is no longer available through the servers that rom manager accesses at this time.

    For what it's worth, I wrote an email to koush the other day, but haven't gotten a reply:
     
    Myco likes this.

Share This Page

Loading...