Help Can't Charge via USB, but can charge using AC


I have an optimus t which i've recently rooted. I don't know if that has anything to do with this but after rooting it worked okay for a while, or at least I haven't noticed anything going bad.

It's until I started using the unit in the car with an aftermarket usb adapter and a micro usb cable, did I notice that the phone won't charge with the setup. I then tried it with the usb cable that I usually charge with at home, and it doesn't seem to charge either. I thought all was lost, and maybe something happened during my app removal with titanium backup or something.

Then I fished out the ac adapter that came with the phone. It's just like an adapter with a usb port. However, for some reason the phone was able to identify it as "charging (AC)" on the phone status where car charging and computer charging would show as "charging (USB)". Charging via AC works fine. Charging with USB, I get a charging battery icon with lightening bolt and the battery filling up in green, but the percentage of charge would drop slowly, or that it really isn't being charged.

The curious thing is 1. the phone was able to charge via usb from the computer USB port before; 2. the phone still charges despite the problem with usb charging. Is this a software related issue? Anyone have any idea what may have happened? The battery seems to charge just fine with AC, and this happened around the time when I started using titanium backup/easy battery saver, etc. Not sure which one did what. Resetting/erasing user data didn't do anything.

Any help is much appreciated.