1. Download our Official Android App: Forums for Android!

Support Can't connect to freenode irc anymore with the thunderbolt?

Discussion in 'Android Devices' started by crimton, Mar 18, 2011.

  1. crimton

    crimton Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,055
    Joined:
    Apr 1, 2010

    Apr 1, 2010
    1,055
    180
    163
    TN
    when i had my incredible i could connect to freenode channels all the time using any of the market clients without any kind of authentication required. now it says sasl required and i get an error every time. androirc is the only client i see that supports sasl and it won't let me connect either. could anyone else confirm this for me? its really not a huge deal but its the little things that really bother me. thanks
     

    Advertisement

  2. LoyalServant

    LoyalServant Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,050
    Joined:
    May 24, 2010

    May 24, 2010
    1,050
    267
    163
    Male
    Programmer
    Columbia, SC
    I noticed it as well.
    I shrugged it off as being some sort of server change but no, it's not working for me either.
     
    crimton likes this.
  3. crimton

    crimton Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,055
    Joined:
    Apr 1, 2010

    Apr 1, 2010
    1,055
    180
    163
    TN
    thanks for the reply at least I'm not going crazy
     
  4. JonathanD

    JonathanD Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Mar 18, 2011

    Mar 18, 2011
    3
    1
    6
    Did you change carrier along with phones? Who is your current carrier?
     
  5. crimton

    crimton Android Expert
    Thread Starter
    Rank:
    None
    Points:
    163
    Posts:
    1,055
    Joined:
    Apr 1, 2010

    Apr 1, 2010
    1,055
    180
    163
    TN
    as far as I know the thunderbolt is only on verizon which is my carrier.
     
  6. JonathanD

    JonathanD Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Mar 18, 2011

    Mar 18, 2011
    3
    1
    6
    You should just need to specify your nickserv nickname and password, as well as the mechanism (both plain and blowfish are supported) in andoirc (under the SASL settings) to connect.

    I'm not sure why you're being required to use SASL in this case though.
     
  7. JonathanD

    JonathanD Lurker
    Rank:
    None
    Points:
    6
    Posts:
    3
    Joined:
    Mar 18, 2011

    Mar 18, 2011
    3
    1
    6
    Well, we figured this out. SASL on freenode requires you use your primary nick, not any grouped nickname you may have. So to use SASL use your primary nick, password, and it should work.
     
    crimton likes this.
  8. TaviRider

    TaviRider Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 4, 2011

    May 4, 2011
    1
    0
    5
    And if you're new to Freenode and don't have a username/password yet? How do you register? All the documentation I've found so far says "type /msg nickserv help", which is ridiculous because you have to be registered and connected to do that.
     
  9. Chizuki360

    Chizuki360 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 26, 2013

    May 26, 2013
    1
    0
    5
    I was having the same problem until recently. The way I solved it was by hopping to the freenode website anf using their webchat. Don't forget to validate your email.
     

Share This Page

Loading...