1. Check out our companion app, Forums for Android! Download from Google Play

Support Can't Connect To Home WIFI

Discussion in 'Android Devices' started by rivercat123, Feb 16, 2012.

  1. rivercat123

    rivercat123 Well-Known Member
    Thread Starter
    36

    Oct 16, 2009
    89
    2
    36
    Clearwater, Fl
    I have always been able to connect to any public wifi with no problems. At home I am unable to connect. I have Knology internet service with the Knology provided modem connected to a desk top Mac. For some reason Knology does not provide wireless routers so I purchased a Trendnet modem at Comp USA. I had no problem hooking it up and got an instant connection with my Dell laptop. When I turn the wifi on my Samsung GS2 phone I get the security sign on and it starts scanning. Then it says disconnected, then scanning, then disconnected and so on. any suggestions?
     

    Advertisement

  2. BigCiX

    BigCiX Well-Known Member
    173

    Jul 30, 2010
    3,591
    363
    173
    California
    Typical problem with android devices. Reset your modemn and router. If problem still exist then download wifi fixer from the market. If the problem is still there then back up your data and do a factory reset.
     
  3. mrcminnesota

    mrcminnesota Active Member
    16

    Sep 26, 2011
    38
    8
    16
    agree with JayC although I would just do the factory reset (holding power button and volume up button at the same time) after you reset your modem if that doesn't fix the issue. Never tried the market app but did have initial problems with WiFi and did the factory reset which fixed the issue.
     
  4. rivercat123

    rivercat123 Well-Known Member
    Thread Starter
    36

    Oct 16, 2009
    89
    2
    36
    Clearwater, Fl
    I tried resetting the modem and then went through all the settings, however I didn't change any of them, and now the phone will connect. I guess resetting the modem did the trick. Thanks.
     
  5. marant

    marant Member
    25

    Feb 26, 2012
    9
    0
    25
    Had the same problem with my new Touch: would not find an ip address. Unplugged modem and router for 5 minutes, now the phone connects. Will have to wait and see if this is a recurring problem or not.
     
  6. rivercat123

    rivercat123 Well-Known Member
    Thread Starter
    36

    Oct 16, 2009
    89
    2
    36
    Clearwater, Fl
    It's been a week now and the phone still connects to the home wifi ok.
     
  7. marant

    marant Member
    25

    Feb 26, 2012
    9
    0
    25
    I have the same problem and seem to need to reset the router daily in order to log on. Would sure like to find a fix, since it is a PITA to have to do it all the time.
     
  8. nomunk

    nomunk Well-Known Member
    38

    Feb 26, 2010
    232
    22
    38
    I have the same issue and had this with my EVO 4g also, now my Epic 4G touch is doing the same thing, just says obtaining IP address then disconnects, then it rescans to obtain ip address then disconnects again

    ill try to reset my modem as suggest above to see if that works, hope a fix comes in a future update
     

Share This Page

Loading...