1. Download our Official Android App: Forums for Android!

Support Can't connect to pc via usb

Discussion in 'Android Help' started by undeadman9914, Apr 20, 2016.

  1. undeadman9914

    undeadman9914 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    5
    Joined:
    Apr 20, 2016

    Apr 20, 2016
    5
    1
    16
    Phone - Galaxy Core Prime
    Carrier or provider or whatever - Straight Talk
    Once upon a time, my phone would connect no problem. Now, when I plug it into a computer it will charge, but it won't show up on a computer as a device, so I can't move files onto it.
    Please help, this is beyond pissing me off.
     

    Advertisement

  2. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator
    Rank:
     #6
    Points:
    3,118
    Posts:
    29,292
    Joined:
    Sep 10, 2010

    Sep 10, 2010
    29,292
    23,466
    3,118
    Male
    Next to you
    Hello there!
    Have you tried different cords or usb ports?
    Are the drivers installed/updated? Perhaps delete and reinstall the drivers?
    Have you rebooted the device and/or computer?
    Can you choose between "Charge only" , "MTP" or PTP" in your phone settings when plugged into the computer?
     
    mikedt likes this.
  3. mikedt

    mikedt 你好
    Rank:
     #7
    Points:
    2,238
    Posts:
    24,221
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    24,221
    13,306
    2,238
    Teachaaa
    Jinan, China
    Tried another USB cable? Also check to make sure the USB connected option is not set to charge only.
     
    Mikestony likes this.
  4. Mikestony

    Mikestony ~30% Carbon Black ±
    Moderator
    Rank:
     #6
    Points:
    3,118
    Posts:
    29,292
    Joined:
    Sep 10, 2010

    Sep 10, 2010
    29,292
    23,466
    3,118
    Male
    Next to you
    I ninj'ad the Chinese Android Guru!! :p
     
    scary alien and mikedt like this.
  5. undeadman9914

    undeadman9914 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    5
    Joined:
    Apr 20, 2016

    Apr 20, 2016
    5
    1
    16
    Hi.
    Yeah, I've tried different cords, different ports, and even different computers.
    Not a clue where to find the drivers (I know that perhaps makes me out as a bit of an idiot, but it is what it is).
    Rebooted both.
    No idea where Charge, MTP or PTP would be in settings.
     
  6. undeadman9914

    undeadman9914 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    5
    Joined:
    Apr 20, 2016

    Apr 20, 2016
    5
    1
    16
    If someone could get back to me soon, that would be great.
     
  7. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,928
    Joined:
    May 15, 2015

    May 15, 2015
    3,928
    2,847
    818
    Male
    Electrician
    Satsuma,Alabama
    You can download Kies3 for Samsung and get all the USB drivers for your device.
    Usually when you connect your phone to PC you will see the USB symbol in the drop down notification on the top of the screen. Pull down on the notification and tap the USB symbol should give you options.

    http://www.samsung.com/us/support/owners/app/kies
     
    Mikestony, mikedt and Brian706 like this.
  8. Brian706

    Brian706 I like turtles!
    Moderator
    Rank:
     #29
    Points:
    1,053
    Posts:
    9,339
    Joined:
    Jul 25, 2012

    Jul 25, 2012
    9,339
    8,582
    1,053
    Drafter
    @Jfalls63 & @mikedt already touched on this a bit but did your device get updated to Marshmallow? I ask because since the MM update, plugging in the device to a PC defaults to charge only. If you pull down the notification shade and tap the USB notification you will have an option to switch to MTP.
     
    Mikestony and mikedt like this.
  9. jefboyardee

    jefboyardee Android Expert
    Rank:
     #63
    Points:
    423
    Posts:
    5,524
    Joined:
    Jan 18, 2011

    Jan 18, 2011
    5,524
    1,788
    423
    Pull down screen to show notifications.
    Tap 'Connected as.'
    Choose Media device (MTP).

    It should now show your droid files on your Windows file manager.
     
    #9 jefboyardee, Apr 21, 2016
    Last edited: Apr 21, 2016
    mikedt likes this.
  10. undeadman9914

    undeadman9914 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    5
    Joined:
    Apr 20, 2016

    Apr 20, 2016
    5
    1
    16
    I have no idea if its updated to Marshmallow or not.
    When I pull down the notifications, there is no USB or connected as option to tap.
     
  11. jefboyardee

    jefboyardee Android Expert
    Rank:
     #63
    Points:
    423
    Posts:
    5,524
    Joined:
    Jan 18, 2011

    Jan 18, 2011
    5,524
    1,788
    423
    Just in case, your PC>USB must be connected to your droid for that option to appear.
     
  12. justconfused

    justconfused Lurker
    Rank:
    None
    Points:
    25
    Posts:
    8
    Joined:
    Mar 26, 2013

    Mar 26, 2013
    8
    0
    25
    Female
    happy town
    i've had this happen to me. it could either be the device, the usb cord, or your computer
    my problem, it was my computer. like you said it would charge several devices using different usb cords but would not recognize them so i could modify things

    i had to open "this pc". right click, go to properties. system would then pop up and i would go to device manager. mind you, the device is connected to the computer through usb this whole time. i would find all the devices, specifically the one im having a problem with, right click to delete, unplug usb, re plug, then redownload the file to connect my phone to the pc

    i found all that through a google search. if you find it, they explain it better than me
     
  13. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,928
    Joined:
    May 15, 2015

    May 15, 2015
    3,928
    2,847
    818
    Male
    Electrician
    Satsuma,Alabama
    Have you enabled Developer Options and checked. Can't remember if USB settings is a option on Samsung but worth looking.

    Go to settings-about phone and scroll down to build number. Tap on build number 7 or 8 times to enable.
    Go back to settings and scroll to bottom and open Developer Options. Look and see if you you have USB options there.
    This is what it looks like on my Moto X
     

    Attached Files:

  14. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,928
    Joined:
    May 15, 2015

    May 15, 2015
    3,928
    2,847
    818
    Male
    Electrician
    Satsuma,Alabama
    I know it is not a solution to your USB status but look at the app Airdriod at the Play Store. It allows file transfer wirelessly.
     
    undeadman9914 likes this.
  15. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,928
    Joined:
    May 15, 2015

    May 15, 2015
    3,928
    2,847
    818
    Male
    Electrician
    Satsuma,Alabama
    One other things to check is the USB hidden menu. Haven't tried it on Core Prime but code works on every S series Samsung but Verizon branded that I've tried it on.
    Open your phone dialer like you are making a call.
    Dial *#0808#
    If it works, should take you to USB menu
    MTP+USB should be checked, if not, select it then press OK at bottom then use return to back out of menu.
    This is what it looks like on S5
     

    Attached Files:

    Mikestony and jefboyardee like this.
  16. rdaj

    rdaj Lurker
    Rank:
    None
    Points:
    16
    Posts:
    2
    Joined:
    Mar 23, 2016

    Mar 23, 2016
    2
    1
    16
    Male
    I have a Samsung S7 Edge & every time I connect it to my Windows 7 computer, the computer does not recognize it. I found that doing the following solves the problem.

    1. Turn on the phone & connect it to phone to computer and turn it on

    2. On the PC, click on START & select DEVICE AND PRINTERS

    3. If your phone icon shows up under DEVICES, right click on the icon & select TROUBLESHOOT

    4. If PC finds a fix to the problem, select the fix. On my PC, the problem always turn out to be "SAMSUNG GALAXY S7 EDGE HAS A DRIVER PROBLEM" ... so after I let the PC reinstall the device driver, it recognized the phone so that I can do a backup
     
    #16 rdaj, Apr 22, 2016
    Last edited: Apr 23, 2016
    Mikestony likes this.
  17. undeadman9914

    undeadman9914 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    5
    Joined:
    Apr 20, 2016

    Apr 20, 2016
    5
    1
    16
    Hey thanks for the info.
    I got Airdroid, and its been a charm, so that's great.
    Absolutely no idea what's going on. I did what you suggested, and things were marked as they should be. I've now gone through three different chords, thinking that was the problem, but bah, whatever. This works well enough.
     
    Jfalls63 likes this.
  18. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #31
    Points:
    818
    Posts:
    3,928
    Joined:
    May 15, 2015

    May 15, 2015
    3,928
    2,847
    818
    Male
    Electrician
    Satsuma,Alabama
    There are so many different things that can be the problem and what works for one phone won't for the next. Glad you were at least able to work around it.
     

Share This Page

Loading...