1. Check out our app, Forums for Android! Download and leave feedback here!

Support Can't connect to PC

Discussion in 'Android Devices' started by Ceezer, Oct 16, 2010.

  1. Ceezer

    Ceezer Member
    Thread Starter
    15

    Aug 7, 2010
    15
    0
    15
    I tried searching and didn't have any luck with results, so I apologize if it's been covered, but I'm having difficulties connecting my Captivate to my PC via USB to transfer pictures/data/music.

    I've had the phone for a few months now but this is the first time I've really attempted to connect, as my pictures are piling up and I'd like to back them up for safekeeping.

    I already had the drivers downloaded months ago when I first got the phone but when I connected it today, I got a message that Windows (Win 7, 64-bit) failed to recognize the device. I went out, using the link in the Captivate Guide here (which is where I got them initially), and redownloaded the drivers to ensure I had the appropriate/most current version. Installed them, made sure the phone was set to 'Mass Storage' in USB settings, and still fail to connect when I plug the USB cord in. Windows fails to recognize the phone as a device and errors out each time.

    I tried putting it into USB Debugging Mode, but still get the same thing. I tried 'Ask on connection', I tried Kies, etc and nothing will work.

    Am I missing a step here, or doing something wrong? This has been extremely frustrating...

    I appreciate any assistance and, again, apologize if I overlooked the solution to this issue.
     

    Advertisement

  2. Grut

    Grut Well-Known Member
    16

    Sep 9, 2010
    50
    4
    16
    Pennsylvania
    Are you "Mounting" the sd card when you connect via mass storage?
     
  3. Ceezer

    Ceezer Member
    Thread Starter
    15

    Aug 7, 2010
    15
    0
    15
    Yes, sorry, I am.
     
  4. Ceezer

    Ceezer Member
    Thread Starter
    15

    Aug 7, 2010
    15
    0
    15
    Still unable to connect... Any suggestions?
     
  5. Infinite-t

    Infinite-t Well-Known Member
    53

    Jul 23, 2010
    412
    74
    53
    I had that exact problem a while back, with win.7 64, I have heared others with the same issue. I used the drivers posted in the guid section of this forum. I connected to the pc and it wouldnt work.. this went on for a few days. One day i got a wild idea and rebooted the phone while it was plugged in to my PC. When it booted back up it connected and connects ever time now. I have no technical explaination for it, it just seemed to work.. probably just dumb luck.

    Another thing to do is make sure when you plug into your PC, plug in to one of the USB ports on the back of your PC, coming straight off the MOBO, for some reason it doesnt like to connect if you use front panel ports or hubs on Win 7.
     
  6. Ceezer

    Ceezer Member
    Thread Starter
    15

    Aug 7, 2010
    15
    0
    15
    Thank you! I didn't even have to do the phone reboot while connected. I just plugged the USB cable into the I/O plate on the back of the PC instead of the panel port on the front and it instantly recognized it.
     
  7. Infinite-t

    Infinite-t Well-Known Member
    53

    Jul 23, 2010
    412
    74
    53
    sweet, glad to hear it
     

Share This Page

Loading...