1. Download our Official Android App: Forums for Android!

Cant connect to the internet

Discussion in 'Chromecast' started by monsterenergy22, Jan 26, 2014.

  1. monsterenergy22

    monsterenergy22 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    496
    Joined:
    Nov 19, 2009

    Nov 19, 2009
    496
    53
    73
    So I went to use my CC and all of the sudden it says it cant connect to the internet. It is successfully connected to my 2.4ghz wireless network as well. It has not taken the new OTA yet.

    I have rebooted my router and done a factory reset on the CC as well.

    Any other ideas?
     

    Advertisement

  2. Rukbat

    Rukbat Android Expert
    Rank:
     #29
    Points:
    943
    Posts:
    10,392
    Joined:
    Jan 16, 2012

    Jan 16, 2012
    10,392
    2,894
    943
    Male
    Being retired and writing Tasker tasks.
    Fayetteville, NC, USA
    If it's connecting to the router but not to the internet, make sure that your router is connected to the internet. Use some other device(a computer, laptop, etc.) and go to some link - here, aol, anywhere.

    Check that the CC's IP address (in the CC - I don't have one, so I can't tell you how to do that - look in the manual if you don't know) starts with 10, 172.16 to 172.31 or 192.168. If it starts with 169, then no matter what it says, it's not connected to the router, it's generating a local link address.

    Make sure your router can be connected to by some other device (one in addition to the ones that are already connected), and make sure that device can access the internet. Then turn that device off and try to connect the CC. (If there's no available DHCP slot, no device will connect.)

    Make sure that the CC is set for DHCP or Dynamic IP address, not Static IP address.

    Those are the first things to check.
     
  3. monsterenergy22

    monsterenergy22 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    496
    Joined:
    Nov 19, 2009

    Nov 19, 2009
    496
    53
    73
    Thanks for the response.

    All other devices are working on the network. I have tried the CC on both my personal 2.5Ghz network and our guest network. Still shows not internet connection.

    Confirmed via my router and the chromecast app that it is getting a 192.168 address.

    My router is setup to automatically assign with DHCP.
     
  4. monsterenergy22

    monsterenergy22 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    496
    Joined:
    Nov 19, 2009

    Nov 19, 2009
    496
    53
    73
    Contacted Google and they are sending me a replacement CC.

    Hopefully this will fix the issue.

    Thanks everyone for your help so far.
     
  5. monsterenergy22

    monsterenergy22 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    496
    Joined:
    Nov 19, 2009

    Nov 19, 2009
    496
    53
    73
    Update: Got the replacement, still a no go.

    Looks like it has something to do with my router.

    Any suggestions?

    Update: Flashed the official Asus 3.0.0.4.276 firmware which Google reports is working with the CC. Did a factory reset with it and still could not get connected to the internet. I think I have ruled out my network, got to be something in my apartment complex...
     
  6. monsterenergy22

    monsterenergy22 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    496
    Joined:
    Nov 19, 2009

    Nov 19, 2009
    496
    53
    73
    So I set up my phone as a hotspot and connected the CC to that just to verify it would connect. It did and updated to the latest version. So I connected it back to my main network, and it worked! I guess the update fixed something, but whatever it is, I am just happy it works again! Thanks again for everyones help, I really appreciate it!
     

Share This Page

Loading...