1. Download our Official Android App: Forums for Android!

Can't connect to wifi

Discussion in 'TV & Video' started by WalwRafii, Jun 5, 2016.

  1. WalwRafii

    WalwRafii Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Jun 5, 2016

    Jun 5, 2016
    2
    2
    6
    Male
    Bought a Phillips AndroidTv yesterday - don't even know what model tbh, I bought it for guest house, not personal use
    Anyway whenever I try to connect to wifi it says invalid password, even if its not. Tried hundreads of times and with other devices it works fine.

     

    Attached Files:


    Advertisement

  2. Dave456

    Dave456 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jun 16, 2016

    Jun 16, 2016
    7
    1
    6
    Male
    Are you sure you are trying to connect to the right WIFI ID?
     
  3. Andrew Cole

    Andrew Cole Android Enthusiast
    Rank:
    None
    Points:
    108
    Posts:
    463
    Joined:
    Jun 12, 2016

    Jun 12, 2016
    463
    158
    108
    Male
    The box is looking for a password for WEP encryption.
    Is this the same type of encryption on your router?

    WEP is an older method of encryption and was easy to hack.
    I'll bet your router is set up with a higher quality protocol like WPA or WPA2.

    If you can get to your router admin panel then changing the encryption type will be easy.
     
    mikedt likes this.
  4. svim

    svim Android Expert
    Rank:
     #42
    Points:
    608
    Posts:
    3,995
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,995
    3,028
    608
    Illinois
    I was asking myself this same question as you mentioned you're setting this up in a guest house. How far away is the guest house from your wireless router? I wouldn't be surprised if that Android TV box is picking up a neighbors' WiFi network.
    If this is what's happening, try installing something like this WiFi Analyzer app on your phone and just do some basic signal strength tests on your home WiFi network:
    https://play.google.com/store/apps/details?id=com.farproc.wifi.analyzer&hl=en
    If the signal out to your guest house is on the weak side, maybe you can relocate your wireless router so its signal extends out further.
     
  5. mikedt

    mikedt 你好
    Rank:
     #4
    Points:
    3,238
    Posts:
    25,126
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    25,126
    14,090
    3,238
    Teachaaa
    Jinan, China

    "WEP key"...hmm

    Probably the TV doesn't support WEP encrypted WiFi, and is refusing to connect. Quite a few modern devices don't.

    See about changing your WiFi network over to WPA or WPA2. If it's a really old WiFi router you might have to replace it.

    WEP has been deprecated for number of years now as it's completely insecure.
     
    #5 mikedt, Jun 16, 2016
    Last edited: Jun 16, 2016
    WalwRafii likes this.
  6. Andrew Cole

    Andrew Cole Android Enthusiast
    Rank:
    None
    Points:
    108
    Posts:
    463
    Joined:
    Jun 12, 2016

    Jun 12, 2016
    463
    158
    108
    Male
    Yes, that's a possibility... but the screenshot from the original poster suggests that that the device is looking for a WEP key.

    Does your router have a WPS button?
    (This will be an unmarked button somewhere on your router that appears to do nothing!)
    If you're lucky there may be a WPS logo near it.
    If it does, you're in luck. The TV will do all the password work for you when you press this button.

    If this doesn't work on your TV under the network settings hit SCAN then STANDARD...

    If you have WEP security encryption, the TV asks for the WEP encryption key in hexadecimal numbers.
    Find this hexadecimal key in the router software on your PC.
    Write down the first key of the WEP keys list and enter it on TV with the remote control.
    If the security key is accepted, the TV is connected with the wireless router.

    I hope this helps...
     
  7. svim

    svim Android Expert
    Rank:
     #42
    Points:
    608
    Posts:
    3,995
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,995
    3,028
    608
    Illinois
  8. Andrew Cole

    Andrew Cole Android Enthusiast
    Rank:
    None
    Points:
    108
    Posts:
    463
    Joined:
    Jun 12, 2016

    Jun 12, 2016
    463
    158
    108
    Male
    Some devices can only be connected through the WPS button.
    My Samsung laser printer is an example.

    But, yes... if you don't use this feature then it's a good idea to disable it if you can... or at least disable the 'pin number' feature associated with WPS.
     
  9. svim

    svim Android Expert
    Rank:
     #42
    Points:
    608
    Posts:
    3,995
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,995
    3,028
    608
    Illinois
    I never heard of a situation where WPS is a requirement. Curious what model Samsung printer are you referring to?
     
  10. Andrew Cole

    Andrew Cole Android Enthusiast
    Rank:
    None
    Points:
    108
    Posts:
    463
    Joined:
    Jun 12, 2016

    Jun 12, 2016
    463
    158
    108
    Male
    SAMSUNG Color SL-C460W
     
  11. svim

    svim Android Expert
    Rank:
     #42
    Points:
    608
    Posts:
    3,995
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,995
    3,028
    608
    Illinois
  12. Andrew Cole

    Andrew Cole Android Enthusiast
    Rank:
    None
    Points:
    108
    Posts:
    463
    Joined:
    Jun 12, 2016

    Jun 12, 2016
    463
    158
    108
    Male
    Yes... that's true... if the printer had come with a computer I could have hooked them both up with a USB cable to eventually get my WiFi sorted out. Or I could have borrowed a computer, set it up at the printer location then hooked them together via a USB cable and done the same thing.

    There are work-arounds to most tech problems. Unfortunately, getting WiFi on my printer is only possible via the WPS button unless I want to go to an extraordinary amount of inconvenience.

    In the end, pressing the button on the printer turned out to be the best option!

    Yes, you're right... it's a good machine and has worked out well... but a tad expensive to run if you do a lot of printing.
    I don't so it's a good option for me.

    Cheers...
     
  13. WalwRafii

    WalwRafii Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Jun 5, 2016

    Jun 5, 2016
    2
    2
    6
    Male
    Of course I was connecting to the right WiFi ID, it was WEP that was the problem. Since I didnt wanted to change my WIFI to that i put a cable on the walls and roof to connect the TV to the network wired.

    Thanks for the help everyone.
     
    Andrew Cole and mikedt like this.
  14. mikedt

    mikedt 你好
    Rank:
     #4
    Points:
    3,238
    Posts:
    25,126
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    25,126
    14,090
    3,238
    Teachaaa
    Jinan, China
    Thought it might be WEP was the problem. I've seen devices that refuse or can't connect to WEP, including a newish Windows 10 tablet.

    You might want to change to a secure encryption. WEP is not secure at all and can be cracked in less than a minute using readily available tools.

    If it's a network that your guest house clients use, they might have difficulties with it as well.
     
    #14 mikedt, Jun 17, 2016
    Last edited: Jun 17, 2016
    svim likes this.

Share This Page

Loading...