1. Check out our companion app, Forums for Android! Download from Google Play

Support Can't delete files from /mnt/sdcard or write to

Discussion in 'Android Devices' started by rustafar, Dec 24, 2011.

  1. rustafar

    rustafar Member
    Thread Starter
    15

    Dec 12, 2011
    22
    0
    15
    Hope someone can help.
    I Can't delete files from /mnt/sdcard or write to it.
    just happened today. Any suggestions ??

    Russ
     

    Advertisement

  2. dart16

    dart16 Well-Known Member
    93

    May 9, 2011
    632
    100
    93
    As the actual location of /mnt/sdcard changes depending on the firmware you are using, I will make an assumption that you are referring to the internal tf card.
    This is a known problem, your firmware has become corrupted and the internal tf card has gone read only. The only fix for this appears to be removing the internal card and formatting it externally. Most people opt for changing the card for a better quality/bigger one. (or return the tablet as faulty).

    What model number is your tablet? (menu/settings/about device/model number) as you need to download the firmware first (if there is one available)
     
  3. rustafar

    rustafar Member
    Thread Starter
    15

    Dec 12, 2011
    22
    0
    15
    My Tab is a Disco10,
    I did some searching and found this fix through the terminal Emulator:
    \system\bin\fsck_msdos -y \dev\block\vold\179:17. than reboot.
    It worked. I'm still going to install a bigger tf card in it,prob a 16gb.
    I already have Tim rom 6a downloaded just incase any problems accur.
    Hope you had a great Christmas and have a great new year.
    Russ.
     
  4. dart16

    dart16 Well-Known Member
    93

    May 9, 2011
    632
    100
    93
    OK Russ, thanks for the info.
    When you fit the bigger card you will obviously have to re-flash the tablet and the partitioning of the card is done automatically. Tims 6a will alter the drive assignments from what you have at the moment, which is presumably why your fsck_msdos command doesn't work on my FT3.....
     
  5. Rabid1

    Rabid1 Well-Known Member
    53

    Jul 15, 2011
    403
    68
    53

    keep an eye on it. If you are going to use a bigger card it is probably not an issue, but a lot of people have the problem come back.
     
  6. rustafar

    rustafar Member
    Thread Starter
    15

    Dec 12, 2011
    22
    0
    15
    Thanks Rabid1, I did buy my tab from someone locally off ebay It came with a warrenty.
    might call him.
     
  7. awolfend

    awolfend New Member
    5

    Jul 13, 2012
    1
    0
    5
    Having same issue with galaxy s3. How would I find the appropriate device to fsck.
     
  8. aestrada

    aestrada New Member
    5

    Aug 30, 2012
    1
    0
    5
    Hi all. I have a flytouch 3 superpad III disco10 Tim6a 5v charger model. The original 8 gb no brand internal sdcard starts saying that /mnt/sdcard folder was only read mode, if I recharges firmware with power-bach button trick, the problem solves, but returns after a few minites, the same if I reflash. So I changed internal microsd for a new Samsung Class10 16gb, reflashed Tim6a, and works flawlessly for many weeks, then suddenly problems became as usual as was. I solved partially with a remount of /mnt/sdcard folder in terminal mode:

    mount -o remount rw /mnt/sdcard

    But the problem returns after a few second or minutes. Th other solution I have done is based in this post, but with a different point of vold (and slash position!!!):

    /system/bin/fsck_msdos -y /dev/block/vold/179:6

    This last solution is more time fail safe, at least 10 minutes free of sdcard ro error, and lasting....
    Thanks all of you. Good work.
     

Share This Page

Loading...