1. Download our Official Android App: Forums for Android!

General Can't dial numbers, get "Hangouts"?

Discussion in 'Android Devices' started by secretsquirrel, May 21, 2016.

  1. secretsquirrel

    secretsquirrel Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    174
    Joined:
    Apr 13, 2011

    Apr 13, 2011
    174
    17
    58
    Male
    copywriter
    Borneo
    I swear, Google and Samsung seem to get together to deliberately pss me off..

    Tried phoning a shop today, checked their details online, tapped the number and...

    ... no dial tone, no attempt at ringing.

    Just some dumbass "Hangouts" screen, where Google demanded the phone number I just tapped on?

    Long-pressing gets me a "copy link address?" - it's not a link, it's a NUMBER. You know, a phone number, for my phone, so I can phone it, and have a phone call.

    I hate my phone but at least it used to be capable of actually phoning. I had to send the shop a stinking email instead.

    "Hello. Are you open today, seeing as it's a Chinese holiday? Cheers."

    FFS... No, they never answered. I dunno if they're shut, or just don't check their emails on Saturday afternoons...

    I can't figure out where in the settings I can get rid of this hangouts garbage and turn the, you know, PHONE of my phone back on?
     

    Advertisement

  2. secretsquirrel

    secretsquirrel Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    174
    Joined:
    Apr 13, 2011

    Apr 13, 2011
    174
    17
    58
    Male
    copywriter
    Borneo
    (Yes I've signed out -not that I recall ever signing in - and have disabled the app - but still it keeps opening?)

    I can't even copy and paste the number into the normal dialer, as the phone's dialer seems incapable of accepting anything pasted now?
     
  3. wunay

    wunay Android Enthusiast
    Rank:
    None
    Points:
    48
    Posts:
    338
    Joined:
    Jan 18, 2011

    Jan 18, 2011
    338
    21
    48
    Staffordshire, UK
    Is it not time that you moved on?.
    Hating the S6 as much as you do I do not understand why you keep ranting on here and obtain another phone.
     
  4. secretsquirrel

    secretsquirrel Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    174
    Joined:
    Apr 13, 2011

    Apr 13, 2011
    174
    17
    58
    Male
    copywriter
    Borneo
    3 words...

    2 year contract.

    So, about using this POS to make a phone call?
     
  5. Snakeyeskm

    Snakeyeskm Android Expert
    Rank:
     #82
    Points:
    293
    Posts:
    1,652
    Joined:
    Apr 8, 2014

    Apr 8, 2014
    1,652
    846
    293
    Male
    Investment Banking
    US
    Have you tried resetting your system cache. If that doesn't work, download (free) a package disabler from Google play and disable hangouts hangouts.

    A blowtorch and/or a sledgehammer could also solve this problem.
     
    mikedt likes this.
  6. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #2
    Points:
    4,238
    Posts:
    36,788
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    36,788
    35,040
    4,238
    Male
    IT
    Pennsylvania
    It sounds like you inadvertently set the default for phone links to open in Hangouts. You could try going to menu>settings>apps and find Hangouts and clear defaults. Or you can go to menu>settings>apps and tap on the menu and reset all app preferences. That way when you tap on a phone number it should give you the choice of which app to use to open it.
     
    mikedt likes this.
  7. mikedt

    mikedt 你好
    Rank:
     #6
    Points:
    2,238
    Posts:
    24,619
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    24,619
    13,625
    2,238
    Teachaaa
    Jinan, China
    No, it's not a Chinese holiday this week, I can assure you first hand of that.

    Sound like the default app for phone calls might have got changed, presumably to Hangouts. If you go into settings > apps, should be able to reset it back to defaults.
     
  8. secretsquirrel

    secretsquirrel Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    174
    Joined:
    Apr 13, 2011

    Apr 13, 2011
    174
    17
    58
    Male
    copywriter
    Borneo
    I live on the island of Borneo (part of Malaysia) and yep, was a Chinese holiday on Saturday.

    I am thinking this might be a browser issue, because the app is already disabled, the problem is tapping a phone number opens a link (not an app per se) to that hangouts cr*p.

    The browser is Opera.

    Lemme try downloading something else...

    Mmm, with Boat browser it opens the phone as normal.

    Ah.

    On this occasion it's my fault, I goofed. I despise this phone so much I just blamed the phone, without checking if it was a browser update (I am so done with "updates!")

    I still hate the phone but can't blame it for this.

    The opera browser is generally very good but the settings are extremely spartan; nothing in there about this. Just shoved in my face as an "update" I guess.

    I never intended turning into a grumpy old man, but this sh&t phone and all these "updates" screwing things up are turning me into one...



    Sorry
     
  9. mikedt

    mikedt 你好
    Rank:
     #6
    Points:
    2,238
    Posts:
    24,619
    Joined:
    Sep 22, 2010

    Sep 22, 2010
    24,619
    13,625
    2,238
    Teachaaa
    Jinan, China
    I'm actually in China, Shandong Province to be exact, and there was no Chinese holiday here on Saturday. :p

    The next Chinese holiday is in June, Dragon Boat Festival.
     

Samsung Galaxy S6

The Samsung Galaxy S6 launched in 2015 as the company's flagship. It features a 5.1-inch screen with 2560 x 1440 resolution, 3GB of RAM, 32GB of storage, and an impressive 16 megapixel camera.

Share This Page

Loading...