1. Download our Official Android App: Forums for Android!

Support Can't dismiss/snooze alarm if it goes off while on a call

Discussion in 'Android Devices' started by grafc, Feb 17, 2011.

  1. grafc

    grafc Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    16
    Joined:
    May 27, 2010

    May 27, 2010
    16
    0
    15
    I noticed recently that if the Eris alarm (set to vibrate) goes off while on a call I cannot dismiss or snooze it. Even after the call ends the phone continues to vibrate until I rebooted it. I tried all of the dismiss options with no luck. I'm curious if anyone else has this issue?
     

    Advertisement

  2. mc48

    mc48 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    480
    Joined:
    Jan 17, 2010

    Jan 17, 2010
    480
    36
    43
    so. east, usa
    Anyone have a clue about this? I have had the same problem. I have one alarm set for each day (different times each day for when I am required to answer the phone at work) through the stock clock alarms. The alarms go off fine but lately more times than not the option to dismiss or snooze doesn't come up so there is no easy way to dismiss the alarm notification. This seems to happen most often when I happen to be doing another task on my phone like grafc said above but sometimes it happens even when no other operation is going on. Sometimes I can go to running services and stop the alarm from there, but often even that doesn't work and I end up having to reboot my phone to get the alarm to stop.

    Is this a known bug and is there some kind of work around to it? I'd hate to have to download another app to use as I like the stock one except for this bug.

    edit: other than running services I don't use a task killer
     
  3. doogald

    doogald Extreme Android User
    Rank:
     #46
    Points:
    483
    Posts:
    6,694
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,694
    1,929
    483
    This is my biggest frustration with the Eris, and it was the reason why I rooted the phone last year - it drove me crazy. Usually the ability to dismiss or snooze comes up the second time the reminder fires.

    One thing that helped was to change the notification to an alert. In the Calendar app, menu->settings (it may be menu->more->settings) and change Alerts & notifications from the stock "status bar notification" to "alert". It may also help to restart the phone.
     
  4. mc48

    mc48 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    480
    Joined:
    Jan 17, 2010

    Jan 17, 2010
    480
    36
    43
    so. east, usa
    thanks for the response doogald. I changed my settings in the calendar app to alert from status bar notification and will see if that helps. I am curious though, you said you rooted to fix this problem. Did it? I have been rooted for awhile and I still get this bug.
     
  5. doogald

    doogald Extreme Android User
    Rank:
     #46
    Points:
    483
    Posts:
    6,694
    Joined:
    Jan 7, 2010

    Jan 7, 2010
    6,694
    1,929
    483
    It's true that just rooting does not necessarily solve this problem, but I have had no problem with this running any of the Cyanogen Froyo or Gingerbread ROMs that I have installed. Unfortunately, if Sense is required, I think that you are stuck with this.(Also, if you need the feature that calendar event notifications ring every few minutes until you dismiss them, I think that these will not help, either, as they only fire off once.) Also note that the latest March 2011 OTA update did not fix this issue.

    I do have to say, though, that the alert setting helped a lot. It should pop a notification in your notification bar (it looks like a numeral 1 within a square) that lets you get to the place to dismiss the notification.
     
    mc48 likes this.

Share This Page

Loading...