1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't download anything from android market using wifi

Discussion in 'Android Apps & Games' started by ryan23, Dec 22, 2009.

  1. ryan23

    ryan23 Lurker
    Thread Starter

    I've been trying to use wifi to download apps from the market but it always says starting download and then never does anything else?
    Any suggestions?
     


  2. nightelvesreasy

    nightelvesreasy Well-Known Member

    i have found this not really a problem, just a annoyance, i download all my apps/games using wifi cause of my area im in, it does download, just takes anywhere from 10-20 seconds for the download to start, not sure why the delay, but it does download
     
  3. speedracr13

    speedracr13 Newbie

    mine won't download when im on the wifi connection at work, but it works fine when im on my wifi at home. must have something to do with the network settings. im not technical enough to point you in the right direction to fix it though.
     
  4. pbwhite

    pbwhite Member

    Try rebooting the phone. I've had that happen in the market on several occasions both on 3G and wi-fi. A reboot has always solved the issue for me.
     
  5. chrlswltrs

    chrlswltrs Extreme Android User

    I only use wifi because I get almost no phone signal at my house. I will get the message that my app will be downloaded but nothing happens immediately. Within a few seconds to 1 minute the download will start, you just have to give it some time.
     
  6. ItalianScallion

    ItalianScallion Well-Known Member

    I've had this issue crop up a few times - it comes and goes. Switching over to VZW's connection usually prompts the download for me.
     
  7. ryan23

    ryan23 Lurker
    Thread Starter

    I have tried all these things and it just stays at the starting download screen and never moves
     
  8. ryan23

    ryan23 Lurker
    Thread Starter

    and the reason i'm using wifi is becasue i dont get any reception where i am
     
  9. craighwk

    craighwk Android Enthusiast

    I've had the same problem at home. Can't download anything through the Market, nor will podcasts download in Doggcatcher. However, I am able to browse, so I know the phone is connected to my WiFI, but other types of activities don't work.

    If I turn off WiFi and go to 3G, all is fine and dandy. Quite annoying.
     
  10. ItalianScallion

    ItalianScallion Well-Known Member

    This issue is one more reason (albeit a minor one) why it would be nice to have a desktop client for the Market - users could still download apps and "hard" sync in the event they're having connectivity issues with their devices.
     
  11. ryan23

    ryan23 Lurker
    Thread Starter

    is this just something verizon hasnt perfected yet and might have an update to fix or is it jsut my phone?
     
  12. craighwk

    craighwk Android Enthusiast

    I don't think it's an issue specific to the phone. I've seen people with other phones (Hero) having similar issues. Something with the way the system's WiFi "code" operates with the marketplace and the certain types of routers.

    Who knows though.
     
  13. Carnot Engine

    Carnot Engine Lurker

    Sorry to bump an older thread but I am having the SAME problem

    nothing is downloading, only getting starting download prompt.



    i finally got it to work for ~20 seconds when I opened a new google account.
     
  14. craighwk

    craighwk Android Enthusiast

    Kinda odd that there's no solution for this problem or a larger group of people having it. It got to the point where I don't even bother enabling WiFi any more.
     
  15. traceyvs

    traceyvs Lurker

    I'm having the same issue. But it's recent. Before this week, WiFi was the only way I downloaded apps. Has anyone found a fix?
     
  16. &roid

    &roid Well-Known Member

    I had never tried to download from the market while using wifi, I hardly use wifi as it is, I just tried it to see what would happen, and I downloaded Advanced Task Killer, and that new Google app, Gestures, both downloaded instantly, no delay, the apps were running within 10 seconds of starting the download.
    I'm running stock, unrooted.
     
  17. williestylez

    williestylez Lurker

    Just to let you all know, it is more than likely a Firewall issue at either your router level, or your ISP. That's how one guy had an issue with his work WIFI, but not at home.

    If you have control of your WIFI (or gateway) router, create a rule to allow a destination port of 5228 (as described here Ip port used by Android market store ? - Android Market Help)

    You shouldn't have any further issues connecting to Android market over WIFI... unless of course your ISP is blocking traffic to that port, then you're SCREWED! LOL! HTH! Good luck!
     
  18. AngryHatter

    AngryHatter Android Expert

    No issues since March last year!:D
     
  19. There are other Markets out there that let work just as fast on WiFi as they do on data.
     
  20. Chuck1906

    Chuck1906 Android Enthusiast

    My phone has been on wifi mode for the last few days and I have downloaded 2-3 apps with it on. Maybe your wifi strength is not that great or something.
     
  21. pesser

    pesser Lurker

    bump iam getting this too :mad::thinking:
     
  22. kmf

    kmf Android Enthusiast

    No problems downloading with my home wifi. Samsung Mesmerize 2.2.1 (USCC)
     
  23. jayde66

    jayde66 Lurker

    Im having the same problem except it worked fine up until a week ago so I reset phone to see if that would help but still the same thing 'download starting' yet never does. very frustrating.
     
  24. jgnornb

    jgnornb Lurker

    I had the same problem. Unable to download through work WIFI and not enough reception in my "walled" office. I turned off my handset wifi and walked out to the nearest window and tried it again, now the download worked.
     
  25. Chuck4237

    Chuck4237 Lurker

    I had this same problem, even returned a tablet because of it. Another tablet acted the same - SOLVED!! The problem was in my router. I changed my firewall setting setting from typical to minimum and everything works great. The answer came from one of these boards. Thank to whoever wrote in.
     
Loading...
Similar Threads - Can't download anything
  1. grameswan
    Replies:
    0
    Views:
    65
  2. androidBum
    Replies:
    6
    Views:
    172
  3. Joel Pietrangelo
    Replies:
    5
    Views:
    205
  4. pasinduvibahaliyanage
    Replies:
    12
    Views:
    386
  5. dorlow
    Replies:
    6
    Views:
    565
  6. TheRealLiam
    Replies:
    12
    Views:
    1,124
  7. rdoty
    Replies:
    4
    Views:
    7,585
  8. circlebecky
    Replies:
    7
    Views:
    1,630
  9. mehmeilhan58
    Replies:
    3
    Views:
    727
  10. loveallpandas
    Replies:
    0
    Views:
    377

Share This Page

Loading...