1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't Download From Google Play (Error RPC:S-5:AEC-0)

Discussion in 'Android Devices' started by RichSz, Jul 25, 2013.

  1. RichSz

    RichSz Not Entitled
    Thread Starter

    This problem is solved but I wanted to document it here in case anyone else had the same issue.

    Yesterday, I decided I was too impatient to wait for 4.3 to download on its own so I remembered the trick where you clear data from Google Services Framework and make the tablet recheck the server for the new firmware. Because I was feeling clever and too cool for school, I went into my Settings/Apps/All and cleared the data on Google Services Framework, or so I thought. I actually did it on the Google Play Services accidentally. Crap. OK, no biggie I fixed my mistake by clearing the correct data and checked for the update. Nope. Oh well.

    Next time I tried installing anything from Google Play, I was greeted with a server error RPC:S-5:AEC-0. Crap. I couldn't update existing apps or install new ones. This bugged me so I did a Google search and found this:

    Android Fix: "RPC:S-5:AEC-0" error while updating or installing apps Google Play Store | AppsLova

    Method 1:

    • Open system settings
    • Go to Applications (or Apps) >> All
    • From all apps select Google Play Store >> Clear Cache and Uninstall updates
    • Again, from All>>Download Manager >> Clear Cache and Data
    • Finally, All >> Google Services Framework >> Clear Cache and Data
    • Now, rerun Google play store.

    Method 2:

    • Go to system settings>> Accounts>>Google>>remove your Gmail account
    • Now from settings>>Apps>>All> Force stop, Clear data and cache for Google Play Store, Google Service Framework and Download Manager (like in method 1)
    • Now again go to settings>> Accounts>>Google>>Add your gmail account
    • Restart your android and then accept all the Google terms and setup Google settings
    • Rerun Google Play Store and update or install your app.


    There are two methods in there and Method 1 seems pretty easy so I tried that. No joy. I had to reboot because Google Play was force closing and still had no success. On to Method 2 which involved removing your Google Account from the tablet and then re-adding it. I wasn't happy doing that but it didn't seem to delete anything unrecoverable and better yet it worked!

    Interestingly Google Play hasn't updated to the latest version and I find the old one so much nicer to use, but that's another thread on another day.

    So that's my yarn. I'm not positive I caused this issue by clearing the wrong data or if it was just a coincidence but I feel it right to document in case there is a correlation.
     

    Advertisement

  2. MeatLoafT

    MeatLoafT Member

    I have one question... Did you get 4.3? ;-)
     
  3. alexward

    alexward Newbie

    Tried method one.... No joy.
    Was going to try method two, but I can't find where to remove my Google account. There doesn't seem to be an option for this on my N4!!
     
  4. Hoosiermama

    Hoosiermama Well-Known Member

    I had the same problem this morning. Method 1 didn't work for me, but two did. Thank you!
     
    RichSz likes this.
  5. sparksd

    sparksd Well-Known Member

    I had the same problem for the same reason and deleting my Google account and recreating it was enough to clear it up - I didn't have to clear data or restart.
     
  6. Dolmangar

    Dolmangar Android Enthusiast

    Method 2 worked for me after 1 didn't.

    I also tried just adding a second (existing) google account I had to see if that would fix it. It didn't. I had to remove and re-add the account.

    As long as you're got your account set to backup you shouldn't loose a thing.
     
  7. Dolmangar

    Dolmangar Android Enthusiast

    Settings > Accounts section > Select Google > Select the account with the Sync icon on the left > From the Menu (three vertical dots top right) > Remove Account.

    It's not simple to find unless you know it's there - Good Luck.
     
    RichSz likes this.
  8. Shocky

    Shocky On Probation

    Tried clearing the cache and its still giving me the error, really don't want to try a factory reset.

    Anyone know how to fix this?

    EDIT: Fixed, if anyone else has this problem you need to remove your Google account, then start Google Play and sign in again. That will remove the error when downloading apps.
     
    blackpent likes this.
  9. Thank you so much for your help. I had to use method 2.

    I first tried Google Tech Support number for my Nexus 7 2012 edition.

    I was first told that 4.3 isn't compatible with the 2012 edition. I told her it was. She put me on hold and while I was waiting I typed in the error code and found this site.

    She came back and said it was a known issue and they don't have a fix for it.
    They will contact me when they do.

    Your two methods took me less than 5 minutes for both and the second worked perfectly.

    Thanks again for the help!
     
    Deleted User likes this.
  10. nickdalzell

    nickdalzell Android Expert

    Remove and readd your Google account. Clearing framework data causes this and does NOT help update faster. It even seems to muck up the "last update checked" date and claims it last checked in 12-31-1969 until you do the above and check again, which says 4.2.2 is the latest and fixes the check date.
     
  11. RichSz

    RichSz Not Entitled
    Thread Starter

    First of all welcome to AndroidForums!

    Second, it's excellent to hear that it worked out for you! It really stinks when something simple but vital doesn't work.
     
  12. Modman

    Modman Android Enthusiast

    Ever since updating to 4.3 I have been getting the RPC error and cannot install or update any apps on my default profile under Google play. I could work around it by using an alternative profile. Its just real annoying to reinstall everything under another profile. From experience I've had this happen before left it alone used an alternate user profile to install new apps and eventually it went away by itself then I deleted second user. Why hasn't Google fixed this annoying bug? This happens frequently when you try to force an ota. Has happened to me also after a failed install.
     
  13. Thanks for the welcome and thanks again for the quick fix.
     
  14. Modman

    Modman Android Enthusiast

    Method 1 does not work.
    And if my primary account has the issue I do not think I can remove it without hard resetting the tablet.
    Found the tab removed my primary account and it still doesnt work
     
  15. Modman

    Modman Android Enthusiast

    I seriously think if you wait a while. I waited approximately two days this stupid RPC error goes away by itself.
    I also created another user and synchronized it and when the owner user started working again I deleted it.
     
  16. kalda01

    kalda01 Newbie

    I did this a few days ago (removing/adding my account) and the problem was fixed until today when it re-appeared.
    Any ideas how to fix permanently ?
     
  17. Modman

    Modman Android Enthusiast

    Mine always disappeared after a while and doesn't return till next ota
     
  18. sadatoni

    sadatoni Lurker

    Also for me, method 1 didn't work, method 2 did. I was working on stopping the massive battery drain I get when at work (it doesn't happen at home, odd), cleared out of bunch of things, and then couldn't do downloads.

    BTW, google hangouts was my battery drainer. It's gone now :)
     
  19. Markdek

    Markdek Newbie

    Method 2, for me, only fixed "most" of the downloads/installed....there were a couple that still required a vpn solution.

    This has the be the most stupid bug of an OS/Cloud system.....really, what does using wifi have to do w/ the ability to download apps, and w/ all these different error messages.
     
  20. jwhite73

    jwhite73 Lurker

    After receiving this error, I went into settings, scrolled down and unchecked "use password to restrict purchases". This fixed the problem for me.
     
  21. justanotherguy

    justanotherguy Android Enthusiast

    I tried both methods...Nothing.
    But since I have 5 accounts on my phone I deleted them all.
    Installed my 'primary' account and DL'ed my game, so far no problems...
    I then re-installed the other accounts...
    Very annoying...
     
Loading...

Share This Page

Loading...