1. Download our Official Android App: Forums for Android!

Apps Can't extends from MapActivity

Discussion in 'Android Development' started by sw22, Sep 25, 2010.

  1. sw22

    sw22 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Sep 14, 2010

    Sep 14, 2010
    7
    0
    5
    Hi,
    Im sorry but Im lost when I want to extends from MapActivity. I have followed 3 times this tutorial:
    Using Google Maps in Android | mobiForge
    and I can't do these type of imports:
    Code (Text):
    1. import com.google.android.maps.MapActivity
    Imports cannot be resolved
    I have found the same type of tutorial several times but there are no other particular explanation for my problem.

    I have installed all packages in eclipse (in Windows>Android sdk...), I develop for Android 2.2.

    Thanks
     

    Advertisement

  2. dima1109

    dima1109 Member
    Rank:
    None
    Points:
    15
    Posts:
    36
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    36
    0
    15
    Try making sure the Build Target of your project is "Google APIs" level 8, not "Android 2.2".
     
  3. sw22

    sw22 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Sep 14, 2010

    Sep 14, 2010
    7
    0
    5
    ah, that's true! It's not mentioned in the tutorial. Thanks!
     

Share This Page

Loading...