Can't fix Bootloop on Nexus 4


Hi, sorry if I have a bad grammar, I'm doing my best writing this :)

I have an old Nexus 4, it used to work fine, honestly one of my best phones I've tested... But then after a while time I bought a Oneplus 2, so I selled my Nexus 4 to a friend, few weeks later he told me that one morning when he tried to power on the Nexus it got stuck on Bootloop without doing weird things like exploring the recovery and these things, he even don't know about that, I tried to fix it by all possible ways and nothing... I flashed via TWRP the stock rom many times, even a custom ROM and nothing, I tried to wipe data via TWRP and stock Recovery many times too and nothing.
The weird thing here is that my Nexus 4 was in perfect conditions, the only issue that it had was his battery, short battery life and some unusual times it used to mark the common Red Light.

In short terms, can't leave bootloop, but can boot into ADB, Recovery, Download mode. Even tried to flash ROMS and wipe data but still in bootloop.

Is my cellphone totally dead?

Hope you can help me.