1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't flash any ROM via CWM recovery - stuck on Samsung logo

Discussion in 'Android Devices' started by yandere, Apr 20, 2012.

  1. yandere

    yandere Lurker
    Thread Starter

    Hello guys.. I'm female and not-so-new at rooting.

    Since I belong to the folk that loved TW in the beginning, but came to absolutely despise it after ICS, I rooted and tried to install some custom ROMs. They could never satisfy me so I kept testing, until I encountered a severe problem.

    Whenever I flash a ROM via CWM recovery, it finishes in 5-10 seconds, being stuck on the Samsung logo after reboot.

    It is driving me to the point of insanity. I tried about 10 ROMS (MIUI, various ICS ROMs etc), but all have the same problem.

    The only ROM I can flash is CM9. But that is via Odin.

    It's strange that CWM won't properly install any custom ROM, yet Odin will. :mad:
    But there are not so many ROMs flashable via Odin and I want to flash the WIUI ROM which I absolutely hated in the beginning (because it resembles the iPhone too much), but came to love it after seeing it on my friend's.. :(

    I tried many kernels (CF-Root, Siyah, Redpill etc.), all with custom CWM recoveries, but no luck.

    Then did some research on XDA and other sites where folks like me had similar problems, and I was thinking that maybe my bootloader got messed up due to the flashes.

    So I flashed the XXKI3 3-part firmware with Bootloader, .PIT-file and re-partition ticked, it passed and worked like a charm via Odin and I hoped me problems would finally be resolved. But no.

    I re-root the device, re-download my favourite ROM (WIUI), put it on my SD-card, boot into CWM, but the same problem arises every time. After doing all the wipes, I try to install WIUI (or any other ROM) but it finishes in 5-10 seconds and leaves me stuck on the Samsung logo :mad:

    I try flashing it twice (like CM7), but no luck again.

    I'm running outta options of what to try :(

    Can a kind soul please help me out?

    1. Download the Forums for Android™ app!


  2. Hawker

    Hawker Android Expert

    Firstly if you don't like TW you don't have to root to come off it. There are many excellent launchers available such as Go Launcher, Launcher Pro, SPB Shell to name but a few.
    Bit concerned about you repartitioning. This isn't usually needed, so not sure if this may have done something untoward.
    For your boot loops, first thing to try is to boot into cwm recovery and wipe cache and dalvik cache.
    If this doesn't work, try a factory reset and re-root with cf-root.
  3. ironass

    ironass Extreme Android User


    I would never recommend playing around with the Re-Partition file normally, unless there is a very good reason and you know exactly what you are doing as it can lead to all sorts of problems. :ahhhhh:

    The bootloader and .pit file are closely linked and if you muck up the PIT you also muck up the bootloader. See here:-

    [RAM] S2 Partitioning of RAM - xda-developers
  4. Acid Twin

    Acid Twin Newbie

    This has happened to me a few times,

    For me it seems to occur when using some modified versions of CWMR.

    Two things have fixed this for me:

    1: Flash CheckRom, rebooting the phone back into recovery (which changes the CWMR version for me) and then doing a manual full wipe and flashing your desired Rom.

    2: (Sometimes had to be done AFTER step one or nanroid restore wont work, I think reflashing checkrom fixes some permission issues??) Restoring my original CF-Root nanroid back up, booting into recovery afterwards, wipe and flash desired Rom.

    Then the ROM suddenly installs correctly again, with the install bar during ROM flash reappearing and it taking the correct amount of time.

    The only deviation from this was when I flashed AndysRom; that got stuck on his custom boot logo for 20 minutes, but I turned the phone off then on and is booted correctly. (For me has been the best of the ICS roms by a long shot, no scrolling issues etc)

    Hope the above helps :)

    yandere likes this.
  5. yandere

    yandere Lurker
    Thread Starter

    I'm confused a bit. I did step one as you said, but when I reboot into CWM and try to restore from Nandroid after flashing CheckRom again, it says "can't mount /sdcard" when trying to restore..

    Is there something I'm doing wrong?

    Edit: Nevermind, I had to choose "restore from INTERNAL sd card" :p

    Edit 2: Doesn't work :(

    It seems to be stuck at "flashing Modem" and then 2 seconds after it says "installation complete". ._.
  6. Hawker

    Hawker Android Expert

    What kernel and version did you use to perform your cwm backup?
    Try flashing th is same version on and retry the restore
  7. yandere

    yandere Lurker
    Thread Starter

    I used the one corresponding to my XXKI3 firmware.. CF-Root-SGS2_XX_OXA_KI3-v4.1-CWM4

    I used this firmware because it has the old bootloader.. I followed Phistacio's guide on XDA for unflashable SGSIIs with the XXKI3 firmware.
  8. EthanP

    EthanP Lurker

    I am having the exact same problem? nothing will flash correctly via cwm? did you find a solution?
  9. frost245

    frost245 Lurker

    Try to reinstall cwm after you flashed a rom, always
    works for me.

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date

Share This Page