1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't get a clean flash/restore.

Discussion in 'Android Devices' started by MusicAddict, Aug 22, 2012.

  1. MusicAddict

    MusicAddict Member
    Thread Starter

    Playing around with the "True Tablet UI" patch has been awesome. But, I wanted to go back to stock or play with CM10. I went to recovery to flash and every time I flash/restore I get the "Apps upgrading" dialog (happens to the table apps) then everything is screwed. No matter what I flash.

    I do a full data/factory wipe as well as cache/Dalvik/Battery. What else should I wipe for a proper clean system?

    If needed, can I mount the tablet from ClockworkMod Recovery?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. MusicAddict

    MusicAddict Member
    Thread Starter

    Can anyone point me to info that shows how make sure that the device fully wiped before a flash?
     
  3. colchiro

    colchiro Extreme Android User

    No need for a document. Every custom rom has similar instructions....

    format cache partition
    clear Dalvik cache
    and if coming from a different rom, format data partition (equivalent to factory reset).
    Then flash rom, and flash other required files... often Google Apps (gApps).

    First two steps (wiping both caches) are also sometimes called "dirty flash" and what a lot of us do when updating a rom to a slightly newer version.
     
    MusicAddict likes this.
  4. MusicAddict

    MusicAddict Member
    Thread Starter

    See, here's where this whole things makes me feel silly. I know these steps. Not the same order, but I've done them. (I usually use AmonRa on my EVO4G though)

    I get this after boot:
    "Android is upgrading..."
    "Optimising app * out of **"


    So there's something still hanging around or the "True Tablet UI" patch keeps being applied somehow from .zip. And I have no clue if I can mount the Nexus7 from recovery to delete the .zip patch.

    Thanx for the help. \m/
     
  5. colchiro

    colchiro Extreme Android User

    If you flashed gApps, you'll see some optimizing, but it won't be ** out of 100. It might only be a total of twenty-some apps that need optimizing.

    Plus, a lot of roms do include some stock apps too. :D
     
  6. MusicAddict

    MusicAddict Member
    Thread Starter

    It's 82 apps. I need to stop it from doing that because its whats causing the issues. It's doing it automatically. I cant control it.

    I gotta figure out a way to fix this somehow. Even if I can wipe the whole thing via the computer somehow.

    I can't do anything in the OS as it just keeps rebooting.

    Any info/suggestions are welcome.
     
  7. colchiro

    colchiro Extreme Android User

    Document exactly what you're doing and we'll take a look at it.

    Usually the biggest problem with looping with a new rom install is neglecting to wipe data.
     
  8. MusicAddict

    MusicAddict Member
    Thread Starter

    From ClockworkMod Recovery v6.0.1.0...
    I followed that to the letter. No matter what I try this patch continues to get applied. I might make a video of it to show the issue.

    EDIT: I do see now that when I try to do a "restore" I get: "Error while restoring /data!"
     
  9. MusicAddict

    MusicAddict Member
    Thread Starter

    While playing with things, if I toggled "signature verification" and then installed a ROM, would that throw things?

    I'm getting that "Error while restoring (or formatting) /data!" issue I see others reporting. grr.... I can't manually unmount /data either.

    It's looking like its a permissioning error of some sort.

    Screenshots of the logs attached.
     

    Attached Files:

  10. colchiro

    colchiro Extreme Android User

    What version of clockwork are you running? There were some issues with early version of v.6.

    If you can't resolve this you might have to return to stock and start over.
     
  11. MusicAddict

    MusicAddict Member
    Thread Starter

    v6.0.1.0 I could try a development build if you have links to those.

    I've been trying to start over but as the screenshots above show, I can properly get rid of things to flash anything usable. I can get to fastboot then use Nexus Root Toolkit to do a bit there. But even there it fails to do what I need.

    I need a way to plug it in without being in the OS (fastboot or a recovery) and nuke everything. Start from scratch.
     
  12. colchiro

    colchiro Extreme Android User

  13. slyd

    slyd Android Enthusiast

    Bad recovery? Maybe re download the recovery.
     
  14. MusicAddict

    MusicAddict Member
    Thread Starter

    I've tried via fastboot. Seems to have the same issues. It can't format /data.
    I've tried latest CWM and TWRP.


    I'll keep trying but at this point I'm losing hope.

    Can ADB be used if you can only connect through fastboot? ie: I can't boot into the OS to enable USB debugging.
     
  15. MusicAddict

    MusicAddict Member
    Thread Starter

    I got it fixed by flashing the stock user data image while in fastboot mode via NRT.

    Please close this thread.
     
  16. colchiro

    colchiro Extreme Android User

    Glad to here you got it fixed.
     
  17. rootbrain

    rootbrain Android Enthusiast

    I got this when flashed the motley kernel then cleared cache and dalvik. But everything came back fine.

    Rootbrain
     
Loading...
Similar Threads - Can't clean flash
  1. zelaine2
    Replies:
    3
    Views:
    365
  2. kwb4
    Replies:
    5
    Views:
    449
  3. gigglepot
    Replies:
    10
    Views:
    462
  4. lynxstch
    Replies:
    2
    Views:
    624
  5. Dennis ingate
    Replies:
    4
    Views:
    506
  6. LP93
    Replies:
    4
    Views:
    3,066
  7. Charles Chambers
    Replies:
    4
    Views:
    649
  8. sachertorte
    Replies:
    5
    Views:
    419
  9. behrprofl
    Replies:
    6
    Views:
    1,203
  10. syc0path
    Replies:
    3
    Views:
    1,061

Share This Page

Loading...