Root Can't get bluetooth to pair with CM7.1


Android Enthusiast
I'm new to CM7.1 and am getting VERY frustrated.

I'm trying to pair a Microsoft Bluetooth Notebook Mouse 5000 and/or my Freedom Pro Bluetooth Keyboard to my Evo 4g running CM7.1. I should point out that I have been able to pair my keyboard (using SPP, not HID) with my Evo running stock (rooted & unrooted) without a problem.

Right now, I can't pair either. I detect both devices, but when I try to pair with either one of them, I have to enter my pin. I enter the correct pin, but instead of pairing... it either does nothing (requiring I attempt to pair again), or it prompts to enter the pin again (and again and again and again).

I've tried a soft reboot. I've tried pairing the keyboard in SPP and HID, but I'm not getting anywhere.


(okay, trying to pair the keyboard again in HID... and it is now stuck "pairing" without doing anything else).

btw, maybe this has something to do with it... under Bluetooth, my device name is "SOUL". I've tried changing the name, but it keeps reverting back to SOUL. Could my bluetooth be reseting or something?

**** edited for progress********

Okay, I said FV<K it and hard reset my phone. I re-installed CM7.1 from scratch without GAPPS and bluetooth is working. Now, I gotta start reloading and rebuilding and see if it will still work. GRRRRRR.


Android Enthusiast
Thread starter
Okay... I reloaded GAPPS. The problem was apparently some bad information in my titanium backup files. I eliminated all data that dealt with bluetooth and uninstalled/reinstalled some apps. I finally got to rename my bluetooth from "SOUL" to whatever I wanted and have it stay there.

Unfortunately, I also got force closings on google processes about every ten seconds. I emptied all the google apps of their caches and force closed them and that finally did the trick (after numerous attempts at rebooting/reflashing GAPPS, etc).

So... I was able to pair my bluetooth mouse and keyboard. Unfortunately, the keyboard won't stay paired once I get a connection.

Getting the mouse or the keyboard to pair takes forever. They'll flash connected for a milisecond... then disconnect again.

Any ideas?!? I'm so damn close!!!!!


Android Enthusiast
Thread starter
I guess I should finish up this thread and tell how things turned out. I did a full factory reset,reloaded gapps, testing all along the way. The fix was not reloading data from my titanium backup. Losing all that info sucked, but bluetooth has been working great. I have syned my bluetooth mouse, keyboard, & wiimote with classic controller.

I am still having some issues with CM7.1, force closings on my launcher (vtl and adw launchers), problems with hdmwin not working consistently and causing headphone icon to stay on/screwing up audio until I reboot, the GPS flaw, etc.

Still, I am getting there.


Android Enthusiast
I have trouble with the bluetooth device I use - Motorola car speaker/MP3 streamer.

Basically, I have to turn on Bluetooth (it tries to connect to my Motorola but then never actually succeeds), turn it off, then turn it back on. It connects on the second time.

I have to do this every time. Very annoying


Well-Known Member
I ordered the Dell (Logitech) keyboard and mouse combo recommended in the ZDa thread mentioned above.

I was having everyone's problem is getting both the Dell keyboard and mouse to both work at the same time. Once you get one connected as an HID device and go to connect the other one, the first one disconnects. Some times even if you connect just one, it will disconnect.

However, what is working reliably together are my Stowaway ultraslim keyboard and Stowaway minimouse when I use "bluetooth keyboard easyconnect" (free in the market).

I can also get the Dell keyboard to work with my Stowaway mouse using bluetooth keyboard easyconnect. (Haven't tried it with the Dell mouse yet.)

But importantly, you need to follow the bluetooth keyboard easyconnect directions in the download page in the Market. (The app once in installed has virtually no help/instructions.

so,onOnce you get the KB and mouse paired (but probably not connected) in wireless settings, start bluetooth keyboard easyconnect. Select which ever device you want (both should show in the top dropdown box), and then click the icon to turn bluetooth off, and then restart it.

It will pair the devices again and while I have only run this for a day or so they seem to stay connected. If you haven't used one or the other for awhile, there may be a lag until it finds it, but then it is very responsive. Infact the mouse is too "responsive."

I have not yet installed the qwerty KB map, nor the mouse update mentioned in that XDA thread.

Has anyone made a better map for the Dell keyboard - perhaps getting the Fn keys to work?

I'm using HDMWin. Is FullHDMI better than HDMWin?

Is Savaged Zen out of action? I wanted to flash their kernel, and while their website is up it links to a mirror that does not have the files.