1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't get flash to work on Nexus 10 (Android 4.2)

Discussion in 'Android Devices' started by UNeverNo, Nov 22, 2012.

  1. UNeverNo

    UNeverNo Lurker
    Thread Starter

  2. UNeverNo

    UNeverNo Lurker
    Thread Starter

    Why? I don't want to develop anything.
  3. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    No need to head to XDA ;)

    I'll move this to the Nexus 10 section, the guys there should be in the best position to assist. :)
  4. Atma

    Atma Extreme Android User

    Welcome to the forums UNeverNo :hello:

    Try using Boat Browser and see if your flash works. If it doesn't, try this flash .apk. It is the latest version. I've used Boat Browser and the flash.apk to watch movies on Amazon streaming with my Nexus 10.
  5. Rcarnes91

    Rcarnes91 Android Enthusiast

    From what i have read boat browser is the only browser you can get flash working on with the nexus 10 I am sure smarter people then I, will get it working on other browsers in the future
    Atma likes this.
  6. tjreishus

    tjreishus Android Enthusiast

    I was able to flash to work on dolphin browser.
    breadnatty08 and Atma like this.
  7. peaches1998

    peaches1998 Newbie

    Would you be willing to share how you did this?


  8. Atma

    Atma Extreme Android User

    Download this version of Dolphin (link removed due to Dolphin's TOS policy) Its an older version that supports flash. There may be another that will but the newest one won't. At least it won't for me.
    breadnatty08 likes this.
  9. peaches1998

    peaches1998 Newbie

    I usually assume that the newest version has advantages over the older version as relates to the Dolphin browser.

    Other than the ability to use Flash in it, is there any downside or advantage to using it rather than the newest version I now use?

    And thanks to you, I now do use the Boat browser to watch Amazon Prime. Actually, Boat is very fast and intuitive and I enjoy using it as much as Dolphin.

  10. breadnatty08

    breadnatty08 pain rustique

    Peaches, I'm not sure what upgrades are in the newest version of Dolphin, but if you want to use Flash it's the only way.
    That's the same method I use on my N7 if I ever need Flash.
    Atma likes this.
  11. UNeverNo

    UNeverNo Lurker
    Thread Starter

    I already tried boat before (and now again with your apk) but it isn`t working for me.
    Any suggestions? Should I go for factory reset? Or root?
  12. Atma

    Atma Extreme Android User

    Rooting wouldn't really change the flash problem. I don't think a factory reset would either.

    Try opening Boat Browser, press the menu (3 little dots), select settings > page content settings > Enable Flash/plug-ins. Try setting it to always on if it isn't already.
  13. lucky013

    lucky013 Well-Known Member

    The Puffin Browser has Flash built in.
  14. UNeverNo

    UNeverNo Lurker
    Thread Starter

    Well all Nexus 10 should be the same - so there have to be a software issue with my device.
    I enabled it at my first try and double checked it now.
  15. Atma

    Atma Extreme Android User

    Hmm .. Have you rebooted your N10 lately?

    Maybe try uninstalling flash. Reinstall the .apk I posted. I'm not sure what could be stopping it from getting flash working. :thinking:

    I guess you could try a factory reset to see if that helps, but there's no guarantee it will.
  16. UNeverNo

    UNeverNo Lurker
    Thread Starter

    Do you talk about rebooting it holding the on/off-key? Did that a couple of times, reinstalled flash a couple of times by moving the app into trash (is there another way maybe in filesystem directly?)...
  17. Atma

    Atma Extreme Android User

    You can check in settings>applications>tap the all tab and uninstall flash player if it is still listed. Also check settings > security > device administrators, and check the box for 'unknown sources' if it isn't checked. Reinstall flash, close the browser if it is open, power off and then back on.
  18. UNeverNo

    UNeverNo Lurker
    Thread Starter

    Did this all a couple of times :(
    I tried it and it surprisingly worked (at least the advertising, but no article at all:()

    Can someone try to start any video here?: http://www.n24.de/mediathek/
  19. Atma

    Atma Extreme Android User

    Videos work for me. I'm sorry but I am out of ideas. :(

    The only thing I can think of you haven't tried is a factory reset.
  20. Steven58



    We're not allowed to post apk's without dev permission, even if it's freeware. So, I deleted the links. Thanks! :)

    Atma likes this.
  21. peaches1998

    peaches1998 Newbie

    My initial experience was the same until I installed Appinstaller from the app store. Once I opened it, the download was in there and it installed from the Appinstaller window.

    Now I can use Boat to watch Amazon Prime on Demand movies.

    Atma likes this.
  22. UNeverNo

    UNeverNo Lurker
    Thread Starter

    Factory reset helped, runs with firefox now :smokingsomb:

    ...and my wife is happy:)
    Atma likes this.
  23. Atma

    Atma Extreme Android User

    That's great. :congrats:

    Glad you finally got it working! :)
  24. mihalich

    mihalich Android Enthusiast


    I got flash working on my nexus 10 in two minutes with the boat browser.

    Go to XDA and go to the Nexus 10 general forum, and look for the article: how I got flash working on my nexus 10.

    In the OP, there's a flash apk, download that to your downloads folder on the sdcard. Then install it (make sure you have non market sources for apps in settings turned on.

    Then install the boat browser. In the Boat Browser settings turn the user agent to desktop, and set flash plugin to always on.

    Boom, i can now watch video on nbcnews.com. Genius.

    Ravenwjf likes this.
  25. Ravenwjf

    Ravenwjf Member

    Wow.....so I tried this......and every other suggestion and I just can't get flash to work. It's not a huge deal to me, especially since I am trying to get away from flash since it is not being supported on Android devices anymore (officially). I am shocked though that I can't get it to work. The only thing I haven't done is a factory reset, and I am not that worried about it to do that......yet. I haven't gotten my Titanium Backup up and running yet....maybe I will try it once I have a backup. At this point....it's the principle of the matter lol. I can unlock the bootloader, I can root, and I can download install ROMs and Kernals, but I can't get Flash to work????? LOL Anyway, good info, I will try it again at some point.

Share This Page