Can't get MP3's on phone to play


First, I've just put Froyo on so I am up to date. I've also just installed a 32g card, formatted it on the phone (twice now) and used Windows explorer to copy mp3's of my CD's over from my laptop to the phone in to a folder called Music a couple of different times to rule out copy issues with the same results. FYI I normally carry/listen to my tunes on my Zune, and keep them associated with Zune.

My problem is that when I look at the phone's properties in Explorer, I see that I've used about 3.9g used, yet when I look at the individual CD folders I see nothing near that size. the Music folder on the phone shows 36 folders,108 files but a size of only 548m. No other phone folder shows any substantial usage. When I browse to the folders, a few of them have mp3's, but almost all show as empty, 0 files. I know I copied files, I watched it happen. When I launch the music app it doesn't see any of the folders with 0 files. Some of the folders that show mp3 files play but most don't. I get an "unable to play this type of audio file" message on the phone yet all of the files are the same. I should note that before I put the 32g card in, I did a trial copy of about 4 CD's with the 8g card in and they played fine. I didn't bother copying any more since I knew that I was getting the 32g card.

Any thoughts? Does the phone have a problem with a 32g card?
First, I would re-format the sd card to rule that out. Keep in mind, obviously you will lose all data on the card.

Then try to copy the music again. I would try to copy one or two cd's at a time. Maybe the phone just wont transfer a large amount of data at once. Or it's possible one or more of the mp3's are corrupt, and messing up the transfer.


Thread starter
Yup, did that twice. I re-formatted twice on the phone. I've also copied the files to phone a couple of times to make sure that I have a good copy and I've also tried playing the files to see if they are corrupted in my computer-they are not. I just tried copying the mp3's directly to one of the 0 file CD folders on the card using the adapter and plugging the card directly into my laptop. They show up fine on my laptop but once back in the phone, it does not see that folder or the mp3's inside.


I was searching around the net for a solution to this or at least an announcement from android that it will limit it's support on MP3's... I had the same problem, but it seems you guys haven't solved it yet.

I did!

It involved a painful process of converting all 3,597 songs I have to .OGG, using a program called Xilisoft audio converter (it also cracks DRM protected M4A files to any music file format you want).

I don't know what happened. At first try, I had some music played into my android using ordinary MP3's I used before flawlessly, then I keep playing around with syncs (deleting, adding, deleting again, and adding again) because not all songs were copying... and then all of the sudden (and also after some few Firmware updates), all MP3s regardless of how they are transferred to the phone suddenly stopped working.

I was thinking a firmware update on the Android made some MP3 files not playable if it isn't purchased through the phone (As if Android is slowly becoming like iTunes).